Jump to content


Photo

Casting from mobile to shield doesn't work well


  • Please log in to reply
34 replies to this topic

#21 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 12 January 2020 - 04:18 PM

After more testing, this happens every time a remux is being done. I tried multiple files. So that's pretty much everything that doesn't have stereo AAC. Everything else appears to require audio transcoding, and every time that happens, it will play from the start, but if you skip forward or choose a chapter, playback freezes.



#22 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 01:39 AM

Oh boy, this is all messed up. I had the theory that most the audio tracks I was playing were actually supported by the chromecast in the shield. So I disabled the allow transcoding of audio option in the user settings, and tried again. I was correct. This time it direct played, and I could skip to any part of the movie and it would play correctly. So there are a few bad things happening, here.

1. These audio tracks shouldn't be being transcoded at all.

2. When they are transcoded and the server remuxes it, the chromecast hates it and it doesn't work well, if at all.

3. And I just discovered that when direct playing, it plays the subs and you can't turn it off.

How on earth can it be this broken?!?!?! It's almost unusable! I'm casting from the Android mobile app, testing from two different devices, and as I mentioned in the OP, it first presented itself on an entirely different Shield/Chromecast when played remotely. So the issue is definitely with Emby. Either the Android mobile app, the server or both.

Edited by Doofus, 13 January 2020 - 02:25 PM.


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:50 AM

Posted 13 January 2020 - 01:57 AM

 

 

1. These audio tracks shouldn't be being transcoded at all.

Why do you feel that way? Did you explore the server dashboard to learn why they were transcoding?



#24 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 01:59 AM

Why do you feel that way? Did you explore the server dashboard to learn why they were transcoding?


I had the theory that most the audio tracks I was playing were actually supported by the chromecast in the shield. So I disabled the allow transcoding of audio option in the user settings, and tried again. I was correct. This time it direct played, and I could skip to any part of the movie and it would play correctly.


Edited by Doofus, 13 January 2020 - 11:05 AM.


#25 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:50 AM

Posted 13 January 2020 - 02:01 AM

Example?



#26 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 02:14 AM

This is a movie I tested with. It has an AC3 audio track. If I disable the option to allow transcoding of the audio, it direct plays with no problems.



#27 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 02:15 AM

The only audio that doesn't transcode is stereo AAC



#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:50 AM

Posted 13 January 2020 - 02:16 AM

How is your audio equipment setup? Because chromecast developer api's tell us if your setup supports ac3, and based on your log it appears it is telling us no.



#29 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 02:33 AM

The Shield is connected to my Marantz receiver. So most audio codecs are supported. And as I said, this happens with any audio other than 2 channel AAC. And this also happened with someone else's Shield/Chromecast, connected to a different receiver.



#30 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 03:24 AM

And here's the same movie direct playing

2020-01-12 23:10:44.962 Info SessionManager: Playback start reported by app Emby for Chromecast 2.1.0 playing 2:22. Started at 0 ms
2020-01-12 23:10:44.962 Info PlaybackReporting - EventMonitorEntryPoint: _sessionManager_PlaybackStart : Entered
2020-01-12 23:10:44.962 Info PlaybackReporting - EventMonitorEntryPoint: Adding PlaybackInfo to playback_trackers : U0hJRUxE-6a8eb582a4af42d1bcef357a756df9b8-138561
2020-01-12 23:10:44.962 Info PlaybackReporting - EventMonitorEntryPoint: Saving PlaybackInfo to DB
2020-01-12 23:10:44.962 Info HttpServer: HTTP Response 204 to 10.1.1.33. Time: 4ms. http://10.1.1.14:8096/emby/Sessions/Playing
2020-01-12 23:10:44.967 Info HttpServer: HTTP POST http://10.1.1.14:8096/emby/Sessions/Playing/Progress. UserAgent: Mozilla/5.0 (Linux; Android 9.0; Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.81 Safari/537.36 CrKey/1.42.179832
2020-01-12 23:10:44.967 Info HttpServer: HTTP Response 204 to 10.1.1.33. Time: 1ms. http://10.1.1.14:8096/emby/Sessions/Playing/Progress
2020-01-12 23:10:45.020 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Users/6a8eb582a4af42d1bcef357a756df9b8/Items/138561. UserAgent: Mozilla/5.0 (Linux; Android 7.1.1; Lenovo YT-X703F Build/S100; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/79.0.3945.116 Safari/537.36
2020-01-12 23:10:45.023 Info HttpServer: HTTP Response 200 to 10.1.1.23. Time: 3ms. http://10.1.1.14:8096/emby/Users/6a8eb582a4af42d1bcef357a756df9b8/Items/138561
2020-01-12 23:10:45.025 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=1024&tag=5955d753005f126812f149ea83f8eb3c&quality=90. UserAgent: Dalvik/2.1.0 (Linux; U; Android 7.1.1; Lenovo YT-X703F Build/S100)
2020-01-12 23:10:45.050 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=140&tag=5955d753005f126812f149ea83f8eb3c&quality=90. UserAgent: Mozilla/5.0 (Linux; Android 7.1.1; Lenovo YT-X703F Build/S100; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/79.0.3945.116 Safari/537.36
2020-01-12 23:10:45.052 Info HttpServer: HTTP Response 200 to 10.1.1.23. Time: 1ms. http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=140&tag=5955d753005f126812f149ea83f8eb3c&quality=90
2020-01-12 23:10:45.085 Info HttpServer: HTTP Response 200 to 10.1.1.23. Time: 60ms. http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=1024&tag=5955d753005f126812f149ea83f8eb3c&quality=90
2020-01-12 23:10:45.182 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=1024&tag=5955d753005f126812f149ea83f8eb3c&quality=90. UserAgent: Dalvik/2.1.0 (Linux; U; Android 7.1.1; Lenovo YT-X703F Build/S100)
2020-01-12 23:10:45.217 Info HttpServer: HTTP Response 200 to 10.1.1.23. Time: 34ms. http://10.1.1.14:8096/emby/Items/138561/Images/Primary?height=1024&tag=5955d753005f126812f149ea83f8eb3c&quality=90
2020-01-12 23:10:45.871 Info HttpServer: HTTP POST http://10.1.1.14:8096/emby/Sessions/Playing/Progress. UserAgent: Mozilla/5.0 (Linux; Android 9.0; Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.81 Safari/537.36 CrKey/1.42.179832
2020-01-12 23:10:45.872 Info HttpServer: HTTP Response 204 to 10.1.1.33. Time: 1ms. http://10.1.1.14:8096/emby/Sessions/Playing/Progress
2020-01-12 23:10:48.629 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/system/info/public. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.629 Info HttpServer: HTTP Response 200 to 10.1.1.13. Time: 0ms. http://10.1.1.14:8096/emby/system/info/public
2020-01-12 23:10:48.632 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/System/Info. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.633 Info HttpServer: HTTP Response 200 to 10.1.1.13. Time: 1ms. http://10.1.1.14:8096/emby/System/Info
2020-01-12 23:10:48.639 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/DisplayPreferences/usersettings?userId=6a8eb582a4af42d1bcef357a756df9b8&client=emby. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.640 Info HttpServer: HTTP Response 200 to 10.1.1.13. Time: 1ms. http://10.1.1.14:8096/emby/DisplayPreferences/usersettings?userId=6a8eb582a4af42d1bcef357a756df9b8&client=emby
2020-01-12 23:10:48.715 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Sync/Items/Ready?TargetId=u5WXjloYg36FQUqsWKJxFanld8tSjchP0gpGDChks. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.716 Debug App: Returning 0 ready sync items for targetId u5WXjloYg36FQUqsWKJxFanld8tSjchP0gpGDChks
2020-01-12 23:10:48.716 Info HttpServer: HTTP Response 200 to 10.1.1.13. Time: 1ms. http://10.1.1.14:8096/emby/Sync/Items/Ready?TargetId=u5WXjloYg36FQUqsWKJxFanld8tSjchP0gpGDChks
2020-01-12 23:10:48.718 Info HttpServer: HTTP POST http://10.1.1.14:8096/emby/Sync/Data. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.719 Info HttpServer: HTTP Response 200 to 10.1.1.13. Time: 1ms. http://10.1.1.14:8096/emby/Sync/Data
2020-01-12 23:10:48.905 Info HttpServer: HTTP GET http://206.189.169.41:8096/emby/system/info/public. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; MSAppHost/3.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363
2020-01-12 23:10:48.905 Info HttpServer: HTTP Response 200 to 10.23.0.82. Time: 0ms. http://206.189.169.41:8096/emby/system/info/public
2020-01-12 23:10:52.601 Info HttpServer: HTTP GET http://10.1.1.14:8096/emby/Items/138561/Images/Backdrop/1?tag=b37e8abfdbb6ca3d0898b921323eba8b&maxWidth=2560&quality=70. UserAgent: Mozilla/5.0 (Linux; Android 7.1.1; Lenovo YT-X703F Build/S100; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/79.0.3945.116 Safari/537.36
2020-01-12 23:10:52.603 Info HttpServer: HTTP Response 200 to 10.1.1.23. Time: 2ms. http://10.1.1.14:8096/emby/Items/138561/Images/Backdrop/1?tag=b37e8abfdbb6ca3d0898b921323eba8b&maxWidth=2560&quality=70
2020-01-12 23:10:55.870 Info HttpServer: HTTP OPTIONS http://10.1.1.14:8096/emby/Sessions/Playing/Progress. UserAgent: Mozilla/5.0 (Linux; Android 9.0; Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.81 Safari/537.36 CrKey/1.42.179832
2020-01-12 23:10:55.870 Info HttpServer: HTTP Response 200 to 10.1.1.33. Time: 0ms. http://10.1.1.14:8096/emby/Sessions/Playing/Progress
2020-01-12 23:10:55.876 Info HttpServer: HTTP POST http://10.1.1.14:8096/emby/Sessions/Playing/Progress. UserAgent: Mozilla/5.0 (Linux; Android 9.0; Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.81 Safari/537.36 CrKey/1.42.179832
2020-01-12 23:10:55.878 Info HttpServer: HTTP Response 204 to 10.1.1.33. Time: 2ms. http://10.1.1.14:8096/emby/Sessions/Playing/Progress
2020-01-12 23:10:57.000 Info HttpServer: HTTP OPTIONS http://10.1.1.14:8096/emby/Sessions/Playing/Stopped. UserAgent: Mozilla/5.0 (Linux; Android 9.0; Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.81 Safari/537.36 CrKey/1.42.179832
2020-01-12 23:10:57.000 Info HttpServer: HTTP Response 200 to 10.1.1.33. Time: 0ms. http://10.1.1.14:8096/emby/Sessions/Playing/Stopped


#31 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 13 January 2020 - 03:43 AM

And I think this is the same issue

 

https://emby.media/c...st-ultra/page-2



#32 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:50 AM

Posted 14 January 2020 - 02:02 AM

Just tested and ac3 is direct playing just fine.



#33 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 14 January 2020 - 02:07 AM

As it should, but clearly in my case, it isn't. Nothing is, except AAC 2 channel. And there's still the issue of when it does remux, it's almost unplayable. Do you have the same version of Chromecast, that I do?



#34 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:50 AM

Posted 14 January 2020 - 02:16 AM

I have basically all of them on hand for testing. I tested this tonight with chromecast ultra.



#35 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 12:50 AM

Posted 14 January 2020 - 02:20 AM

Mine is in the Shield TV, can you test with that? According to the logs, it's version 2.10.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users