Jump to content
murky024

Shield TV Setup Help

Recommended Posts

murky024

So I am working on building a Shield TV server for my mini-van when we take long car trips. There are a few things I am working to solve and I am not 100% sure how:

 

1. The Server and Emby client require a network connection

 

How do I get around needing to be connected to a network? I have an original Shield TV setup with an 8 TB hard drive connected directly to the Shield. So I would think that I could run the client and connect to the server via localhost without any connection to the network.

 

2. Shield TV runs out of space after streaming movie for 10 minutes. 

 

I need to get all of my cache paths setup to Emby Server but it is giving me the error that Emby does not have access. Do I just need to SSH in and manually give rights? Is there a way to have this done by default?

 

Thanks in advance for the help...

Share this post


Link to post
Share on other sites
Luke

 

 

I need to get all of my cache paths setup to Emby Server but it is giving me the error that Emby does not have access.

 

Hi, can't you just use the defaults without having to customize this?

 

 

 

How do I get around needing to be connected to a network? I have an original Shield TV setup with an 8 TB hard drive connected directly to the Shield. So I would think that I could run the client and connect to the server via localhost without any connection to the network.

Hi, you should, if you run our player app on the same Shield. have you tried this?

  • Like 1

Share this post


Link to post
Share on other sites
murky024

Hi, can't you just use the defaults without having to customize this?

 

Hi, you should, if you run our player app on the same Shield. have you tried this?

 

No, the default cache locations seem to be causing me problems. After streaming locally for ~10 minutes Emby freezes and the server shuts down, and the Shield TV gives me a message that is it critically low on space.

 

 

As for the player app, I am using the standard Emby player, is there a custom app for playing locally? I get server unavailable messages when I am not connected to the network, even for a localhost setup.

Share this post


Link to post
Share on other sites
Luke

How much space is available?

Share this post


Link to post
Share on other sites
murky024

How much space is available?

8 gb

Share this post


Link to post
Share on other sites
Luke

What are you trying to play? How big is the file?

Share this post


Link to post
Share on other sites
murky024

What are you trying to play? How big is the file?

 

I am trying to play Aladdin and its a .mkv file that was a converted bluray so its 17.43 gb.

 

 

Also, for some odd reason my Premier is no longer showing up on the server, is there something wrong with the registration server or did I mess something up messing around with my Shield TV Server?

Edited by murky024

Share this post


Link to post
Share on other sites
Luke

Ok, if the file can't direct play, then there needs to be at least as much space as the original video itself. This is because the video will be re-packaged into an alternate format on the fly. What does it say as the reason for not direct playing? You can check this directly in the video player using the stats feature.

Share this post


Link to post
Share on other sites
murky024

Ok, if the file can't direct play, then there needs to be at least as much space as the original video itself. This is because the video will be re-packaged into an alternate format on the fly. What does it say as the reason for not direct playing? You can check this directly in the video player using the stats feature.

 

The file is in direct stream

 

Transcode reason is for unsupported audio

Share this post


Link to post
Share on other sites
murky024

Ok, so I was able to use the NVIDIA SHIELD folder that is created on the remote storage and use that for transcoding, that seems to have solved my storage issue without having to manually set permissions in Android.

 

I am still trying to figure out how to get the app to work without being connected to a network. Any suggestions on that?

Share this post


Link to post
Share on other sites
Luke

What happens when you try?

Share this post


Link to post
Share on other sites
murky024

What happens when you try?

What do I need to try?

 

I have cleared the cache and data on the Emby client app as I have uninstalled and reinstalled the client.

 

To answer your previous question, yes the Emby client and server are on the same Shield TV.

Share this post


Link to post
Share on other sites
Luke

Can you try using the app to connect to the Emby Server using the localhost address?

Share this post


Link to post
Share on other sites
murky024

Can you try using the app to connect to the Emby Server using the localhost address?

Localhost connects fine as long as it is in a network, the app won't find the server if it is not on a network.

 

I haven't tried setting a manual IP address but I doubt that will work. I also haven't tried 127.0.0.1 as a replacement for localhost but still not confident that would work.

Share this post


Link to post
Share on other sites
ebr

It works fine when I connect to a WiFi hotspot on a cell phone. I used that as a work around in our 16 hour drive but I want to try and avoid that due to data use concerns.

 

Was any data actually being used?

 

I'm thinking this may just be an issue where the network stack is not available at all if the device adapter isn't connected to a network of some kind.

Share this post


Link to post
Share on other sites
Luke

I'm saying enable that feature on the shield.

Share this post


Link to post
Share on other sites
murky024

Was any data actually being used?

 

I'm thinking this may just be an issue where the network stack is not available at all if the device adapter isn't connected to a network of some kind.

I agree, I was thinking the same thing which is why I didn't try any other workarounds. I wasn't sure how to get it to show... I will try Luke's suggestion once I figure out how to implement it...

 

Edit:

And I was worried about the Shield TV using the data, not Emby...

Edited by murky024

Share this post


Link to post
Share on other sites
murky024

 

Luke,

I am trying to figure out how exactly to make the IP stack available without a connected device. Best I can come up with is as you suggest turning the Shield TV into a hot spot, but these instructions are just for some generic 3g router, not for the Shield TV. I have been googling how to setup a hot spot on the Shield TV but I am not finding much of use.

Share this post


Link to post
Share on other sites
Luke

OK yea I haven't tried this myself, it's just something that I thought of that might be a way.

Share this post


Link to post
Share on other sites
murky024

OK yea I haven't tried this myself, it's just something that I thought of that might be a way.

I found a guy who sideloaded pdanet on the Shield TV so I will give that a try. I will update when I get that done and tested.

Share this post


Link to post
Share on other sites
Luke

Interesting, thanks. Let us know how that goes.

Share this post


Link to post
Share on other sites
murky024

Ok PDANet gives the device an IP address. When I open the Emby client it shows the server with that IP address but the client won't connect. It gives an offline error...

Share this post


Link to post
Share on other sites
Luke

Try entering the address manually.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...