Jump to content


Photo

Freenas 4.3.0.23 crash silently


  • Please log in to reply
29 replies to this topic

#21 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted 19 November 2019 - 03:30 PM

Hi Luke.

 

I currently testing different version, but the installation of older version doesn't seems to works well. I tried both ways (direct install with older version and uninstall/reinstall with older version)

 

The problem is, when I uninstall or reinstall, the directory:     var/db/emby-server/plugins is updated (delete or replace with the older version.

But when I restart the server, I can see those log lines:

     

2019-11-19 14:19:12.095 Info App: File /var/db/emby-server/plugins/Emby.Dlna.dll has version 1.0.30.0

2019-11-19 14:19:12.095 Info App: File /usr/local/lib/emby-server/system/plugins/Emby.Dlna.dll has version 1.0.31.0
2019-11-19 14:19:12.095 Info App: Copying plugin from /usr/local/lib/emby-server/system/plugins/Emby.Dlna.dll to /var/db/emby-server/plugins/Emby.Dlna.dll
 

So, the "older" is replaced by the latest and boot with latest version... I guess it is "normal" to ensure we used the latest available but in my current testing, I just cannot do this using the plugin catalog. I need to copy the older DLL in the usr/local/...... directory too.

 

This was just FYI

 

Thanks, will be back soon with the results



#22 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted 19 November 2019 - 04:02 PM

Hi Luke.

 

will try to simplify the test I did. Currently, I have a beta installation package of 4.3.0.13 that DON'T crash (works well). So, I install it and copy all plugins from this version.

After, I reinstall the version 4.3.0.23. Paste all plugins (from 4.3.0.13) to this current version. Turn ON my TV and it crash. I also did the test before by replacing only the "Emby.Dlna.dll file but the result was the same.

 

 

SO, I can say that the problem doesn't come directly from the plugins, but from the server.... If I can have acces to all previous version (14, 15, 16, 17, 18, 19, 20, 21) I could test them to tell you which version is broken.

 

EDIT: BTW, I found that Emby Theater 3.0.10 doesn't sync with DLNA / PlayTo. Is it normal?

EDIT2: Forget my last previous EDIT, I restest it all from scratch and it has been discovered and can use the playto with ET

 

Thanks


Edited by eraser8, 19 November 2019 - 04:14 PM.


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142617 posts
  • Local time: 01:48 AM

Posted 19 November 2019 - 04:15 PM

Are you sure the older dlna plugin version was used?



#24 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted 19 November 2019 - 04:31 PM

Are you sure the older dlna plugin version was used?

 

Yes, pretty sure. I just restest it using only the Emby.Dlna.dll 1.0.27 (from 4.3.0.13) and here is the log

Attached Files



#25 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted 22 November 2019 - 03:50 PM

FYI, this bug appear also in version 4.3.0.25

 

Thanks



#26 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted 26 November 2019 - 08:50 AM

Hi guys,

 

Just a quick follow up. I just install the new version 4.3.0.30 and the bug appear again. I thought you fixed it since the version comments talked about the "fix dlna header for old LG"....

But unfortunately, I got the bug again.

 

Thanks

Attached Files



#27 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142617 posts
  • Local time: 01:48 AM

Posted 26 November 2019 - 12:00 PM

Thanks for the info.

#28 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted Today, 12:45 AM

Hi Luke, FYI, I just tested this bug with the latest beta server (4.4.0.1) and now, it run great... No more crashing!!! (for the moment) Good job :)

 

I'll let you know if there is anything.

 

Thanks


Edited by eraser8, Today, 12:46 AM.


#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142617 posts
  • Local time: 01:48 AM

Posted Today, 12:46 AM

Interesting, thanks for the feedback.



#30 eraser8 OFFLINE  

eraser8

    Advanced Member

  • Members
  • 230 posts
  • Local time: 01:48 AM

Posted Today, 12:53 AM

Yep... Here is the current log I have when I turn ON my TV:

 

2019-12-11 20:50:42.333 Debug Dlna: Found matching device profile: LG Smart TV
2019-12-11 20:50:42.336 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 7ms. http://192.168.11.55...description.xml
2019-12-11 20:50:42.463 Debug HttpServer: HTTP GET http://192.168.11.55...ntdirectory.xml. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:42.468 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 5ms. http://192.168.11.55...ntdirectory.xml
2019-12-11 20:50:42.488 Debug HttpServer: HTTP GET http://192.168.11.55...tionmanager.xml. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:42.490 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 2ms. http://192.168.11.55...tionmanager.xml
2019-12-11 20:50:43.799 Debug HttpServer: HTTP POST http://192.168.11.55...rectory/control. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:43.802 Debug Dlna: Found matching device profile: LG Smart TV
2019-12-11 20:50:43.803 Debug Dlna: Control request. Headers: SOAPAction="urn:schemas-upnp-org:service:ContentDirectory:1#GetSearchCapabilities", DLNADeviceName.lge.com=%5bLG%5d%20webOS%20TV, User-Agent=Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50, Host=192.168.11.55:8096, Content-Length=278, Content-Type=text/xml; charset="utf-8"
2019-12-11 20:50:43.805 Debug Dlna: Received control request GetSearchCapabilities
2019-12-11 20:50:43.814 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 15ms. http://192.168.11.55...rectory/control
2019-12-11 20:50:43.846 Debug HttpServer: HTTP SUBSCRIBE http://192.168.11.55...irectory/events. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:43.848 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 2ms. http://192.168.11.55...irectory/events
2019-12-11 20:50:43.878 Debug HttpServer: HTTP SUBSCRIBE http://192.168.11.55...nmanager/events. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:43.878 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 1ms. http://192.168.11.55...nmanager/events
2019-12-11 20:50:44.848 Debug HttpServer: HTTP POST http://192.168.11.55...rectory/control. UserAgent: Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50
2019-12-11 20:50:44.848 Debug Dlna: Found matching device profile: LG Smart TV
2019-12-11 20:50:44.848 Debug Dlna: Control request. Headers: SOAPAction="urn:schemas-upnp-org:service:ContentDirectory:1#Search", DLNADeviceName.lge.com=%5bLG%5d%20webOS%20TV, User-Agent=Linux/3.10.19-32.afro.6 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/05.05.70 DLNADOC/1.50, Host=192.168.11.55:8096, Content-Length=739, Content-Type=text/xml; charset="utf-8"
2019-12-11 20:50:44.848 Debug Dlna: Received control request Search
2019-12-11 20:50:44.996 Debug HttpServer: HTTP Response 200 to 192.168.11.63. Time: 148ms. http://192.168.11.55...rectory/control
2019-12-11 20:50:47.566 Debug Dlna: Attempting to create PlayToController from location http://192.168.11.63:1582/
2019-12-11 20:50:47.566 Debug Dlna: Logging session activity from location http://192.168.11.63:1582/
2019-12-11 20:50:47.598 Debug HttpClient: HttpClientManager GET: http://192.168.11.63:1582/
2019-12-11 20:50:47.622 Debug Dlna: Dlna Device.Start
2019-12-11 20:50:47.623 Debug Dlna: Found matching device profile: LG Smart TV
2019-12-11 20:50:47.630 Info Dlna: DLNA Session created for [LG] webOS TV - LG TV

 

 

 

Definitely much better :)


  • Luke likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users