Jump to content


Photo

[4.3.0.21] - FFMPeg errors


  • Please log in to reply
5 replies to this topic

#1 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3443 posts
  • Local time: 11:15 AM
  • LocationWarrington,UK

Posted 10 November 2019 - 08:19 AM

Just upgraded to .21 and getting loads of errors from ffmpeg in the log

2019-11-10 11:41:08.640 Info FfmpegManager: ProcessRun 'ffmpeg -hide_banner -decoders' Execute: F:\EmbyCore\system\ffmpeg.exe -hide_banner -decoders
2019-11-10 11:41:08.644 Debug FfmpegManager: ProcessRun 'ffmpeg -hide_banner -decoders' Started.
2019-11-10 11:41:08.674 Info FfmpegManager: ProcessRun 'ffmpeg -hide_banner -decoders' Process exited with code -1073741819
2019-11-10 11:41:08.674 Error FfmpegManager: ProcessRun 'ffmpeg -hide_banner -decoders' Output:
	
2019-11-10 11:41:08.674 Error FfmpegManager: ProcessRun 'ffmpeg -hide_banner -decoders' Error Output:

and

2019-11-10 11:35:49.443 Debug App: ProcessRun 'extract-image' Started.
2019-11-10 11:35:49.870 Info App: ProcessRun 'extract-image' Process exited with code -1073741819
2019-11-10 11:35:49.949 Error App: Error running extract-image -threads 4 -i file:"F:\EmbyTest\Music\Electric Light Orchestra\All Over The World The Very Best Of ELO\01 Mr. Blue Sky.mp3" -map 0:1 -threads 0 -vframes 1 -vf "scale=600:trunc(ow/a/2)*2" -f image2 "F:\EmbyCore\programdata\cache\temp\d64fc3e4-b1a2-4807-a730-8879bcda3ef4.jpg"
	*** Error Report ***
	Version: 4.3.0.21
	Command line: F:\EmbyCore\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///F:/EmbyCore/system/System.Private.CoreLib.dll
	Processor count: 8
	Program data path: F:\EmbyCore\programdata
	Application directory: F:\EmbyCore\system
	System.Exception: System.Exception: Error running ffmpeg extract-image for file:"F:\EmbyTest\Music\Electric Light Orchestra\All Over The World The Very Best Of ELO\01 Mr. Blue Sky.mp3" - Command: -threads 4 -i file:"F:\EmbyTest\Music\Electric Light Orchestra\All Over The World The Very Best Of ELO\01 Mr. Blue Sky.mp3" -map 0:1 -threads 0 -vframes 1 -vf "scale=600:trunc(ow/a/2)*2" -f image2 "F:\EmbyCore\programdata\cache\temp\d64fc3e4-b1a2-4807-a730-8879bcda3ef4.jpg"
	   at Emby.Server.MediaEncoding.ImageExtraction.ImageExtractorBase.RunExtraction(String inputPath, ReadOnlyMemory`1 container, MediaStream videoStream, Nullable`1 protocol, Nullable`1 streamIndex, Nullable`1 threedFormat, Nullable`1 startOffset, Nullable`1 interval, String targetDirectory, String targetFilename, Nullable`1 maxWidth, Boolean enableThumbnailFilter, CancellationToken cancellationToken)
	Source: Emby.Server.MediaEncoding
	TargetSite: Void MoveNext()
	
2019-11-10 11:35:49.949 Error App: ProcessRun 'extract-image' Output:
	
2019-11-10 11:35:49.949 Error App: ProcessRun 'extract-image' Error Output: 

Also hardware detection is failing

{"ApplicationVersion":"4.3.0.21","VersionType":"Beta","ReleaseCode":"393d783c30484015a24645f7844060b4","OperatingSystem":"Windows","OperatingSystemName":"Win32NT","OperatingSystemVersion":"6.2.9200.0 ","FfmpegCapabilities":{"FullVersionInfo":"\r\n","IsEmbyCustom":false,"SupportsSkipInterval":false,"SupportsSkipList":false,"SupportsTempSegmentWriting":false,"SupportsLogTimeStamps":false,"SupportsWebVttReferenceStream":false,"VideoDecoders":{},"AudioDecoders":{},"SubtitleDecoders":{},"VideoEncoders":{},"AudioEncoders":{},"SubtitleEncoders":{},"VideoFilters":{},"AudioFilters":{},"InputProtocols":{},"OutputProtocols":{},"HardwareAccelerations":{},"SupportsThrottling":false,"SupportsFillWallClockDts":false,"SupportsDiscardCorruptPts":false},"DetectionOutputs":{"Dx11VaCodecProvider":{"CodecProviderName":"Dx11VaCodecProvider","Result":[
"Detection Log"
]
},"DxvaCodecProvider":{"CodecProviderName":"DxvaCodecProvider","Result":[
"Detection Log"
]
}},"VideoDecoders":{},"VideoEncoders":{},"EncodingOptions":{"EncodingThreadCount":-1,"ExtractionThreadCount":4,"TranscodingTempPath":"","DownMixAudioBoost":2,"EnableThrottling":false,"ThrottleBufferSize":120,"ThrottleHysteresis":5,"H264Crf":23,"H264Preset":"","EnableHardwareEncoding":true,"EnableSubtitleExtraction":false,"CodecConfigurations":[{"IsEnabled":true,"Priority":100,"CodecId":"V-D-mpeg2_d3d11va-d3d11va-devid6088"},{"IsEnabled":false,"Priority":0,"CodecId":"V-D-mpeg2_cuvid-nv-cudaId0"},{"IsEnabled":false,"Priority":0,"CodecId":"V-D-vc1_cuvid-nv-cudaId0"},{"IsEnabled":false,"Priority":0,"CodecId":"V-D-vc1_d3d11va-d3d11va-devid6088"},{"IsEnabled":true,"Priority":100,"CodecId":"V-D-h264_d3d11va-d3d11va-devid6088"},{"IsEnabled":false,"Priority":0,"CodecId":"V-D-h264_cuvid-nv-cudaId0"},{"IsEnabled":false,"Priority":0,"CodecId":"V-D-vp8_cuvid-nv-cudaId0"},{"IsEnabled":true,"Priority":100,"CodecId":"V-D-hevc_d3d11va-d3d11va-devid6088"},{"IsEnabled":true,"Priority":100,"CodecId":"V-E-h264_nvenc-nv-cudaId0"},{"IsEnabled":true,"Priority":100,"CodecId":"V-E-hevc_nvenc-nv-cudaId0"}],"HardwareAccelerationMode":2}}

I reverted to .20 and all the errors go away so its not a change on the pc

 

 

Attached File  hardware_detection-63708982868.txt   2.03KB   0 downloadsAttached File  embyserver-63708982857.txt   1.21MB   0 downloads

 


  • CBers likes this

#2 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3443 posts
  • Local time: 11:15 AM
  • LocationWarrington,UK

Posted 10 November 2019 - 08:52 AM

Odd - this issue has gone away now

 

Not sure why - hmmmm

 

Poss corrupt upgrade - re done the upgrade and now things are back to normal


  • CBers likes this

#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142718 posts
  • Local time: 06:15 AM

Posted 10 November 2019 - 01:13 PM

@softworkz

#4 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1902 posts
  • Local time: 12:15 PM

Posted 11 November 2019 - 06:56 PM

 

@Luke - Why? He said it was fixed by repeating the update.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142718 posts
  • Local time: 06:15 AM

Posted 11 November 2019 - 06:59 PM

Has it happened again?



#6 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3443 posts
  • Local time: 11:15 AM
  • LocationWarrington,UK

Posted 12 November 2019 - 08:12 AM

So far No






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users