Jump to content


Photo

Roku app crashing when opening


  • Please log in to reply
4 replies to this topic

#1 awyounglu OFFLINE  

awyounglu

    Newbie

  • Members
  • 4 posts
  • Local time: 12:57 AM

Posted 09 November 2019 - 08:08 PM

When I try to launch to Roku Emby app, it starts loading then immediately returns to the home screen.

 

I checking the log.

 

This is what I saw

 

 

Any ideas on how to fix the problem? It was working fine yesterday.


Edited by awyounglu, 10 November 2019 - 11:08 AM.


#2 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5769 posts
  • Local time: 09:57 PM

Posted 09 November 2019 - 10:15 PM

Have you restarted the machine the Emby server is running on? It might be related to that PortMapper error and NAT Addressing. The Roku crashes because we must be expecting data and get NULLS instead. There are a few spots where NULL replies were not expected in the code and a type mismatch crashes the app. We are going through correcting this as we find them and tightening up this logic. The Roku makes the gears/cogs/mechanics required to do most things complicated. You must keep render methods in the render thread and everything else in task threads. Then communicate back and forth using fields and observers. It makes it so the Roku side can get NULL where we never anticipated. We are doing much better at this as time goes on and cleaning up the last few spots where this can happen.

 

We apologize this is an issue. If restart your Emby machine does not solve this can you please post server logs from a new Emby server start and after a fresh crash of the Roku app. Please SCRUB your IP/Host from these logs with find/replace. Use <SNIPPED> or <MY-IP> or similar when you replace. Don't just delete what was there we need a placeholder of what used to be there so we can read the logs properly. Thanks. :)


Edited by speechles, 09 November 2019 - 10:17 PM.


#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:57 AM

Posted 10 November 2019 - 01:21 AM

Can you please attach the complete emby server log? thanks.



#4 awyounglu OFFLINE  

awyounglu

    Newbie

  • Members
  • 4 posts
  • Local time: 12:57 AM

Posted 10 November 2019 - 11:27 AM

here is the log

Attached Files


Edited by awyounglu, 10 November 2019 - 11:29 AM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:57 AM

Posted 16 November 2019 - 06:20 PM

@awyounglu are you still running into this with the latest roku update?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users