Jump to content


Photo

Any big issues in .190?


  • Please log in to reply
18 replies to this topic

#1 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 26 October 2019 - 10:35 AM

I'd like to push a general release primarily for the playback error handling enhancements (plus it is just time).

 

Please report any show-stoppers that exist in the current beta.  FYI - this doesn't mean all the things you wish were there that aren't :).



#2 shocker OFFLINE  

shocker

    Advanced Member

  • Members
  • 444 posts
  • Local time: 05:30 AM

Posted 26 October 2019 - 11:04 AM

I'd like to push a general release primarily for the playback error handling enhancements (plus it is just time).

Please report any show-stoppers that exist in the current beta. FYI - this doesn't mean all the things you wish were there that aren't :).


No issues for playback. Didn’t played with filters and other settings inside the app

#3 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 475 posts
  • Local time: 10:30 PM

Posted 26 October 2019 - 01:31 PM

Pretty stable...  Nothing earth shattering.  Am experiencing long load times for music library again.  But not concerned until i get my library finished.



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16581 posts
  • Local time: 07:30 PM
  • LocationWashington State

Posted 28 October 2019 - 12:06 AM

Not sure if is the app or the beta server but playback error when selecting play on Latest Series on Home screen or via tv library.  Have to enter the series to play the item.

2019-10-27 21:00:25.400 Info HttpServer: HTTP Response 206 to 192.168.151.3. Time: 219ms. http://192.168.151.16:8096/emby/Videos/129804/stream.mp4?static=true&mediaSourceId=f4ee9cb53dc918b5ce8f8bf587f73692
2019-10-27 21:00:25.419 Info HttpServer: HTTP GET http://192.168.151.16:8096/emby/Videos/129804/stream.mp4?static=true&mediaSourceId=f4ee9cb53dc918b5ce8f8bf587f73692. Host=192.168.151.16:8096, User-Agent=Roku/DVP-9.20 (299.20E04128A), Accept=*/*
2019-10-27 21:00:25.424 Error MediaSourceManager: Error getting media sources
	*** Error Report ***
	Version: 4.3.0.16
	Command line: Y:\Emby-Server\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///Y:/Emby-Server/system/System.Private.CoreLib.dll
	Processor count: 12
	Program data path: Y:\Emby-Server\programdata
	Application directory: Y:\Emby-Server\system
	SQLitePCL.pretty.SQLiteException: Busy: database is locked - PRAGMA journal_mode
	SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown.
	   at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail)
	   at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql)
	   at Emby.Sqlite.BaseSqliteRepository.PrepareStatement(IDatabaseConnection connection, ReadOnlySpan`1 sql)
	   at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly)
	   at Emby.Server.Sync.SyncRepository.GetJobItemReader[T](SyncJobItemQuery query, String baseSelectText, Func`2 itemFactory)
	   at Emby.Server.Sync.SyncRepository.GetJobItems(SyncJobItemQuery query)
	   at Emby.Server.Sync.SyncManager.GetJobItems(SyncJobItemQuery query)
	   at Emby.Server.Sync.SyncedMediaSourceProvider.GetSyncedItems(BaseItem item)
	   at Emby.Server.Sync.SyncedMediaSourceProvider.GetMediaSources(BaseItem item, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetDynamicMediaSources(BaseItem item, IMediaSourceProvider provider, CancellationToken cancellationToken)
	Source: SQLitePCL.pretty
	TargetSite: SQLitePCL.pretty.IStatement PrepareStatement(System.String, System.String ByRef)
	

Might be a server change as doing the same on the server plays first episode instead of next up episode from latest or on series.

 

Could be a beta 4.3.0.16 issue as this started today, but I did not use Roku yesterday.

 

Seems to only affect older items as items add to .16 are playing via Latest.


Edited by Happy2Play, 28 October 2019 - 01:28 AM.


#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 28 October 2019 - 10:30 AM

Happy, you and Luke determined this is an issue in the beta server, correct?



#6 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16581 posts
  • Local time: 07:30 PM
  • LocationWashington State

Posted 28 October 2019 - 02:50 PM

Happy, you and Luke determined this is an issue in the beta server, correct?

Since it is the same error being thrown as the Download and Convert tasks, yes.  It is likely the beta server server. 



#7 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16581 posts
  • Local time: 07:30 PM
  • LocationWashington State

Posted 29 October 2019 - 02:55 PM

Anyone else get a Playback Error when you enter the TV library, then Shows and click play on the Series cover?



#8 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 29 October 2019 - 03:23 PM

Confirmed.  Will be fixed in next beta.

 

Thanks.



#9 shocker OFFLINE  

shocker

    Advanced Member

  • Members
  • 444 posts
  • Local time: 05:30 AM

Posted 29 October 2019 - 04:37 PM

I've seen that for some movies there are some playback issues. Roku is buffering a lot.

Even if I manually set to 2-3 Mbps or 60 Mbps FullHD the result is the same.

The wireless is working with ~400Mbps and I'm playing via LAN. With other devices for the same file (Apple TV, nVidia Shield, iOS, Android Mobile) everything works fine on every quality.

I don't think this is a Roku latest version issue as with the standard one I'm encountering the same issue.

 

Emby Server 4.3.0.17

Roku Streaming Stick+ latest OS version

Attached Files


Edited by shocker, 29 October 2019 - 04:40 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142429 posts
  • Local time: 10:30 PM

Posted 29 October 2019 - 04:42 PM

I've seen that for some movies there are some playback issues. Roku is buffering a lot.

Even if I manually set to 2-3 Mbps or 60 Mbps FullHD the result is the same.

The wireless is working with ~400Mbps and I'm playing via LAN. With other devices for the same file (Apple TV, nVidia Shield, iOS, Android Mobile) everything works fine on every quality.

I don't think this is a Roku latest version issue as with the standard one I'm encountering the same issue.

 

Emby Server 4.3.0.17

Roku Streaming Stick+ latest OS version

 

Try without hardware transcoding and see how that compares.



#11 shocker OFFLINE  

shocker

    Advanced Member

  • Members
  • 444 posts
  • Local time: 05:30 AM

Posted 29 October 2019 - 04:49 PM

Try without hardware transcoding and see how that compares.

It's worst

Attached Files



#12 Jdiesel ONLINE  

Jdiesel

    Advanced Member

  • Members
  • 2746 posts
  • Local time: 09:30 PM
  • LocationRegina, SK

Posted 29 October 2019 - 04:51 PM

Roku betas have been rock solid for me for a while now



#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 29 October 2019 - 05:51 PM

It's worst

 

Also try without throttling but this is not related to the beta.

 

Thanks.



#14 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 30 October 2019 - 01:09 PM

Anyone else get a Playback Error when you enter the TV library, then Shows and click play on the Series cover?

 

Happy, when you get a chance, please confirm this is fixed in 191.

 

Thanks!



#15 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16581 posts
  • Local time: 07:30 PM
  • LocationWashington State

Posted 30 October 2019 - 04:48 PM

Happy, when you get a chance, please confirm this is fixed in 191.

 

Thanks!

Confirmed the playback error issue is resolved in .191.


  • ebr likes this

#16 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 11 November 2019 - 04:09 PM

I need all Roku beta testers to hammer on .192.  I'd like to push it to release but it also contains a few changes that haven't been fully vetted yet so want to be sure no new problems have been introduced.

 

Main things to test are:

 

Playback

Playback correction (for things that cause errors or you can just trigger manually)

Guide navigation

 

Thanks.



#17 shocker OFFLINE  

shocker

    Advanced Member

  • Members
  • 444 posts
  • Local time: 05:30 AM

Posted 12 November 2019 - 10:05 AM

Tested Guide navigation, no issues found with .192.

Tested the playback with stable server and everything works fine. Seems pretty stable for me.

 

For playback under linux with server .21, there is no way to watch something without lots of interruptions but this is being discussed here: https://emby.media/c...-in-roku/page-2


  • ebr likes this

#18 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1063 posts
  • Local time: 01:30 PM

Posted 13 November 2019 - 05:29 PM

I personally have no issues, Just have the one remote user that has playback issues on some media files only on their Roku that @speechles has been looking at.  He has access to my system.

They can play everything fine on Windows, Mac safari, Iphone and Ipad - it is only the Roku that has this playback issue.



#19 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48154 posts
  • Local time: 10:30 PM

Posted 13 November 2019 - 06:10 PM

Thanks.  Version 193 is in review for release.


  • cybergrimes likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users