Jump to content


Photo

Live TV using Roku Express aspect ratio


  • Please log in to reply
35 replies to this topic

#1 Philip55 OFFLINE  

Philip55

    Member

  • Members
  • 11 posts
  • Local time: 03:14 AM

Posted 28 September 2019 - 06:40 PM

I a using HDHomeRun with Synology NAS DS415+ as the server. All other devices work perfectly. However, when I watch live TV via Roku express plugged into my TV. The screen looks like it is zoomed in and the top and bottom of the screen is no visible. This only happens on Roku device. I have tried to change display settings on the Roku and TV but it make no difference. Has anyone experienced this before?
  • Alawi likes this

#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50827 posts
  • Local time: 10:14 PM

Posted 29 September 2019 - 10:00 AM

Hi.  No this definitely sounds like a setting on one of the devices...



#3 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 10:17 AM

I have experienced the same thing when viewing a channel that is broadcast in Standard Definition and not High Def.  Some of the local channels here are sending what looks like a letterboxed (on all sides) video.  When viewed through HDHomeRun to Emby to Roku, I get exactly as you described.  If I switch to an HD channel, all is well.  This was a problem a few versions back, was corrected, and has now returned.  Not sure of the versions as things changed.



#4 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 10:32 AM

It is anamorphic video. That is why it appears zoomed in. There is no way Roku gives us to detect devices without anamorphic support. We have to do this on an as needed basis using model numbers.

 

Right now we drop anamorphic support for models 3700 and 3900. Both are Roku express models.

 

@Philip55 and @Scott D What are your Roku model numbers that experience the issue? We can fix this. Yes we can! :)


Edited by speechles, 29 September 2019 - 10:32 AM.


#5 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 11:04 AM

I have several:

I haven't tested on all devices, but these are the ones that I currently have installed.

 

3600X, 3710X, 4630, 3900RW, 3800RW and a few others that I have not docummented models numbers.


Edited by Scott D, 29 September 2019 - 11:06 AM.


#6 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 11:06 AM

I have several:

3600X, 3710X, 4630, 3900RW, 3800RW and a few others that I have not docummented models numbers.

 

Do all of those model numbers produce wonky for that TV channel?

 

Only the models which produce funky zoom-in effect on your anamorphic SD channels are the ones we need to fix. The ones that do it correctly are just fine.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:14 PM

Posted 29 September 2019 - 11:09 AM

Can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !



#8 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 11:13 AM

Do all of those model numbers produce wonky for that TV channel?

 

Only the models which produce funky zoom-in effect on your anamorphic SD channels are the ones we need to fix. The ones that do it correctly are just fine.

 

I will check them later today, as well as get a listing of all device models.

I will also attach pictures from both the over the air signal and that processed by HDHomeRun through Emby.



#9 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 11:23 AM

I will check them later today, as well as get a listing of all device models.

I will also attach pictures from both the over the air signal and that processed by HDHomeRun through Emby.

 

Thanks. You can get the model numbers on the Roku itself using Settings >> System >> About ...

 

There is also firmware 9.2.x coming out soon on Roku which may make everything we are doing moot.



#10 Philip55 OFFLINE  

Philip55

    Member

  • Members
  • 11 posts
  • Local time: 03:14 AM

Posted 29 September 2019 - 11:47 AM

The model of Roku is 3900X. Is it possible get the fix for this model?

Thank you all for you help and advice.

#11 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 11:56 AM

Quick test shows on the 3900X with Roku 9.1.0 build 4919-51

Emby server 4.2.1.0

Roku Emby 3.0.183

 

Attached is a screenshot of the image on screen of the actual OTA signal.

Second picture is the image as shown on the same tv through Emby.

 

Tv settings remained the same.

 

 

Attached Files



#12 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 12:16 PM

@Scott D What does the stats for nerds say for the play method? When you play the item press down on the remote as it plays. This opens the video player OSD. At the bottom is a gear. Click the gear and in that menu is stats for nerds. Once enabled it is remembered and will come back as you play more items.  Are these items transcoding? I am suspecting they already are and it is something in the transcoding.



#13 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 12:29 PM

@Scott D What does the stats for nerds say for the play method? When you play the item press down on the remote as it plays. This opens the video player OSD. At the bottom is a gear. Click the gear and in that menu is stats for nerds. Once enabled it is remembered and will come back as you play more items.  Are these items transcoding? I am suspecting they already are and it is something in the transcoding.

 

Not the stats during the previous post, but similar display problem.  Same channel, same tv, same roku.

Attached Files


Edited by Scott D, 29 September 2019 - 12:30 PM.


#14 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 12:34 PM



Not the stats during the previous post, but similar display problem.  Same channel, same tv, same roku.

 

Okay that clearly shows it is an anamorphic video. Resolution of 704x480 directly passing the video stream into the app where the profile clearly says 3700 and 3900 model numbers do not support anamorphic. It is directstream/remux(convert audio) copying the video so it must not be model 3700 or 3900 unless the server is doing something wrong.

 

Is your model number of the Roku you took these screenshots from either 3700 or 3900?

 

Technical note: Technically 704x480 is a cropped 720x480 true anamorphic. Most true DVD rips wont have this cropping. This is an out-of-specification TV broadcast not under your control. So we need to be able to consume/ingest it correctly.

 

The server doesn't understand the video is anamorphic or it would transcode if this is a 3700 or 3900. If it "recently" broke it has something to do with ffprobe. @Luke

 

@Scott D Can you post some ffmpeg logs when these problems happen for the problem channels? This would give us clearer insight into what is going on.. see post #7 of this thread. Thanks. :)


Edited by speechles, 29 September 2019 - 12:46 PM.


#15 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 01:02 PM

Attached is the ffmpeg log from the period of time when I captured the Nerd Stats.

I would attach the server log, but see my other post about overly verbose log files.

I can shut down the server (clear log file) and keep all users off until a sample can be run if that would help in any way.

Attached Files



#16 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5968 posts
  • Local time: 07:14 PM

Posted 29 September 2019 - 01:09 PM

{"Codec":"mpeg2video","TimeBase":"1/90000","CodecTimeBase":"1001/30000","VideoRange":"SDR","DisplayTitle":"480i MPEG2VIDEO","IsInterlaced":true,"BitRate":2000000,"RefFrames":1,"IsDefault":false,"IsForced":false,"Height":480,"Width":704,"AverageFrameRate":29.97003,"RealFrameRate":29.97003,"Profile":"Main","Type":"Video","AspectRatio":"4:3","Index":-1,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Protocol":"File","PixelFormat":"yuv420p","Level":8,"IsAnamorphic":false}

 

it is both interlaced and anamorphic. But isAnamorphic says false. @Luke

 

The issue is probably that broadcaster should be using 720x480 and incorrectly uses 704x480 which throws off everything. Combined with the poor ability of some Roku models to properly render anamorphic material. Since the anamorphic flag isn't showing which it should be because the pixel aspect ratio isn't 1:1. If that were corrected it may fix everything else likely.

 

https://en.wikipedia...tandards#MPEG-2

 

@Scott D Fast fix.. you can hit playback correction once to fix it. After that it should force a transcode of the video stream and correct the problem with ffmpeg. Let us know if this helps or doesn't. Thanks. :)


Edited by speechles, 29 September 2019 - 01:26 PM.


#17 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 01:19 PM

I was able to pull a portion of the server log during the timeframe while getting the nerd stats

Attached Files



#18 Scott D OFFLINE  

Scott D

    Advanced Member

  • Members
  • 171 posts
  • Local time: 07:14 PM
  • LocationPhoenix, AZ USA

Posted 29 September 2019 - 02:16 PM

OK.  Hopefully this will be everything needed to track this down.

 

What I did.

 

Shut down server.

Deleted all log files.

Restarted the server.

Opened 3900X with Roku 9.1.0 build 4919-51

Roku Emby 3.0.183

 

Scrolled to Live TV and selected channel 15.3

Turned on Stats for Nerds.  See photo

Turned on Playback correction.  See photo (No change in image)

 

Stopped all playback and exited Emby on Roku

Shut down server.

 

Copied all log files.

Did a quick search for personal information and REDACTED (please remove if there is more).

Attached Files


Edited by Scott D, 29 September 2019 - 02:17 PM.


#19 Philip55 OFFLINE  

Philip55

    Member

  • Members
  • 11 posts
  • Local time: 03:14 AM

Posted 29 September 2019 - 06:58 PM

I have the following versions
Roku Express 3900X with Roku 9.1.0 build 4919-51 verfied
Emby server 4.2.1.0 verified
Roku Emby 3.0.183 unknown. how do I find the version on Roku box?

#20 Philip55 OFFLINE  

Philip55

    Member

  • Members
  • 11 posts
  • Local time: 03:14 AM

Posted 30 September 2019 - 05:41 PM

@Scott D sadly I am unable to update the version installed on my Roku Express from Roku Emby 3.0.175 to Roku Emby 3.0.183. I spoke to Roku support and they said I need to contact the developers for the Emby channel to request an update. Is this possible?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users