Jump to content

firefox web interface - cache problem


alberto.bracci
Go to solution Solved by alberto.bracci,

Recommended Posts

alberto.bracci

Hello,

 

I have a problem with web interfaces, both in firefox and chrome on windows. In particular when I open emby from browser it often shows an older cached session, meaning that the next episodes to play and the one to be resumed are older. If I clean the cache, things get back to normal. Still, it happens all the time and I cannot keep clearing the cache every time, is there a way to prevent this from happening?

 

Thanks,

Alberto

Link to post
Share on other sites
  • 2 weeks later...
alberto.bracci

Do you need any logs or config info? Apparently the issue is present also in the android app.

I run emby server on a Manjaro Linux desktop machine, using nginx with reverse proxy for remote connection.

I am not sure but maybe the issue appeared with latest server update, it was not always present in the past

Link to post
Share on other sites
alberto.bracci

I tried some changes in the reverse proxy but nothing works. In particular I tried adding proxy_cache off; or expires off; to the emby block without any success.

Only thing that works is disabling http caching in a firefox developer session. Unfortunately it is only a temporary workaround.

 

It seems like it is an issue with caching, maybe due to nginx. Unfortunately I have many services set up with nginx and cannot do without it. I share the emby block to see whether some of you might have any suggestion.

 

Thanks for your help!

 

 

post-479250-0-38138000-1570387091_thumb.png

Link to post
Share on other sites
  • Solution
alberto.bracci

Thanks for the hint! Apparently, I also had to look for cache related settings in other parts of the file.

In particular, I had a line the @@pir8radio 's file didn't have:

 

add_header Cache-Control "public, max-age = 15778463";

removing it seems to solve the issue at least for the browser.

Thanks!

Link to post
Share on other sites
pir8radio

Yea you don't want to force long cache times for anything but the .webp images.    Emby versions all of their javascripts and what not, if you cache html it will try to call old scripts and stuff.  

 

Good job finding the issue. 

Edited by pir8radio
Link to post
Share on other sites
alberto.bracci

Thanks for the explanation! This reminds me of another small issue I have that might be related.

My libraries' images on the homepage are the same one that have been generated when I first set up emby. I cannot find a way to force their update, as the content has changed and thus the image shows wrong content.

Can it still be a cache related problem?

 

I think this issue was present even before I set up nginx, so it shouldn't be related to that.

Link to post
Share on other sites
Happy2Play

Thanks for the explanation! This reminds me of another small issue I have that might be related.

My libraries' images on the homepage are the same one that have been generated when I first set up emby. I cannot find a way to force their update, as the content has changed and thus the image shows wrong content.

Can it still be a cache related problem?

 

I think this issue was present even before I set up nginx, so it shouldn't be related to that.

 

 

Haven't tested in awhile and am not sure if it is broke in stable version or not.  I know it has been updated in the beta 4.3.x.x and requires a delete of current image to generate new image on next library scan.

  • Like 1
Link to post
Share on other sites
alberto.bracci

Thanks for another good hint!

Emby server stable version 4.2.1.0 on Manjaro Linux, deleting the images and scanning the libraries made them update!

 

Thanks again to all of you for your help!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...