Jump to content


Photo

[Auto Organize] Shows with Periods, QNAP, and Cache

Auto Organize QNAP

  • Please log in to reply
3 replies to this topic

#1 antilog17 OFFLINE  

antilog17

    Member

  • Members
  • 10 posts
  • Local time: 08:09 AM

Posted 19 September 2019 - 11:13 AM

Previously Posted in Wrong Forum:

 

I love the functionality of Auto Organize, but I'm running into an issue with shows that contain a period in the name. I've tried looking into the forum, but my searching has come up empty. When Auto-Organize moves an episode for a show with a period in the name, the folder name for the series gets screwy. For example, I am trying to sort through an episode for Mythbusters Jr. It tells me it has successfully sorted the episodes, but the series folder name is wrong. Instead of ending up in a series folder named "Mythbusters Jr." or even "Mythbusters Jr", it ends up in a folder named "M16HM6~T". See the screenshot (EmbyScreenshotNamingIssue.png) to see that Auto Organize doesn't even mention "M16HM6~T" as the name of the folder it ended up in. I've even deleted the folder, but now, Auto-Organize seems to permanently contain the series listing as an option when you try to manually specify a series (EmbyPeriodNameIssue.png). In the past, if a series folder is deleted, Auto-Organize does not show the option, but not even clearing the emby cache gets rid of these options. Is there anyway for me to clear the Auto Organize cache or change how auto-organize deals with periods?

 

For reference, I am running Emby Server on QNAP TVS-871.

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 03:09 AM

Posted 19 September 2019 - 12:46 PM

Hi, this sounds to me like the operating system changing the name when the folder ends with a period. I'm guessing the solution is to just not even attempt to do that anymore and just try to save with "Mythbusters Jr".



#3 antilog17 OFFLINE  

antilog17

    Member

  • Members
  • 10 posts
  • Local time: 08:09 AM

Posted 19 September 2019 - 12:59 PM

I am trying, but I'm running into a problem with Auto Organize hanging on to the old Mythbusters Jr. entry. I've created a new series and manually edited the NFO to say Mythbusters Jr (without the period), but when I try to save episodes there, it gets reorganized into the bad name folder (which is what happens when it organizes into the entry with the period anyway). At the moment, I'm looking for a way to clear Auto Organize's entry for Mythbusters Jr. when you try to manually assign an episode. Clearing emby's cache did not work. Any ideas?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 03:09 AM

Posted 19 September 2019 - 01:08 PM

I would try deleting the series folder it created, then running a scan of all libraries. then try again.







Also tagged with one or more of these keywords: Auto Organize, QNAP

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users