Jump to content

Wrong sort order on Photo folders


EduardoSantos
 Share

Recommended Posts

EduardoSantos

Hi,

 

I am running MediaBrowser Server (Version 3.0.5238.39498) on a Windows 8.1 box. I also use HTML, Roku, Windows and Android apps as clients.

 

I understand the photo folder support is kind of initial and hope there will be lots of improvement on this.

 

I have, though, a problem that seems to be very simple: the display order of the images seems to be random when I choose "sort by name" (ascending or descending).

 

Both on the HTML, Roku, Android and Windows apps, this sort by name simply does not work.

 

Is there any procedure/configuration I could do to solve this?

 

Thanks

Link to comment
Share on other sites

The only name information we would have on a photo is the actual file name.  Are you sure it isn't sorting properly based on those file names?

Link to comment
Share on other sites

I didn't examine each of those names closely but a name is going to sort by alpha sort rules which will not follow numeric sort rules.

 

For instance,  '1' '2' '10' will sort as '1' '10' '2'.

Link to comment
Share on other sites

EduardoSantos
All names are the same size and their formation rule is YYYYMMDDXXZZZ where X and Z are sequential.

The alpha text order was the first thing I considered but I think it is not the case.

In the sample picture attached, for the first three images the sort order is:

- 2014051801008

- 2014051801051

- 2014051801001

Which seems not ok on alpha text order.

 

On the HTML interface I also noticed on the actual picture display that the URI is:


So there is an internal id to that image. I wondered if this would not be the "name" key.

So, for the first three images the corresponding ids are:

- ad2534008b8fdddf1d588428edd71236

- 9a1da100654edb6ce1b586fce9855b97

- a0b667042fcee6ae24be39d9bcb2057b

Which also seems not ok on alpha text order.

 

And, as I did these tests, I also discovered another weird thing:

For the second photo, named 2014051801051 (id 9a1da100654edb6ce1b586fce9855b97), the thumb displayed on the folder level does not correspond to the actual image displayed when clicked.

These tests were held on the HTML interface so I verified on the android app.

This thumb/image swap did not occur. It led me to consider browser cache so I tested again with another browser and on another machine.

Facts are that for some reason the HTML interface presents thumbs that are not from the images.

This does not occur on android app nor on the windows 8 app. BUT on the windows 8 app, the same image swapped on the HTML interface is shown as a backdrop (!?!) to the image.

Well, this seems to be another issue and I think maybe there should be another thread to this.

 

We would better stick to the sort order. You see now they are wrong?

Edited by EduardoSantos
Link to comment
Share on other sites

Is the sort also off in the Android app?

 

The backdrop is by design.  We make the image itself its own backdrop so that it will display in a large format in clients that support that.

Link to comment
Share on other sites

EduardoSantos

 

Both on the HTML, Roku, Android and Windows apps, this sort by name simply does not work.

 

Yes, in all client apps I tested.

Link to comment
Share on other sites

If you edit one of the photos in the web client what is shown in the Sort Title field?

Link to comment
Share on other sites

No it doesn't.  The Sort Name is blank...

 

That should make it fall back to a sort on the name though.

Link to comment
Share on other sites

EduardoSantos
Ok, so do you think it is a bug or am I missing something?

 

Just installed the new server version (3.0.5271.29451) and the odd behaviour is the same.

Link to comment
Share on other sites

  • 2 months later...
EduardoSantos

Well, this is just an update to report that on the current server version (3.0.5347.22095) the problem still exists.

I do not know if this issue will be addressed on a near future but I would like it very much to show photos on the corret sort order.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...
  • 1 month later...
  • 4 years later...
cnwinger

Sorry to bump this old topic, but it appears this issue still exists universally?  I'm experiencing this on Windows 7 and on the AppleTV app, on Emby Server version 4.3.0.30.  There's no rhyme or reason that I can see as to how the app sorts Photos by filename/title.  Every Photo I have has a prefix of "YYYY-MM-DD-" which works fine for sorting in Windows, Kodi, DS Photo, Plex, and basically everything else. Here's some example fillenames:

 

2018-12-25-IMG_5455
2018-05-14-IMG_4632
2018-11-10-IMG_5252
2018-03-10-IMG_4079

 

They are sorted in that exact order in Emby. Is this a known issue?

Edited by cnwinger
Link to comment
Share on other sites

Sorry to bump this old topic, but it appears this issue still exists universally?  I'm experiencing this on Windows 7 and on the AppleTV app, on Emby Server version 4.3.0.30.  There's no rhyme or reason that I can see as to how the app sorts Photos by filename/title.  Every Photo I have has a prefix of "YYYY-MM-DD-" which works fine for sorting in Windows, Kodi, DS Photo, Plex, and basically everything else. Here's some example fillenames:

 

2018-12-25-IMG_5455

2018-05-14-IMG_4632

2018-11-10-IMG_5252

2018-03-10-IMG_4079

 

They are sorted in that exact order in Emby. Is this a known issue?

 

Hi there, have you explored the different sorting options that are available?

Link to comment
Share on other sites

cnwinger

Hi there, have you explored the different sorting options that are available?

I just checked 'by Folder' and 'by Title', and both result in this weirdness. The only other sort option that really applies to Photos is 'by Date Added', which is not what I'm looking for here.

Link to comment
Share on other sites

cnwinger

Have you checked the sort title in the metadata editor for these? Is it blank for them?

 

Yes, all were blank.  When I populated the Sort Title for 3 photos that were sorting incorrectly (I just copied+pasted the titles), they then sorted correctly, placed before all the other photos. 

 

So this is a required field for Title sorting?  Is there an easy way to mass-update using the filename/Title?

Link to comment
Share on other sites

cnwinger

So this is an issue that needs to be corrected, right?  Photos don't sort correctly unless the 'Sort Title' is populated, but 'Sort Title' is not populated as part of the library scan?

Edited by cnwinger
Link to comment
Share on other sites

dbjungle

I have this exact same issue with home videos.  It seems to have started with a recent update.  If I click to sort nothing changes.  I've even tried manually tagging the mp4s, but the number and title appear to be ignored.  I'm not sure exactly when this started, but it appears to have been within the past month.  I'm having the problem on 2 servers; one Ubuntu 18.04 host and the other is on a Windows 10 1903 host.

Link to comment
Share on other sites

cnwinger

I have this exact same issue with home videos.  It seems to have started with a recent update.  If I click to sort nothing changes.  I've even tried manually tagging the mp4s, but the number and title appear to be ignored.  I'm not sure exactly when this started, but it appears to have been within the past month.  I'm having the problem on 2 servers; one Ubuntu 18.04 host and the other is on a Windows 10 1903 host.

Thanks, at least I know now it's not just me.  Just need a staff member to verify this issue will be fixed.

Edited by cnwinger
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...