Jump to content

Rocketman playback keeps halting


Lonald

Recommended Posts

Hi all,

 

The Rocketman Blu Ray keeps halting during playback, though it plays fine using external players like Leawo and Kodi.  This is occurring with both the Emby theater app for Windows as well as through the Web app on Google Chrome.  The Theater app is using Direct play and the web app is using Direct Streaming.

 

Is this a known problem - I don't see it referenced on a search here?  Media information attached.

 

Thanks!

 

 

post-876-0-49681900-1568565527_thumb.png

Link to post
Share on other sites
Guest asrequested

As it's happening on two different players, you'll need to attach your server log. But how have you set up your library addresses? What path(s) are you using for your folders?

Link to post
Share on other sites

There are a couple of spots that I've noticed, though I haven't tried to go too deep.  One is early and during the credits and the other is at 3:19.

 

Thanks!

Link to post
Share on other sites

Hi,

 

Yes it is an MKV and this is the one file I've encountered this behavior with.  Does play fine with Kodi.

 

Media Info

Video Title1080p H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.976
Bitrate34,978 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4
Audio TitleEnglish Dolby Digital 5.1
LanguageEnglish
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48,000 Hz
DefaultNo
Audio TitleFrench Dolby Digital 5.1
LanguageFrench
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48,000 Hz
DefaultNo
Audio TitleEnglish TRUEHD 7.1 (Default)
LanguageEnglish
CodecTRUEHD
Layout7.1
Channels8 ch
Sample rate48,000 Hz
Bit depth24 bit
DefaultYes
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleFrench (PGSSUB)
LanguageFrench
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleFrench (Forced PGSSUB)
LanguageFrench
CodecPGSSUB
DefaultNo
ForcedYes
ExternalNo
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Containermkv
Path\\Diskstation\Blu-Ray Movies\Rocketman (2019)\Rocketman.mkv
Size30342 MB
Edited by Lonald
Link to post
Share on other sites

Hiya,

 

MPV plays the file without any problems - at least through the first couple of spots where there's been halts.

 

And just to check, the playback halts on Emby at 3:19, which is the usual spot.

 

Thanks!

Link to post
Share on other sites

Couldn't find the audio bitstreaming, but with hardware acceleration off the playback is working!

 

Thanks!

 

Is there any other information that would help?

Link to post
Share on other sites
Guest asrequested

I think the audio is the problem. You're using optical and it's trying to output 7.1. What do you have the audio channels set to in Theater? You should have that set to auto. And if using audio bitstreaming, only select AC3 and DTS. mpv will decode all other audio, but multichannel audio will be converted to stereo. Optical only supports stereo raw audio. There is a way to have mpv convert everything that's not supported to AC3, which will support up to 5.1.

Link to post
Share on other sites
Guest asrequested


[ 0.476][v][af] [in] 48000Hz 7.1 8ch s32
[ 0.476][v][af] [userspeed] 48000Hz 7.1 8ch s32
[ 0.476][v][af] [userspeed] (disabled)
[ 0.476][v][af] [convert] 48000Hz 7.1 8ch s32
[ 0.476][v][ao] Trying audio driver 'wasapi'
[ 0.476][v][ao/wasapi] requested format: 48000 Hz, 7.1 channels, s32
[ 0.476][d][ao/wasapi] Init wasapi
[ 0.476][d][ao/wasapi] Find device ''
[ 0.485][v][ao/wasapi] No device specified. Selecting default.
[ 0.490][v][ao/wasapi] Selecting device '{e4d91b10-57fd-4a48-9dfb-a449f9416762}' (Realtek Digital Output(Optical) (Realtek High Definition Audio))
[ 0.490][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{e4d91b10-57fd-4a48-9dfb-a449f9416762}
[ 0.510][d][ao/wasapi] Init wasapi thread
[ 0.510][d][ao/wasapi] Activating pAudioClient interface
[ 0.514][d][ao/wasapi] Probing formats
[ 0.545][v][ao/wasapi] Trying 7.1 s32 (32/32 bits) @ 48000hz (shared) -> ok
[ 0.545][v][ao/wasapi] Accepted as 7.1 s32 @ 48000hz -> 7.1 s32 (32/32 bits) @ 48000hz (shared

 

Edited by Doofus
Link to post
Share on other sites

Interesting.  I do have Theater set to "Auto" for the audio.

 

I enabled audio passthrough for DTS & AC3 and the recording stopped at the same spot.

 

I also tried switching the speaker layout to Stereo without improvement.

 

Thanks!

Link to post
Share on other sites
Guest asrequested

Something is wrong. mpv by default should downmix to stereo with 7.1 audio over optical. In a little while I'm going to have you replace mpv, and try again. I just need to get to my computer.

Link to post
Share on other sites
Guest asrequested

OK, I'm going to give you something that should 'workaround' the issue, and possibly give you something that you'll prefer.

 

First, your audio settings should look like this:

 

5d87b0c708810_audiosettings.jpg

 

 

Then add this line as the first line of the mpv.conf that you made for logging.

af=lavcac3enc=yes:384:3
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...