Jump to content


Photo

Rocketman playback keeps halting


  • Please log in to reply
42 replies to this topic

#1 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 15 September 2019 - 12:46 PM

Hi all,

 

The Rocketman Blu Ray keeps halting during playback, though it plays fine using external players like Leawo and Kodi.  This is occurring with both the Emby theater app for Windows as well as through the Web app on Google Chrome.  The Theater app is using Direct play and the web app is using Direct Streaming.

 

Is this a known problem - I don't see it referenced on a search here?  Media information attached.

 

Thanks!

 

 

Attached Files



#2 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 15 September 2019 - 01:16 PM

As it's happening on two different players, you'll need to attach your server log. But how have you set up your library addresses? What path(s) are you using for your folders?



#3 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 15 September 2019 - 04:23 PM

Thanks, I have two Synology NAS devices.  The one being used for this movie is named in the library as \\Diskstation\Blu-Ray Movies\Rocketman (2019)

 

Server log is attached.

Attached Files



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138217 posts
  • Local time: 12:53 PM

Posted 15 September 2019 - 05:31 PM

Does it always stop at the exact same spot?



#5 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 15 September 2019 - 09:25 PM

There are a couple of spots that I've noticed, though I haven't tried to go too deep.  One is early and during the credits and the other is at 3:19.

 

Thanks!



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138217 posts
  • Local time: 12:53 PM

Posted 16 September 2019 - 12:18 PM

And they are consistent?

#7 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 17 September 2019 - 07:53 PM

Yes, they are.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138217 posts
  • Local time: 12:53 PM

Posted 18 September 2019 - 12:32 PM

And it's only this file? Is it an mkv?

#9 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 18 September 2019 - 07:00 PM

Hi,

 

Yes it is an MKV and this is the one file I've encountered this behavior with.  Does play fine with Kodi.

 

Media Info

Video Title1080p H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.976
Bitrate34,978 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4
Audio TitleEnglish Dolby Digital 5.1
LanguageEnglish
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48,000 Hz
DefaultNo
Audio TitleFrench Dolby Digital 5.1
LanguageFrench
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48,000 Hz
DefaultNo
Audio TitleEnglish TRUEHD 7.1 (Default)
LanguageEnglish
CodecTRUEHD
Layout7.1
Channels8 ch
Sample rate48,000 Hz
Bit depth24 bit
DefaultYes
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleFrench (PGSSUB)
LanguageFrench
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Subtitle TitleFrench (Forced PGSSUB)
LanguageFrench
CodecPGSSUB
DefaultNo
ForcedYes
ExternalNo
Subtitle TitleEnglish (PGSSUB)
LanguageEnglish
CodecPGSSUB
DefaultNo
ForcedNo
ExternalNo
Containermkv
Path\\Diskstation\Blu-Ray Movies\Rocketman (2019)\Rocketman.mkv
Size30342 MB

Edited by Lonald, 18 September 2019 - 07:01 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138217 posts
  • Local time: 12:53 PM

Posted 19 September 2019 - 02:07 AM

Would you mind trying it in mpv for windows and see how that compares?

https://mpv.io/installation/

 

You should be able to just drag the file onto the window. thanks.



#11 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 19 September 2019 - 06:46 AM

Hiya,

 

MPV plays the file without any problems - at least through the first couple of spots where there's been halts.

 

And just to check, the playback halts on Emby at 3:19, which is the usual spot.

 

Thanks!



#12 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 19 September 2019 - 10:17 AM

Try disabling audio bitstreaming and hardware acceleration in theater.

Edited by Doofus, 19 September 2019 - 12:18 PM.


#13 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 19 September 2019 - 08:01 PM

Couldn't find the audio bitstreaming, but with hardware acceleration off the playback is working!

 

Thanks!

 

Is there any other information that would help?



#14 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 19 September 2019 - 08:03 PM

Spoke too soon.  The playback stopped at 5:32 into the movie.

 

Grrr....



#15 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 19 September 2019 - 09:35 PM

Can you follow this and post the log, please? 

 

https://emby.media/c...ng-for-theater/



#16 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 20 September 2019 - 06:58 AM

Attached.

Attached Files



#17 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 20 September 2019 - 09:37 AM

Did you stop playback when it paused itself? Or did you resume?

#18 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 20 September 2019 - 09:59 AM

I think the audio is the problem. You're using optical and it's trying to output 7.1. What do you have the audio channels set to in Theater? You should have that set to auto. And if using audio bitstreaming, only select AC3 and DTS. mpv will decode all other audio, but multichannel audio will be converted to stereo. Optical only supports stereo raw audio. There is a way to have mpv convert everything that's not supported to AC3, which will support up to 5.1.

#19 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12300 posts
  • Local time: 09:53 AM

Posted 20 September 2019 - 10:19 AM

[ 0.476][v][af] [in] 48000Hz 7.1 8ch s32
[ 0.476][v][af] [userspeed] 48000Hz 7.1 8ch s32
[ 0.476][v][af] [userspeed] (disabled)
[ 0.476][v][af] [convert] 48000Hz 7.1 8ch s32
[ 0.476][v][ao] Trying audio driver 'wasapi'
[ 0.476][v][ao/wasapi] requested format: 48000 Hz, 7.1 channels, s32
[ 0.476][d][ao/wasapi] Init wasapi
[ 0.476][d][ao/wasapi] Find device ''
[ 0.485][v][ao/wasapi] No device specified. Selecting default.
[ 0.490][v][ao/wasapi] Selecting device '{e4d91b10-57fd-4a48-9dfb-a449f9416762}' (Realtek Digital Output(Optical) (Realtek High Definition Audio))
[ 0.490][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{e4d91b10-57fd-4a48-9dfb-a449f9416762}
[ 0.510][d][ao/wasapi] Init wasapi thread
[ 0.510][d][ao/wasapi] Activating pAudioClient interface
[ 0.514][d][ao/wasapi] Probing formats
[ 0.545][v][ao/wasapi] Trying 7.1 s32 (32/32 bits) @ 48000hz (shared) -> ok
[ 0.545][v][ao/wasapi] Accepted as 7.1 s32 @ 48000hz -> 7.1 s32 (32/32 bits) @ 48000hz (shared

Edited by Doofus, 20 September 2019 - 10:26 PM.


#20 Lonald OFFLINE  

Lonald

    Advanced Member

  • Members
  • 109 posts
  • Local time: 11:53 AM

Posted 22 September 2019 - 10:45 AM

Interesting.  I do have Theater set to "Auto" for the audio.

 

I enabled audio passthrough for DTS & AC3 and the recording stopped at the same spot.

 

I also tried switching the speaker layout to Stereo without improvement.

 

Thanks!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users