Jump to content


Photo

Have to reboot Mac to restart Emby

reboot Mac

  • Please log in to reply
32 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153449 posts
  • Local time: 02:45 PM

Posted 31 January 2020 - 09:23 PM

Great, thanks!

#22 Michael - S OFFLINE  

Michael - S

    Newbie

  • Members
  • 7 posts
  • Local time: 06:45 PM

Posted 05 February 2020 - 04:33 PM

I have Emby server running on a Mac Mini 2012 with High Sierra (never bothered to upgrade to Mojave like my other Macs, probably should).  Have had no issues rebooting Emby server, it does take several minutes though, but I don't have to reboot the macOS. 



#23 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 08 February 2020 - 01:47 PM

I have Emby server running on a Mac Mini 2012 with High Sierra (never bothered to upgrade to Mojave like my other Macs, probably should). Have had no issues rebooting Emby server, it does take several minutes though, but I don't have to reboot the macOS.


Interesting. Mine is an ongoing battle. It all revolves around launching at boot or restarting, neither seems to happen consistently.

I can’t restart the app without booting entire machine, ever. The most recent beta seems to make this worse. Maybe dB is corrupted.

#24 Michael - S OFFLINE  

Michael - S

    Newbie

  • Members
  • 7 posts
  • Local time: 06:45 PM

Posted 08 February 2020 - 02:21 PM

I just upgraded the Mini to Mojave. Emby is running fine, able to restart the server no problem. I’m guessing you have a corrupt database or install. You might try backing up your media, and completely uninstalling (using an app like AppCleaner) and reinstall.
  • meatball likes this

#25 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 08 February 2020 - 08:14 PM

Yup, did exactly that and it’s night/day better. Once I read your experience was different I came to the same conclusion that something was corrupted.

When I wiped it out and reinstalled it I could see it was way more responsive. I was able to restore my previous config and so far so good.

Thanks for chiming in.
  • Michael - S likes this

#26 Michael - S OFFLINE  

Michael - S

    Newbie

  • Members
  • 7 posts
  • Local time: 06:45 PM

Posted 08 February 2020 - 08:50 PM

Awesome, glad it helped.



#27 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 09 February 2020 - 03:39 PM

So the app is definitely more responsive and I can reboot as needed. Im still running into the issue of crashing. something is happening on my end that triggers it when I interact with the metadata or the treatments plugin I think. It just crashed and I grabbed the logs/attached them here. I also included a sample below outlining the permissions error right before it crashed. 

 

Possibly worth noting- Looking through my previous log when it crashed was the same error with a different TV shown a different path/network storage.. The only similarity is it seems to be only happening when interacting with the server through the iOS app. This might be a coincidence but whenever I do something via the browser I haven't run into this (least not yet).

 

I'd be grateful for any guidance or suggestions. Thanks a lot. 

 

Edit- I'm getting the same error with a lot of the plugins. I attached a 2nd log showing the same error with another plugin. 

 

 

 

*** Error Report ***

Version: 4.4.0.12
Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll -noautorunwebapp
Operating system: Unix 18.7.0.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime: file:///Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
System.Environment.Version: 3.1.1
Processor count: 12
Program data path: /Users/damien/emby-server
Application directory: /Applications/EmbyServer.app/Contents/MacOS
System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path '/Volumes/plex_media/TV/Brick City/tvshow.nfo' is denied.
---> System.IO.IOException: Permission denied
  --- End of inner exception stack trace ---
  at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
  at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
  at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
  at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions)
  at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Boolean isAsync)
  at NfoMetadata.Savers.BaseNfoSaver.SaveToFile(Stream stream, String path)
  at NfoMetadata.Savers.BaseNfoSaver.Save(BaseItem item, CancellationToken cancellationToken)
  at MediaBrowser.Providers.Manager.ProviderManager.SaveMetadata(BaseItem item, LibraryOptions libraryOptions, ItemUpdateType updateType, IMetadataSaver[] savers, CancellationToken cancellationToken)
Source: System.Private.CoreLib
TargetSite: Void ThrowExceptionForIoErrno(ErrorInfo, System.String, Boolean, System.Func`2[Interop+ErrorInfo,Interop+ErrorInfo])
InnerException: System.IO.IOException: Permission denied
Source: 
TargetSite: 
 
2020-02-09 10:58:17.679 Info HttpServer: HTTP GET http://192.168.0.158...89dd&quality=50. UserAgent: Mozilla/5.0 (iPad; CPU OS 13_1_2 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2020-02-09 10:58:17.695 Info HttpServer: HTTP Response 200 to 192.168.0.184. Time: 16ms. http://192.168.0.158...89dd&quality=50
2020-02-09 10:58:22.033 Info HttpServer: HTTP OPTIONS 
 

Attached Files


Edited by meatball, 09 February 2020 - 03:56 PM.


#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153449 posts
  • Local time: 02:45 PM

Posted 09 February 2020 - 03:41 PM

 

So the app is definitely more responsive and I can reboot as needed. Im still running into the issue of crashing. something is happening on my end that triggers it when I interact with the metadata or the treatments plugin I think. It just crashed and I grabbed the logs/attached them here. I also included a sample below outlining the permissions error right before it crashed. 

 

Possibly worth noting- Looking through my previous log when it crashed was the same error with a different TV shown a different path/network storage.. The only similarity is it seems to be only happening when interacting with the server through the iOS app. This might be a coincidence but whenever I do something via the browser I haven't run into this (least not yet).

 

I'd be grateful for any guidance or suggestions. Thanks a lot. 

 

 

 

*** Error Report ***

Version: 4.4.0.12
Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll -noautorunwebapp
Operating system: Unix 18.7.0.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime: file:///Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
System.Environment.Version: 3.1.1
Processor count: 12
Program data path: /Users/damien/emby-server
Application directory: /Applications/EmbyServer.app/Contents/MacOS
System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path '/Volumes/plex_media/TV/Brick City/tvshow.nfo' is denied.
---> System.IO.IOException: Permission denied
  --- End of inner exception stack trace ---
  at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
  at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
  at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
  at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions)
  at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Boolean isAsync)
  at NfoMetadata.Savers.BaseNfoSaver.SaveToFile(Stream stream, String path)
  at NfoMetadata.Savers.BaseNfoSaver.Save(BaseItem item, CancellationToken cancellationToken)
  at MediaBrowser.Providers.Manager.ProviderManager.SaveMetadata(BaseItem item, LibraryOptions libraryOptions, ItemUpdateType updateType, IMetadataSaver[] savers, CancellationToken cancellationToken)
Source: System.Private.CoreLib
TargetSite: Void ThrowExceptionForIoErrno(ErrorInfo, System.String, Boolean, System.Func`2[Interop+ErrorInfo,Interop+ErrorInfo])
InnerException: System.IO.IOException: Permission denied
Source: 
TargetSite: 
 
2020-02-09 10:58:17.679 Info HttpServer: HTTP GET http://192.168.0.158...89dd&quality=50. UserAgent: Mozilla/5.0 (iPad; CPU OS 13_1_2 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2020-02-09 10:58:17.695 Info HttpServer: HTTP Response 200 to 192.168.0.184. Time: 16ms. http://192.168.0.158...89dd&quality=50
2020-02-09 10:58:22.033 Info HttpServer: HTTP OPTIONS 

 

 

This snippet shows that you turned on saving to nfo files but did not ensure write access to your folders is available. So as a result it is trying to save nfo files but your file system is throwing access denied errors.



#29 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 09 February 2020 - 04:00 PM

This snippet shows that you turned on saving to nfo files but did not ensure write access to your folders is available. So as a result it is trying to save nfo files but your file system is throwing access denied errors.

 

Thanks for pointing that out. Weird it writes in the same folder for other things. Ill double check the permissions. 

 

Do you think the permissions issue with .nfo file could cause the crash?



#30 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153449 posts
  • Local time: 02:45 PM

Posted 09 February 2020 - 07:47 PM

No I'd want to see the complete log file for that.

#31 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 10 February 2020 - 01:42 AM

No I'd want to see the complete log file for that.

 

sorry totally thought I'd attached it previously, that's attached here. I grabbed it right after it crashed. Thanks for your help @Happy2Play please move my posting to the testing area. thanks.

Attached Files


Edited by Luke, 10 February 2020 - 01:46 AM.


#32 meatball OFFLINE  

meatball

    Advanced Member

  • Members
  • 82 posts
  • Local time: 11:45 AM

Posted 11 February 2020 - 06:16 PM

FYI, removing the plugin stopped the crashing. Im getting multiple plugin errors in the logs but nothing external as far as I can tell. Ill direct this to the testing area. Thanks again



#33 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153449 posts
  • Local time: 02:45 PM

Posted 11 February 2020 - 07:03 PM

Great, thanks !







Also tagged with one or more of these keywords: reboot, Mac

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users