Jump to content


Photo

MPV questions


  • Please log in to reply
25 replies to this topic

#21 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 626 posts
  • Local time: 09:06 AM

Posted 11 September 2019 - 08:30 PM

Thanks doofus. I'm trying this out right now, and it's starting to look pretty good.

#22 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 626 posts
  • Local time: 09:06 AM

Posted 11 September 2019 - 10:35 PM

One more quick question doofus, will MPV get me the same level of pq that I get with a Blu-ray or is that an unrealistic expectation. Some other things I notice are a screen door effect or jagged edges in zoomed out camera shots, and faces are still pretty soft. Will adjusting the interlacing settings in ET or at the graphics card yield any improvement.

#23 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12062 posts
  • Local time: 06:06 AM

Posted 11 September 2019 - 10:58 PM

Are you playing interlaced media? If yes, do you have deinterlacing, enabled?


Edited by Doofus, 11 September 2019 - 11:00 PM.


#24 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12062 posts
  • Local time: 06:06 AM

Posted 11 September 2019 - 11:14 PM

The deinterlacing will try to use the GPU deinterlacing capabilities. I don't know what your GPU does. You could check what options there are in your GPU settings. The 'jagged' that you see, is aliasing. In your case, it might just be using yadif, which will cause some aliasing. I have an Nvidia GPU and I don't have any aliasing.

Edited by Doofus, 12 September 2019 - 02:51 PM.


#25 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12062 posts
  • Local time: 06:06 AM

Posted 12 September 2019 - 12:29 AM

You could also try this
vf=d3d11vpp=deint=yes:interlaced-only=yes:mode=adaptive
But when using a video filter, I'd suggest start using auto-profiles. You don't want that enabled all the time. It might force 8 bit surfaces for all videos, and screw with 10 bit stuff.

Options, here

https://mpv.io/manua...ilters-d3d11vpp

Edited by Doofus, 12 September 2019 - 03:09 PM.


#26 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12062 posts
  • Local time: 06:06 AM

Posted 12 September 2019 - 10:01 PM

So you would set the deinterlacing option in Theater to 'no', and use this config;

hwdec=d3d11va
scale=ewa_lanczossharp
deband
deband-iterations=2
vf=d3d11vpp=deint=yes:interlaced-only=yes:mode=adaptive

or if you use it at as an auto-profile (you will need the script), it will look like this;

hwdec=d3d11va
scale=ewa_lanczossharp
deband
deband-iterations=2

[Interlaced]
profile-desc=cond:p["video-frame-info/interlaced"]
vf=d3d11vpp=deint=yes:interlaced-only=yes:mode=adaptive





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users