Jump to content

Android 10 Live Playback


dhunterjacobs
 Share

Recommended Posts

Just going to throw out a guess and I'll test this later - Check in the Android settings for the app to see if the app is being forced into low power or battery optimized mode. For Live TV the app uses a larger memory buffer for being able to seek the live stream. Perhaps it's being denied access to this and not handling it very well and just crashing.

Link to comment
Share on other sites

speedingcheetah

Just going to throw out a guess and I'll test this later - Check in the Android settings for the app to see if the app is being forced into low power or battery optimized mode. For Live TV the app uses a larger memory buffer for being able to seek the live stream. Perhaps it's being denied access to this and not handling it very well and just crashing.

App settings have not changed since 9.0 

Background restriction: App can use battery in the background.

 

Battery optimization: Optimizing battery usage.

 

Toggling the latter, no change. still crash

Link to comment
Share on other sites

dhunterjacobs

Luke - if you want to use me as a test, I'm happy to let you remotely control my phone to see what's happening and check things out. Just a thought.

Link to comment
Share on other sites

If the OS asks you to submit crash logs, please make sure to do that because we'll be able to see them in our developer account. Thanks.

Link to comment
Share on other sites

speedingcheetah

If the OS asks you to submit crash logs, please make sure to do that because we'll be able to see them in our developer account. Thanks.

Not possible. it crashes too fast I cant even see the crash message or options...it just goes to the lock screen, unlock, then see frozen pixelated vid stream, try to play, instantly back to lock screen.

Link to comment
Share on other sites

dhunterjacobs

An additional tidbit. I just tried on my wife's phone. Same as mine. Pixel 3. She's on Android 10. Her live playback works fine. Only difference I can think of is I was on the Android 10 beta prior to upgrading to the final Android 10 release. She was on stable Android 9 then upgraded to Android 10. *shrug*

Link to comment
Share on other sites

An additional tidbit. I just tried on my wife's phone. Same as mine. Pixel 3. She's on Android 10. Her live playback works fine. Only difference I can think of is I was on the Android 10 beta prior to upgrading to the final Android 10 release. She was on stable Android 9 then upgraded to Android 10. *shrug*

 

Different build number?

Link to comment
Share on other sites

speedingcheetah

An additional tidbit. I just tried on my wife's phone. Same as mine. Pixel 3. She's on Android 10. Her live playback works fine. Only difference I can think of is I was on the Android 10 beta prior to upgrading to the final Android 10 release. She was on stable Android 9 then upgraded to Android 10. *shrug*

Is the full gesture navigation enabled on her phone?

because that is the ONLY setting that seems to affect this issue for me.

Edited by speedingcheetah
Link to comment
Share on other sites

dhunterjacobs

Surprisingly, different build number. I'm on QP1A.190711.020. She's on QP1A.190711.019. I'm running full gesture navigation. She's running 2-button navigation.

Link to comment
Share on other sites

dhunterjacobs

I just switched my phone to 2-button navigation and live TV works fine. It definitely has something to do with full gesture navigation. There's a bug related to live playback and that.

Link to comment
Share on other sites

dhunterjacobs

SiliconDust HDHomeRun Prime. The fact that it works fine on my phone with 2-button navigation and doesn't work with gesture navigation tells me something is up with gesture navigation. That's just my 2 cents lol.

Link to comment
Share on other sites

Yes, it all has to do with gesture navigation. My Pixel 3 works fine with gesture navigation off. Live TV won't work with it on.

 

Understood.

 

Have you tried the Web player?

Link to comment
Share on other sites

Understood.

 

Have you tried the Web player?

 

I never thought about trying that but I just did and it works fine! Good temporary fix until the app is updated. Thanks for the idea!

Link to comment
Share on other sites

I never thought about trying that but I just did and it works fine! Good temporary fix until the app is updated. Thanks for the idea!

 

I actually stopped using the app completely and use just the Web app now.

 

Might not be the best solution for everyone, but for me, it's great.

Link to comment
Share on other sites

speedingcheetah

I actually stopped using the app completely and use just the Web app now.

 

Might not be the best solution for everyone, but for me, it's great.

 

It is not a solution at all.... just delete and not use dedicated app....

 

Web app does not direct play, it transcodes.

 

I have been using the full navigation gestures thing since it came out in is early forum in 9. It would hard for me to go back to the old school way of navigating things. And i wont just for the odd times i want to watch live tv on my phone. Much easier just to have to use the HDhomeun app to play livetv, though that will only work at home network.

 

I would think, A proper fix to resolve this issue should be quite straight forward...as it has be narrowed down to the setting/feature of the OS that causes it from the very beginning of it being reported, by multiple users.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...