Jump to content

5.1 FLAC files not playing in 5.1


Shkrmaker
 Share

Recommended Posts

I was directed towards Emby after a Plex bug stopped 5.1 FLAC files from playing, but I'm having the same issue with Emby. 

 

It might be something in the settings I don't have configured correctly, but I can't find much audio-specific to configure. I know it's not my system or my AppleTV, because the files play correctly using VLC, however I'd rather use Emby because I can last.fm scrobble and the interface is just much more pleasant. But the files basically play in stereo with "phantom surround" instead of playing in discreet 5.1.  Is this just another bug or am I doing something wrong?

Link to comment
Share on other sites

I would suspect that you are doing something wrong. I get 5.1 sound from 5.1 FLAC using the AppleTV emby app. I even get 7.1 sound from 7.1 FLAC. I am at a loss to know what is wrong for you though. Perhaps, your movie files are not quite correct format somehow, and, VLC is more forgiving. There really aren't many AppleTV settings, I just use AUTO for audio in AppleTV.

 

You should enclose a copy of the log files for the video.

Edited by sfatula
Link to comment
Share on other sites

I would suspect that you are doing something wrong. I get 5.1 sound from 5.1 FLAC using the AppleTV emby app. I even get 7.1 sound from 7.1 FLAC. I am at a loss to know what is wrong for you though. Perhaps, your movie files are not quite correct format somehow, and, VLC is more forgiving. There really aren't many AppleTV settings, I just use AUTO for audio in AppleTV.

 

You should enclose a copy of the log files for the video.

 

I'm not playing video files, just FLAC audio. They used to work on Plex, but there's a known bug that Plex hasn't addressed yet, so I'm trying Emby. 

 

It might be something I'm doing, but I know the issue isn't the files themselves, or my AppleTV.  It's just strange. Sometimes when I start playing, it automatically changes the mode on my receiver, but I'm not sure why it's doing this. 

Link to comment
Share on other sites

I've attached a log file where I played "How The West Was Won And Where It Got Us" by REM, which is my "test" file, since it's easy to tell if the 5.1 is working since the mix has clear isolated instruments in the real channel within the first 5 seconds of the intro. 

 

You'll find that around halfway through the log (not sure what else I'm looking for in here)

embyserver-63702892799.txt

Edited by Shkrmaker
Link to comment
Share on other sites

That's strange. We are direct playing it using the system audio player. We'll have to look into whether or not it supports 5.1 flac.

Link to comment
Share on other sites

Vlc is not using the system audio player. We are direct playing it using the system audio player. We'll have to look into whether or not it supports 5.1 flac.

Link to comment
Share on other sites

  • 2 weeks later...

Yeah, movie files are a different matter entirely. It's a different player/mechanism/etc, I'm guessing. In general, I've often found these kind of apps (Plex as well) are mostly video/movie focused, and music/audio files are sort of second-fiddle for most users, so functionality is iffy.

 

There's some test 5.1 files at archive.org: https://archive.org/details/5.1SurroundSoundTestFilesVariousFormatsAACAC3MP4DTSWAV

Link to comment
Share on other sites

The only file I find on that site is a 2.0 flac. So, no way for me to test your example. You asked if it's working for other emby users, I offered to assist and tell you, but need a sample that you have used and does not work, not random web downloads. Up to you.

Link to comment
Share on other sites

Sorry I thought a file labeled 5.1 test file would actually be in 5.1

 

Here's the REM song I use to test. There's a very prominent shaker in the intro that should come out of the rear left speaker, and a little keyboard blip that should come from the other rear just before the main band comes in: http://www.filefactory.com/file/55cd3cma9lsb/01_-%20How%20The%20West%20Was%20Won%20And%20Where%20It%20Got%20Us.flac

Link to comment
Share on other sites

Current beta Apple TV app has strange behavior regarding multi channel flac with 4.2.0.1 and 4.3.10 @@Luke

 

I notice now that multi channel flac ONLY plays in multi channel, when played, AFTER a multi channel movie is played. When Emby app is started fresh, multi channel flac plays ONLY in stereo with my setup.

Don't know if this is a new issue with tvOS 13 combined with the Emby app ?

Link to comment
Share on other sites

it's probably tvos13 related. These are going to be direct playing through the server where there's no processing on the source files. It's unlikely the server could have that kind of impact unless it was transcoding.

Link to comment
Share on other sites

Can someone also confirm that 5.1 flac file always plays in 5.1, when before flac playback, a DD5.1 movie is played in the Emby Apple TV beta app ?

Link to comment
Share on other sites

I suspect tvOS 13 even more, now I just experienced in Netflix app, that a 5.1 movie starts in stereo and ONLY switches to 5.1 by selecting another audio language track and switching back again to default audio track.

Link to comment
Share on other sites

So I downloaded the file and played it in emby as music. I used direct, no dolby settings, etc. And I heard what you described. So, it seems to work for me if I understand correctly.

Link to comment
Share on other sites

Can someone also confirm that 5.1 flac file always plays in 5.1, when before flac playback, a DD5.1 movie is played in the Emby Apple TV beta app ?

Well, some more of the same type problem:

 

https://www.quadraphonicquad.com/forums/index.php?threads/appletv-tvos-13-to-break-5-1-mp4-playback.27119/

 

I will note that the Amazon Prime app does correctly play 2.0 and 5.1 movies correctly, every time in tvos 13. So, it can be done.

Edited by sfatula
Link to comment
Share on other sites

I am having the same problem as well. I purchased Emby because Plex was taking forever to fix the issue with multi-channel music. It sure looks like the Apple music player is the culprit here and that, I suppose, means that the media players (plex and emby) will have to write their own code to support multi-channel music? I'm going to bring up my Roku and see how that works. This just sucks!  Has anyone tried other audio formats? Will Emby play ALAC files? 

Link to comment
Share on other sites

I've been having the same problem, both here and using Plex. Today I finally gave up and am streaming Emby to a Chromecast device. It seems to be the only thing that is working these days. 

Link to comment
Share on other sites

  • 7 months later...

Is this moving forward at all? Is it on a to do list? Emby is useless to me without this. Plex is building their own audio player, but it has been over a year and nothing. 

Link to comment
Share on other sites

Hi.  Nothing specific at this time.  We are always looking to improve it but Apple is not a great platform for broad format support :).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...