Jump to content


Photo

How to update Emby version in Linux?

debian update upgrade linux

Best Answer Luke , 19 August 2019 - 09:29 PM

Ok so you just update by installing the latest version the same way you installed 4.0.2. Does that make sense?

Go to the full post


  • Please log in to reply
26 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:52 AM

Posted 18 November 2019 - 12:35 AM

We do support running the apps with older versions of the server, but only up to a point.

We generally try to set the line at supporting older versions that are you to a year old. Any more than that and it just becomes unrealistic in terms of the amount of testing and development required.

In some cases it might require us to build entire features in multiple different ways just to accommodate older versions. At some point we have to look at the cost of that and make difficult decisions about whether that's feasible or not.

#22 acnp77 OFFLINE  

acnp77

    Advanced Member

  • Members
  • 224 posts
  • Local time: 12:52 PM
  • LocationSwitzerland

Posted 21 November 2019 - 02:21 PM

Thank you for explaining... cheers



#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:52 AM

Posted 22 November 2019 - 12:03 PM

Did you update?



#24 acnp77 OFFLINE  

acnp77

    Advanced Member

  • Members
  • 224 posts
  • Local time: 12:52 PM
  • LocationSwitzerland

Posted 24 November 2019 - 06:09 PM

Thanks for asking. Yes, I just finished a complete new installation of emby-server on debian 10.

There is still a lot to configure, but the basic system is up. I am a bit confused though. With the old version I had to install many dependencies and other stuff like ffmpeg, mono etc. Now I just installed one file, it took like 2 minutes and that's it.

Seems great! Thanks!

I am running new the server in parallel with the old one until everything is setup.

 

QUESTIONS:

- can I use my premiere key on both servers until I delete the old one?

- Does transcoding still depend on ffmpeg?

 

CHEERS


Edited by acnp77, 24 November 2019 - 06:10 PM.


#25 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:52 AM

Posted 24 November 2019 - 06:12 PM

Thanks for the feedback! The answers are yes and no. Ffmpeg is still used but it's embedded in the install package so that you don't have to worry about installing it.
  • acnp77 likes this

#26 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17134 posts
  • Local time: 03:52 AM
  • LocationWashington State

Posted 24 November 2019 - 06:15 PM

Thanks for asking. Yes, I just finished a complete new installation of emby-server on debian 10.

There is still a lot to configure, but the basic system is up. I am a bit confused though. With the old version I had to install many dependencies and other stuff like ffmpeg, mono etc. Now I just installed one file, it took like 2 minutes and that's it.

Seems great! Thanks!

I am running new the server in parallel with the old one until everything is setup.

 

QUESTIONS:

- can I use my premiere key on both servers until I delete the old one?

- Does transcoding still depend on ffmpeg?

 

CHEERS

 

Can I use my Emby Premiere key on more than one server



#27 acnp77 OFFLINE  

acnp77

    Advanced Member

  • Members
  • 224 posts
  • Local time: 12:52 PM
  • LocationSwitzerland

Posted 24 November 2019 - 08:07 PM

@Happy2Play

Thanks for the additional info. And yes, sorry, I should have searched for the answer first :(







Also tagged with one or more of these keywords: debian, update, upgrade, linux

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users