Jump to content


Photo

Live TV Spinning Wheel

qnap

Best Answer softworkz , 18 August 2019 - 10:11 PM

Is this because of the “hardware” my Emby server is running in? Ie the QNAP?

Can it be a ffmpeg issue? Although isn’t this built into Emby now?

I don’t care about getting this to work on all devices as I only really use the Xbox to view Emby content.

Given that the m3u list is free should I be using a premium or paid device to get these channels?

Would buying something like a HD homerun fix the issue it would I still have a spinning wheel ?

Really appreciate all the help.

 

It's likely not a hardware issue. 

 

One thing you can try is to use 

 

VLC/3.0.1

 

for the user agent instead of just 'VLC'.

Go to the full post


  • Please log in to reply
39 replies to this topic

#21 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 07:05 PM

This seems to be playing h264 ok in Chrome, though it may not be exactly the same stream. EDIT - though it is via NextPVR v5.

 

5d59d9b6897cc_EmbyAUchannelplaying.jpg


Edited by arrbee99, 18 August 2019 - 07:09 PM.


#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139873 posts
  • Local time: 10:16 AM

Posted 18 August 2019 - 07:52 PM

Try the native support. That makes the comparison apples to oranges.



#23 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 08:22 PM

Native support  (I think, did it quickly but should be) -

 

5d59ebaf9ff96_EmbyAUchannelplayingnative



#24 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 08:28 PM

and via NPVR in Emby

 

5d59ed0b2e4f5_EmbyAUchannelplayingnative



#25 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 08:29 PM

Different container. Wonder if they're different streams of the same stuff. Oh well...



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139873 posts
  • Local time: 10:16 AM

Posted 18 August 2019 - 08:33 PM

So that's his stream you're using?



#27 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 08:45 PM

The one in post 23 is from a downloaded file of urls from someone called Matt Huisman which I downloaded and added channel numbers too, so it from the same guy but might be out of date somehow.

 

The one in post #24 is from Matt Huisman but its from a url of his, so it should be more up to date, but its actually from NPVR and the plugin.

 

This image below, is from Matt Huisman, also using a url of his, should be the same as the above being used in NPVR, but this time its directly in Emby.

 

Got from here https://www.matthuis...-epg-files.html

 

5d59f0307ed60_EmbyAUchannelplayingnative

 

Hope I'm vaguely helping and not just confusing the issue, which I'm sure you've noticed I'm good at.



#28 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1855 posts
  • Local time: 04:16 PM

Posted 18 August 2019 - 09:19 PM

Hope I'm vaguely helping and not just confusing the issue, which I'm sure you've noticed I'm good at.

 

You're right, this is not overly helpful, but what would be really helpful: when you could try to reproduce with the identical setup that he has described in the initial posts...



#29 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 09:44 PM

Well I'm trying to use the same source as the OP using the latest beta server, but there's not much I can do about being in a different country or not having a QNAP thingy. I just don't know the exact channels that have been tried.



#30 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1855 posts
  • Local time: 04:16 PM

Posted 18 August 2019 - 09:49 PM

Well I'm trying to use the same source as the OP using the latest beta server, but there's not much I can do about being in a different country or not having a QNAP thingy. I just don't know the exact channels that have been tried.

 

He didn't say that some are working and some aren't. 

 

What I meant is using the exact same configuration that he's using:

 

I am using this file for my M3U Tuner https://shadowtek.com.au/au-iptv.m3u and this for my EPG https://i.mjh.nz/au/Sydney/epg.xml

 

 

 

...but I had assumed you were both from the same country..



#31 shadowtek OFFLINE  

shadowtek

    Member

  • Members
  • 14 posts
  • Local time: 01:16 AM
  • LocationAustralia

Posted 18 August 2019 - 09:59 PM

Thanks everyone for your input.

Not sure if this helps. The streams and epg work perfectly using other apps like vlc or iptv apps on the iPad. They seem just not to want to work on Emby of any platform.

Is this because of the “hardware” my Emby server is running in? Ie the QNAP?

Can it be a ffmpeg issue? Although isn’t this built into Emby now?

I don’t care about getting this to work on all devices as I only really use the Xbox to view Emby content.

Given that the m3u list is free should I be using a premium or paid device to get these channels?

Would buying something like a HD homerun fix the issue it would I still have a spinning wheel ?

Really appreciate all the help.

#32 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 10:04 PM

He didn't say that some are working and some aren't. 

 

What I meant is using the exact same configuration that he's using:

 

 

 

...but I had assumed you were both from the same country..

 

Fair enough. Those are good points.



#33 arrbee99 OFFLINE  

arrbee99

    Advanced Member

  • Members
  • 3029 posts
  • Local time: 04:16 AM
  • LocationNew Zealand

Posted 18 August 2019 - 10:08 PM

Deleted.


Edited by arrbee99, 18 August 2019 - 10:15 PM.


#34 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1855 posts
  • Local time: 04:16 PM

Posted 18 August 2019 - 10:11 PM   Best Answer

Is this because of the “hardware” my Emby server is running in? Ie the QNAP?

Can it be a ffmpeg issue? Although isn’t this built into Emby now?

I don’t care about getting this to work on all devices as I only really use the Xbox to view Emby content.

Given that the m3u list is free should I be using a premium or paid device to get these channels?

Would buying something like a HD homerun fix the issue it would I still have a spinning wheel ?

Really appreciate all the help.

 

It's likely not a hardware issue. 

 

One thing you can try is to use 

 

VLC/3.0.1

 

for the user agent instead of just 'VLC'.


  • shadowtek likes this

#35 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1855 posts
  • Local time: 04:16 PM

Posted 18 August 2019 - 10:57 PM

@shadowtek - Your playlist is incorrect. It MUST start with the token '#EXTM3U'

 

I can't tell whether that's the problem, but it could be.



#36 shadowtek OFFLINE  

shadowtek

    Member

  • Members
  • 14 posts
  • Local time: 01:16 AM
  • LocationAustralia

Posted 18 August 2019 - 11:53 PM

@softworkz Thanks 

 

I have added VLC/3.0.1 to the user agent http header and updated the m3u file to 

#EXTM3U x-tvg-url="https://i.mjh.nz/au/Sydney/epg.xml"

#EXTINF:-1 tvg-id="tv.101406020625" tvg-logo="https://i.mjh.nz/au/images/tv.101406020625.png",TEN
https://i.mjh.nz/au/Sydney/tv.101406020625.m3u8

#EXTINF:-1 tvg-id="tv.101406020628" tvg-logo="https://i.mjh.nz/au/images/tv.101406020628.png",10 Peach
https://i.mjh.nz/au/Sydney/tv.101406020628.m3u8

#EXTINF:-1 tvg-id="tv.101406020621" tvg-logo="https://i.mjh.nz/au/images/tv.101406020621.png",10 Bold
https://i.mjh.nz/au/Sydney/tv.101406020621.m3u8

#EXTINF:-1 tvg-id="tv.101305020520" tvg-logo="https://i.mjh.nz/au/images/tv.101305020520.png",Seven
https://i.mjh.nz/au/Sydney/tv.101305020520.m3u8

#EXTINF:-1 tvg-id="tv.101305020528" tvg-logo="https://i.mjh.nz/au/images/tv.101305020528.png",RACING.COM
https://i.mjh.nz/au/Sydney/tv.101305020528.m3u8

#EXTINF:-1 tvg-id="tv.7pac12" tvg-logo="http://i.mjh.nz/au/images/tv.7pac12.png",PAC-12
https://i.mjh.nz/au/Sydney/tv.7pac12.m3u8

#EXTINF:-1 tvg-id="tv.7outdoor" tvg-logo="http://i.mjh.nz/au/images/tv.7outdoor.png",Outdoor Channel
https://i.mjh.nz/au/Sydney/tv.7outdoor.m3u8

#EXTINF:-1 tvg-id="tv.101305020523" tvg-logo="https://i.mjh.nz/au/images/tv.101305020523.png",7mate
https://i.mjh.nz/au/Sydney/tv.101305020523.m3u8

#EXTINF:-1 tvg-id="tv.101305020527" tvg-logo="https://i.mjh.nz/au/images/tv.101305020527.png",7food network Sydney
https://i.mjh.nz/au/Sydney/tv.101305020527.m3u8

#EXTINF:-1 tvg-id="tv.101305020525" tvg-logo="https://i.mjh.nz/au/images/tv.101305020525.png",7flix
https://i.mjh.nz/au/Sydney/tv.101305020525.m3u8

#EXTINF:-1 tvg-id="tv.101305020522" tvg-logo="https://i.mjh.nz/au/images/tv.101305020522.png",7TWO
https://i.mjh.nz/au/Sydney/tv.101305020522.m3u8

#EXTINF:-1 tvg-id="tv.320203000307" tvg-logo="https://i.mjh.nz/au/images/tv.320203000307.png",SBS World Movies Sydney
https://i.mjh.nz/au/Sydney/tv.320203000307.m3u8

#EXTINF:-1 tvg-id="tv.320203000303" tvg-logo="https://i.mjh.nz/au/images/tv.320203000303.png",SBS VICELAND HD
https://i.mjh.nz/au/Sydney/tv.320203000303.m3u8

#EXTINF:-1 tvg-id="tv.320203000302" tvg-logo="http://i.mjh.nz/au/images/tv.320203000302.png",SBS VICELAND
https://i.mjh.nz/au/Sydney/tv.320203000302.m3u8

#EXTINF:-1 tvg-id="tv.320203000304" tvg-logo="https://i.mjh.nz/au/images/tv.320203000304.png",SBS Food
https://i.mjh.nz/au/Sydney/tv.320203000304.m3u8

#EXTINF:-1 tvg-id="tv.320203000301" tvg-logo="https://i.mjh.nz/au/images/tv.320203000301.png",SBS
https://i.mjh.nz/au/Sydney/tv.320203000301.m3u8

#EXTINF:-1 tvg-id="tv.320203000305" tvg-logo="https://i.mjh.nz/au/images/tv.320203000305.png",NITV
https://i.mjh.nz/au/Sydney/tv.320203000305.m3u8

#EXTINF:-1 tvg-id="tv.101204200421" tvg-logo="https://i.mjh.nz/au/images/tv.101204200421.png",Channel 9
https://i.mjh.nz/au/Sydney/tv.101204200421.m3u8

#EXTINF:-1 tvg-id="tv.101204200424" tvg-logo="https://i.mjh.nz/au/images/tv.101204200424.png",9Life
https://i.mjh.nz/au/Sydney/tv.101204200424.m3u8

#EXTINF:-1 tvg-id="tv.101204200428" tvg-logo="https://i.mjh.nz/au/images/tv.101204200428.png",9Go!
https://i.mjh.nz/au/Sydney/tv.101204200428.m3u8

#EXTINF:-1 tvg-id="tv.101204200427" tvg-logo="https://i.mjh.nz/au/images/tv.101204200427.png",9Gem
https://i.mjh.nz/au/Sydney/tv.101204200427.m3u8

#EXTINF:-1 tvg-id="tv.101002210220" tvg-logo="https://i.mjh.nz/au/images/tv.101002210220.png",ABC NEWS
https://i.mjh.nz/au/Sydney/tv.101002210220.m3u8

#EXTINF:-1 tvg-id="tv.101002210224" tvg-logo="https://i.mjh.nz/au/images/tv.101002210224.png",ABC ME
https://i.mjh.nz/au/Sydney/tv.101002210224.m3u8

#EXTINF:-1 tvg-id="tv.101002210222" tvg-logo="http://i.mjh.nz/au/images/tv.abckids.png",ABC KIDS
https://i.mjh.nz/au/Sydney/tv.101002210222.m3u8

#EXTINF:-1 tvg-id="tv.abc2" tvg-logo="http://i.mjh.nz/au/images/tv.abc2.png",ABC Comedy
https://i.mjh.nz/au/Sydney/tv.abc2.m3u8

#EXTINF:-1 tvg-id="tv.101002210221" tvg-logo="https://i.mjh.nz/au/images/tv.101002210221.png",ABC
https://i.mjh.nz/au/Sydney/tv.101002210221.m3u8

#EXTINF:-1 tvg-id="tv.redbull.tv" tvg-logo="http://i.mjh.nz/au/images/tv.redbull.tv.png",Redbull TV
https://i.mjh.nz/au/Sydney/tv.redbull.tv.m3u8

#EXTINF:-1 tvg-id="tv.fox.sports.news" tvg-logo="http://i.mjh.nz/au/images/tv.fox.sports.news.png",Fox Sports News
https://i.mjh.nz/au/Sydney/tv.fox.sports.news.m3u8

#EXTINF:-1 tvg-id="tv.acctv" tvg-logo="http://i.mjh.nz/au/images/tv.acctv.png",ACCTV
https://i.mjh.nz/au/Sydney/tv.acctv.m3u8

Tested and still get the spinning wheel and nothing else :(



#37 shadowtek OFFLINE  

shadowtek

    Member

  • Members
  • 14 posts
  • Local time: 01:16 AM
  • LocationAustralia

Posted 19 August 2019 - 12:09 AM

UPDATE: There has been some advancements :) 

 

So i did the above changes and also disabled the Nordvpn connection the Qnap was running on and after a few restarts of emby most streams are now playing.

 

I still get the spinning wheel for about 5 secs then the player appears with an image of the show and i can then hit play and again after a few seconds it starts to play.

 

Is this normal behaviour?

 

So im not sure what the solution was but im too scared to change it again incase it stops working lol



#38 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139873 posts
  • Local time: 10:16 AM

Posted 19 August 2019 - 12:19 AM

Well the vpn will add an additional layer of complication there.



#39 softworkz OFFLINE  

softworkz

    Advanced Member

  • Developers
  • 1855 posts
  • Local time: 04:16 PM

Posted 19 August 2019 - 12:20 AM

Also the VPN might hide your origin which the iptv provider uses to verify your access.

 

From Germany for example, those streams are blocked.



#40 shadowtek OFFLINE  

shadowtek

    Member

  • Members
  • 14 posts
  • Local time: 01:16 AM
  • LocationAustralia

Posted 19 August 2019 - 12:24 AM

I can see how this could be an issue and I’m sorry I didn’t even think of it before hand....

I will just schedule the VPN for late night downloading and off during viewing times for Emby.

I will test it more tonight and hopefully get the stream working well enough so I can record them. Don’t really need to watch through Emby but would love to record.

Thanks again everyone





Also tagged with one or more of these keywords: qnap

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users