Jump to content


Photo

Music playback bug? Songs randomly restart halfway through


  • Please log in to reply
5 replies to this topic

#1 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 660 posts
  • Local time: 11:20 AM

Posted 17 August 2019 - 12:21 PM

I tried an "Instant Mix" from my Music library in Emby, using the AppleTV client. Every so often, partway through a song, it woudl pause and restart the song. It did this in several songs over a couple hours of listening. There are a total of 44 log files from that time frame, 40 of which are the transcode logs. I've attached a handful of them below.

Attached File  embyserver-63701510401.txt   180.12KB   0 downloads

Attached File  ffmpeg-transcode-d08aed65-20e8-4afb-9313-a0a840e889b9_1.txt   5.68KB   2 downloads

Attached File  ffmpeg-transcode-b9f54e81-9a3a-4904-9202-97455af21327_1.txt   6.31KB   0 downloads

Attached File  hardware_detection-63701585692.txt   222.75KB   0 downloads

Attached File  hardware_detection-63701585695.txt   222.75KB   0 downloads


Edited by ShoutingMan, 17 August 2019 - 12:21 PM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46935 posts
  • Local time: 11:20 AM

Posted 18 August 2019 - 10:54 AM

Hi.  Does the same thing happen with the same songs on the web app?  Also, are these songs also transcoding when played that way?



#3 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 660 posts
  • Local time: 11:20 AM

Posted 19 August 2019 - 08:51 PM

Hi. Does the same thing happen with the same songs on the web app? Also, are these songs also transcoding when played that way?

I will try to repeat this and find out.

I don’t know if all the songs are transcoded. There are more songs transcoded than have the restart problem.

Edited by ShoutingMan, 19 August 2019 - 08:53 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137605 posts
  • Local time: 11:20 AM

Posted 20 August 2019 - 02:16 PM

Yes let us know how the web app compares. thanks.



#5 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 660 posts
  • Local time: 11:20 AM

Posted 29 September 2019 - 08:23 PM

Yes let us know how the web app compares. thanks.

 

I tried the web interface from a client machine on my LAN and it seemed to play normally. I think I played enough songs that I would have heard several restarts.

 

But in the AppleTV, multiple songs restart during a playback.

 

I don't use music much, so it's hard to gather bug-report data (that is, if it worked perfectly on the AppleTV, I'd use it all the time. But these quirks make it unusable and I just go back to the cable music stations).

 

So, if there's some tests I can do, let me know and I'll get to them as soon as I can. :)



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46935 posts
  • Local time: 11:20 AM

Posted 30 September 2019 - 08:37 AM

Sounds like it is related to them being transcoded.  Can you find the ffmpeg log for one of the songs that actually had the problem?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users