Jump to content
Attidudinal

BIG Endless loop bug in Emby - and resultant problems

Recommended Posts

Attidudinal

Since this won't allow a copy / paste function the explanation, what was done, and how it corrupted the DB is attached.

WON'T REWRITE THE WHOLE STORY - Suggest this page get modified to accept content.

 

Occurs when trying to preface the "sort" title with "The"

Emby_Loop.rtf

Share this post


Link to post
Share on other sites
Luke

Hi, thanks for reporting. Can you please provide the server log from when this happened?

Share this post


Link to post
Share on other sites
Attidudinal

Not sure a log was made... had to terminate the program (stop through WebGUI) to make it functional again. (as stated, it was in a loop)

Logs were subsequently made and the one that I saved from that period of time can be forwarded; as soon as I find a way to attach it.

I believe it was the report which told me the DB was corrupted after a couple of Dashboard alerts that Library scan had failed.

ONLY able to get Emby working again through a complete restoration of last backup. That was 10 days ago, however as of today,

I started another thread on the failure of Emby to update when "Identify information supplied...

and then, Libraries failed to scan and STILL will not.

What gives?  Seems like Emby goes downhill as soon as a problem is encountered.

An inspection of the logs only shows a failure of ffdetect and ffmpeg due to /usr/lib/emby-server not existing

(in case that has anything to do with these issues)

It has never existed that I know of - emby installation (as with apps) is automated in unRAID through use of dockers.

So, where is an "attach" button for the reply so I can send you what I have?

Looks like its under More Reply Options, here.

Thanks

 

BTW - No failure to scan Libraries or any kind of DB corruption was ever encountered

(in months amounting to years) until this "loop" bug.

 

 

embyserver-63700611676.txt

Share this post


Link to post
Share on other sites
Luke

Is this about the time when you used the metadata editor?

2019-08-05 14:17:04.340

Share this post


Link to post
Share on other sites
Attidudinal

Yep.  Edit Metadata.  Enter "sort title" prefaced with "The" whatever

If you have a test system available, give it a go.

You gonna love the results (make sure your DB is backed-up)

The "loop" was encountered every time I tried it.

And, as it's in a loop, the program will have to be abended.

Share this post


Link to post
Share on other sites
Luke

Had you done that prior to this log file, or was that time the first time?

Share this post


Link to post
Share on other sites
Attidudinal

The loop was encountered prior to that log file being produced.

Here is a list of all the logs, all of the same date and time.

 

all_loop.rtf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...