Jump to content

Cannot get Library to show/read movie files Linux install


Go to solution Solved by mastrmind11,

Recommended Posts


Hello all. I apologize in advance if this is long and sound nuts.


I have just about lost my mind as I have spent last 5 days on Google and these forums trying desperately to get Emby to work. (by the way I have seen the software work on a friend at work and was blown away so I immediately signed up for premiere account. So I know it is possible and will be great once I get it going. Only difference is I want to use Linux and not windows like my friend. Major Kudos to the developer for this awesome software.)


To my problem, as stated in title, I'm running Emby on a (at first) headless Ubuntu server 18.04.3 and now due to difficulties I have installed the LXDE desktop environment to help trouble shoot. The install and Emby setup went fine and appears to be working. I can go to a Windows Host and access the Emby control panel and default user screen.


The setup  I want Emby on this Ubuntu Server ( 4GBs RAM, 250GB SSD) to be able to access and show my library that is going to be hosted (for now) on a Synology NAS (DS713+ 4TBs with latest updates).  So far I have only uploaded about 3 movie MKV files to the share on the Synology. This share is "Videos". I was able to add it as a library in the EMby control panel and set up.


I believe the issue has to do with permissions and access to the Synology share. (I also tried setting up a temp share on a windows client as well and cannot get Emby to scan that library either, so I am double convinced it is something I am doing wrong on the Linux side of things. Which can be seen in the attached Embylog.txt)


On the Synology I have shared the Videos folder and given just about everyone read/write access to it, including an account I created called "emby" with NO password. It is not locked down and access should be wide open.


I believe I need to mount this shared folder on the Ubuntu server so the emby account/service running there can access the folder and scan library.


I am able to successfully mount the Synology Share folder "Videos" to either the / directory or within my users /home directory. BUT it seems that "ROOT" is always the owner of the mounted directory (both user and group). I cannot seem to find a way to change this? Also when I tried mounting it in the "/home" directory it says emby is owner and emby group, but still no access when I try to read/scan the library from Emby control panel.


For example for the Home Mount I did:

 sudo mount -t cifs -0 username=emby,password=,uid=999,gid=999 // ~/mnt/share

Which does mount the directory of the Synology share and allows me to browse it. But when I try scanning my this library from Emby control panel it fails. (the log txt shows //JAYNAS which is the same as IP of


Here is another example I tried testing a mount to windows share:

sudo mount.cifs // /windows-share -o user=emby

This too worked and from linux side I can browse the share, but Emby server cannot scan library. (Here I do see owner as root and group as root so that is probably why, but I don't know how to fix this as "chown" fails on a mount and will not change permissions.)


So if you have read this far:


Is there any guide or install help that explains when running Emby from a Linux server how to get it to read a library from another Device (like NAS) or computer? Does it need to be a permanent mount in "/etc/fstab"  and if so what account or permissions need to be assigned? Is this something specific to Synology Shares? (I dont think so as my Windows efforts have failed as well.)


I'm going nuts as I feel there HAS to be a way to do this on Linux and it is probably simple, and I'm missing it. But the mounting of shares and permissions is killing me. ( I do not want to run this on Windows. Seems like there is a lot of windows help online and would be easier, but no. I love Linux and Open source too much and don't wish to go back unless there was no other way. I just currently suck at Linux administration obviously.)


Thanks in advance  whoever can read all this and possibly help. (Heck if a clear solution is found or commands in Linux that works, I'll go and write up a guide to help the next person here on the forums if allowed.)


Edited by greyhulk1976
Link to comment
Share on other sites

  • Solution

It most definitely works on Linux w/ mounted NAS shares.


Looking at your logs there are a bunch of 

SharpCifs.Smb.SmbException: SharpCifs.Smb.SmbException: smb://jaynas/

when you initiate the library scan.  Obviously an smb issue.  What version of SMB are you running on the server and nas?  Are they compatible?  It's either that or a permission issue.  If I were you I would use NFS instead of CIFS.  Much easier to use in *nix land with better performance.  And while this should work w/ a mount command to test it out, you'll definitely want to use fstab to make the mounts permanent.  You'll want to make sure you have permissions set properly on BOTH your nas and your server when using NFS (ie, make sure your nas has an emby or whoever user as well as your server, with matching uids etc).  Once thats set up, this is what my fstab looks like for one of my shares /storage/movies/Kids nfs rsize=8192,wsize=8192,timeo=14,intr

That should do it.  Post back with how you get on.

  • Like 1
Link to comment
Share on other sites




Thanks for the tip. I spent the day looking up info on NFS shares and mounting them. I came home and deleted all the current libraries, then set up the NFS shares on my Emby server and Synology following mainly these two sites:






I was able then to have the NFS share in "fstab" and auto-mount on boot...BUT STILL could NOT get library path to work or add it. I was so frustrated and was beginning to take screen shots of the system , when I again thought about "permissions". I then went and "Chown- R" the mounted directory on the Emby server to the "emby" account and "Chmod -R 777" to the same folder structure. ( I know, 777 is not the best or most secure, but it is working for now.)


BOOM! Success. Finally after nearly 2 weeks...I can now see my movies in Emby and stream them to my devices at home. Now I just have to continue to learn the application ( and Linux better as well) and take it from here.


I appreciate the quick response and help!  (Also big props to fellow Long Islander! I now reside in PHX, but spent first 38 yrs of my life on Long Island.)


I still may later come back and try to write a tutorial for someone else going through this for the first time, but I mainly was slapping things against the wall to try and make it all work. Once I 100% have down what works in a process and those damn permissions, I'll come back to do it.


Anyways, consider  this closed and thanks again!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...