Jump to content

Purchased theme now acting as trial MB2x


WarrenH
 Share

Recommended Posts

Previously purchased lotus theme and today am getting a message "Lotus trial period has ended please purchase". Was working fine for the past 3 years and up until this morning.

 

MB2 configuration no shows no themes or plugins. Can only assume someone's cut off something to the MB2 server plugins?

 

 

5389caba83983_2.jpg

 

5389cacab7c06_1.jpg

 

Link to comment
Share on other sites

Beardyname

@@ebr

 

Also the Infrastructure for MB2 is gone so that might be it, never used mb2 so ebr should be able to give a better answer :)

Link to comment
Share on other sites

All MB 2 infrastructure is gone.  There have been several announcements and lots of discussion about this out here.  Here is one such discussion.

Link to comment
Share on other sites

Ahh, must have been the thread header "wow what happened" that wasn't under the legacy section that slipped my eye,

Pity that we're now forced to the vanilla MB2 theme or to MB3 which doesn't easily support entry points. Sure a simple change to the legacy plugins could have removed their dependency on the online MB2 servers and kept us old timers happy - @@Soultaker?

 

Sent from my HTC One using Tapatalk

Edited by WarrenH
Link to comment
Share on other sites

To be fair, MB2 is at the end of life point and it is an extreme drag on the developer's resources to support a dead product and a new version since they are not a company with many employees. You have to go with the flow since they have to provide for families.

 

Here is my suggestion for what many have done since EBR created an MB2 emulation in the MB3 environment.

 

1. Preserve your present MB2 setup by creating a backup that can be used in the future.

 

2. Select the time of entry into MB3 when it has reached critical mass for you.

 

Finally the viewing habbits of users has changed dramatically we with the Home Theater room or the dedicated entertainment area are the dinosaurs. Most persons watch content today on portable devices and MB2 was never intended for that. So MB2 was heading into extinction no matter if the developers would support it or not and it has nothing to do with MS's lack of support for WMC. People are getting away from watching content on TVs or other large displays.

Link to comment
Share on other sites

Fully appreciate your comments; I use MB3 on my main machine which serves our handheld devices and a Roku, and there's no doubt it's fantastic software.

MB2 is on our lounge PC, which we use exclusively for all our viewing, including Sat TV. We don't have any terrestrial, cable or Sat boxes. MB2 is in my opinion with its entry points and simplification 100% WAF.

I do image my drives for fallback, however this is useless as the MB2 plugins are dependant on MB internet servers for license validation - that I'm saying could have been easily avoided with a little effort. I don't know of any other purchased software that expires, even Win XP still works despite not being supported.

Creating a preservation point wouldn't keep my previously purchased plugins.

 

Sent from my HTC One using Tapatalk

Edited by WarrenH
Link to comment
Share on other sites

Sure, small effort, if you can go hunt down those developers and twist their arms.

Link to comment
Share on other sites

MB2 is on our lounge PC, which we use exclusively for all our viewing, including Sat TV. We don't have any terrestrial, cable or Sat boxes. MB2 is in my opinion with its entry points and simplification 100% WAF.

I do image my drives for fallback, however this is useless as the MB2 plugins are dependant on MB internet servers for license validation - that I'm saying could have been easily avoided with a little effort.

The thread WOW What happened addresses that problem. Many of us love Throg's themes and when the MB2 servers dissapeared, the trial option popped up. That is internally of the specific Plug-In. There is nothing that the MB3 team can do because those themes are locked to them. As Luke mentioned they tried to get the developers of those themes to correct that but to no avail, those developers abandoned their clients, not the MB3 team.

 

EBR went beyond the call of duty and authenticated Throg's themes for his users. Throg has been MIA from this site and his products for many months. We all are hoping and wishing that some of the MB2 developers will adapt their themes for MB3, but that is the specific developer's choice.

 

I hear you loud and clear about the WAF issue, have you tried the Chocolate theme? It seems to be promising.

Link to comment
Share on other sites

Fully appreciate your comments; I use MB3 on my main machine which serves our handheld devices and a Roku, and there's no doubt it's fantastic software.

MB2 is on our lounge PC, which we use exclusively for all our viewing, including Sat TV. We don't have any terrestrial, cable or Sat boxes. MB2 is in my opinion with its entry points and simplification 100% WAF.

I do image my drives for fallback, however this is useless as the MB2 plugins are dependant on MB internet servers for license validation - that I'm saying could have been easily avoided with a little effort. I don't know of any other purchased software that expires, even Win XP still works despite not being supported.

Creating a preservation point wouldn't keep my previously purchased plugins.

 

Sent from my HTC One using Tapatalk

 

I wrote a handler on our new servers that mimics the old MB 2 validation.  So, if you have things not validating now it must be some sort of hard-end date in the software itself and there is nothing I can do about that.

Link to comment
Share on other sites

Can you be so kind to post what version of Lotus you are running?

 

EDIT

 

Actually version is irrelevant, the last version of Lotus had no such hard expiry.

Edited by Soultaker
Link to comment
Share on other sites

Okay - then this may be some other issue.  Maybe a temporary problem with your connection.

 

However, I can tell you that the metadata fetching for MB 2 is probably not going to work like it should anymore either because tmdb changed their image host and MB 2 will be looking in the wrong place.

Link to comment
Share on other sites

Okay - then this may be some other issue.  Maybe a temporary problem with your connection.

 

However, I can tell you that the metadata fetching for MB 2 is probably not going to work like it should anymore either because tmdb changed their image host and MB 2 will be looking in the wrong place.

Hi EBR, metadata not required, I'm using metabrowser and also have MB3 installed with media on network NAS. I have internet providers turned off in MB2. Lotus appears to be version 1.004.

 

All I'm after is for Lotus to work on MB2, I have a purchased license key. User @@Ansgar seems to be in the same situation.

 

@@Soultaker - any thoughts? Is there not a standalone version / changed DLL that can be used to resolve the license issue?

Edited by WarrenH
Link to comment
Share on other sites

As above it seems to be 1.004 - per the xml file as I obviously can't use the plug-in to verify

I did a new install in Feb this year

If you see my screen pics above you'll see there are no themes available on the configurator

MB in Win MC won't run unless I switch to the standard theme

 

Sent from my HTC One using Tapatalk

Edited by WarrenH
Link to comment
Share on other sites

The .dll is probably still on your hard disk. Go to C:\programdata\mediabrowser\plugins and see if you can locate the Lotus.dll and view it's properties to find out the version number.

Link to comment
Share on other sites

Soultaker, I'll look tonite, I assume then it's been updated for MB2 since Feb 2014 when as I said. I did a fresh new install?

 

Sent from my HTC One using Tapatalk

Link to comment
Share on other sites

Soultaker, the DLL shows version 2.0.0.0 (lotus.dll)

 

Sent from my HTC One using Tapatalk

Link to comment
Share on other sites

That was the last version of Lotus that was released for MB2.

Hmmm

Do you have any log files I can view?

Link to comment
Share on other sites

@@Soultaker - tried the version you sent thanks.

 

Replaced original DLL with your DLL in hidden programdata folder. However Lotus no longer lists as a display option theme, only the standard theme. When returning to the original DLL, Lotus shows as a theme though obviously with the previously indicated expiration issue.

 

I see your new DLL is around 150kb whereas the standard DLL is around 250kb, possibly there's some code missing? Any continued help will be most appreciated.

 

Warren

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...