Jump to content


Photo

Slow loading times / delays on web frontend and crashes

slow loading times web delay

  • Please log in to reply
1 reply to this topic

#1 DelSol OFFLINE  

DelSol

    Member

  • Members
  • 21 posts
  • Local time: 11:22 AM

Posted 05 August 2019 - 05:55 AM

So I just figured out why my web frontend seems to be unresponsive and slow from time to time and wanted to share my experience in case anyone stumbles about the same issues.

 

my setups is:

emby in docker on unraid behind a pfsense firewall linked with an nginx docker as reverse proxy.

 

In the past I had the issue, that my web page loading times are super slow. the categorys would show fast, but everything underneath takes up to 10 seconds to load, sometimes even crashes the server and kills stable connections from other users. Also I had slow loading times on the admin page and everywhere. 

I fiddled around with stable/beta of emby and nginx and tried different versions, checked my firewall and could not figure it out. 

In the end it was the fact that I forwarded my connections from the encrypted nginx connection to the encrypted 8920 port of the emby container. I tried several certificate options there as well but just plain forward it unencrypted internally to 8096 solved my problems and the website is faster than ever. 

 

I hope this helps anyone who might has the same issue and if the emby team wants to dig deeper into this just let me know.

 

greetings from germany. DelSol


Edited by DelSol, 05 August 2019 - 05:55 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 05:22 AM

Posted 05 August 2019 - 02:39 PM

Interesting, thanks for the info !







Also tagged with one or more of these keywords: slow, loading times, web, delay

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users