Jump to content

"More from Season" Scrolls back to 1st Episode since Server 4.2.0.40 update


Mobius
 Share

Recommended Posts

Mobius

Hi.

 

When using Emby Theatre for Windows; the "More from Season" thumbnails load showing episodes that come next as usual, but now in addition to that; it immediately auto scrolls the thumbnails back to the 1st episode of the season.

 - I have tested this on 2 Different machines using Emby Theater for Windows and the results are the same.
 - The Web interface however; on both those machines does not 'auto scroll' back to the 1st episode.

 - Using Emby Theatre for Windows 3.08 running Windows 10 Pro 1903.

 

Odd that I did not notice the behaviour when I first updated to 4.2.0.40. a few days ago as I have only just noticed this happening today. Maybe I'm getting senile :).

Anyone else seeing this?

Cheers :)
 

Edited by Mobius
Link to comment
Share on other sites

Mobius

Sorry should have included screenshots to illustrate.

 

Here is the Web interface where I have selected Episode 9. You can see in "More from Season" that Episode 9 is also shown shown as well as 10, 11 etc. When the episode finishes it returns to here and you can easily select the next episode (10 in this example). So no issue.

 

5d406a62b8213_WebInterface_Firefox.jpg

 

However if I select the same episode 9 within Emby Theatre it loads the same as the Web Interface above, but then the "More from Season" immediately scrolls (auto scrolls) back the the beginning of the season. You can no longer see or select the next episode after 9.  (see below).

 

5d406b1d7cc2b_EmbyTheatre_Windows.jpg

 

Thanks

Edited by Mobius
Link to comment
Share on other sites

Why can't you select it?

 

I imagine he can select it - it just isn't readily in view because the list is positioning at the beginning instead of on the current episode.

 

Mobius - are all the episodes in this series already watched?

Link to comment
Share on other sites

Mobius

I imagine he can select it - it just isn't readily in view because the list is positioning at the beginning instead of on the current episode.

 

Thanks ebr for clarifying that. Yes that is is exactly what I meant.

 

Mobius - are all the episodes in this series already watched?

 

Yes in the example I have given; however I have checked other seasons in which all the episodes are not watched and still see the same behavior of the "More from Season" list automatically "positioning at the beginning".

 

To help narrow the issue down a bit; I unzipped a copy of emby-theater-3.08-x64.zip which I had download in late June this year and ran it directly from the folder. I simply entered the path to the server and signed in making no other configuration changes and the results are the same. That suggests to me that the behavior is server side related.

 

Thanks

Edited by Mobius
Link to comment
Share on other sites

Mobius

Thanks, we'll take a look.

 

Cheers Luke. Much Appreciated! :)

Edited by Mobius
Link to comment
Share on other sites

  • 2 weeks later...
Mobius

UPDATE:

 

Decided to test emby-theater-3.06-x64 and emby-theater-3.04-x64 in portable mode as I did with 3.08  which I mentioned in my previous post.

 

- 3.06: The "More from Season" list automatically "positions at the beginning".

- 3.04  Works perfectly fine. (No re-positioning)

Link to comment
Share on other sites

  • 2 weeks later...
Mobius

Hey Luke

Was looking at the 'Overlay missing on 3.0.8' thread when I saw a post by Doofus here: https://emby.media/community/index.php?/topic/72982-overlay-missing-on-308/page-8&do=findComment&comment=779972
Asking if people had tried the latest test build. Followed it, then saw your comment re wanting to release an app update using 'electron 6.03' rather that 5.

Anyway I gave the test build a go and it has solved my "More from Season" list automatically "positions at the beginning" issue.

So I'm all good it seems. Just thought I'd let you know.

Cheers.

 

Update:

 

BTW; version 3.09 navigation through the libraries, menus etc is DAMN FAST with 4.2.1.0 on my 3rd Gen i7 laptop using HD 4000 and Samsung SSD.

Also like the navigation/option changes and aesthestics that I've seen so far.

Edited by Mobius
Link to comment
Share on other sites

There are some definite recent improvements in the app's performance, and combining that with the improvements of Chromium 77, that's why you're seeing that.

  • Like 1
Link to comment
Share on other sites

  • 1 year later...
Mobius

Well would you believe the behaviour is back again..

The curious thing this time is that when I tested this on another system; the "More from Season" did not Initially scroll back to the first episode.

However it did when I closed ET and then restarted it. Both systems are using 'Emby theatre for Windows 3.0.15.'

Tested 3.0.14. Again, no scrolling back to the first episode initially. Then upon a restart, it did

Tested 3.0.13 exact same behaviour. Fine until after a restart.

So it seems something is 'updating/changing' which is not coming into effect until after ET has been restarted. Then the problem persists.

Any Ideas?

 

Update:

Ok this only appears to be happening with shows where I have already watched the entire season and have reset it to 'unplayed' to watch again.

It does not do it with seasons I have never watched before.

'Next Up' still works as it should BTW.

 

Edited by Mobius
added more specific info
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...