Jump to content

Emby on Google Home: I can't reach your Emby server.


jellelle
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

jellelle

Hi,

 

I bought a Google mini to play around with, but I can't seem to get Emby to connect.

 

The things I did:

  • My server (v 4.2.0.40) is behind a reverse proxy on port 443 (https://emby.website.com)
  • I created a Emby Connect user and I can log in with my browser at https://app.emby.media/
  • I link Emby Home in Google Home. I fill out the credentials and get to choose which of my servers (only have 1) I want to connect with.

Then I get this message:

5d3c5f2b19f9f_00204f376bc7d4cfccdc2ddc0f

 

 

Which seems weird to me because the app knows the name of my server.

How can I fix this?

 

Thanks,

Jelle

Edited by jellelle
Link to comment
Share on other sites

jellelle

Hi, did you use the same Emby Connect user when setting up google home?

 

I think I don't understand your question completely but:

the user (the email address) on Google Home is different then the user (the email address) on Emby Connect.

Link to comment
Share on other sites

jellelle

I unlinked the previous account and used the email address from the Google Home account to create and link a new Emby connect account.


Again I get the option to select which server I want to use (as in: Google Home sees the name of my server), but I get the same "I can't reach your Emby server" error message.


 


I have unchecked Allow remote connections to this Emby Server because traffic is handled by the reverse proxy.


Link to comment
Share on other sites

  • Solution
Angelblue05

According to logs, the remote address provided by your emby server does not reflect your reverse proxy.

 

For this to work, you need to update your server settings.

 

In your server settings > advanced;

 

Enable allow remote connections. Change secure connection mode to handled by reverse proxy.

 

Set your public https port to 443

 

Set your external domain ie emby.blah.com

 

You want your remote address in the dashboard to reflect the address via your reverse proxy otherwise clients won’t know the way to reach your server externally. Once that is done, restart your server, and it should hopefully work. If not, go through the emby home to emby connect linking process once more. This should get you going.

Edited by Angelblue05
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

jellelle

According to logs, the remote address provided by your emby server does not reflect your reverse proxy.

 

For this to work, you need to update your server settings.

 

In your server settings > advanced;

 

Enable allow remote connections. Change secure connection mode to handled by reverse proxy.

 

Set your public https port to 443

 

Set your external domain ie emby.blah.com

 

You want your remote address in the dashboard to reflect the address via your reverse proxy otherwise clients won’t know the way to reach your server externally. Once that is done, restart your server, and it should hopefully work. If not, go through the emby home to emby connect linking process once more. This should get you going.

 

Yes, that did the trick.

Thanks!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...