Jump to content


Photo

Transcode just video?

transcode

  • Please log in to reply
8 replies to this topic

#1 pgalbavy OFFLINE  

pgalbavy

    Advanced Member

  • Members
  • 59 posts
  • Local time: 06:52 PM

Posted 24 July 2019 - 10:35 AM

I have Emby (current beta) on a Linux server playing on an nvidia shield TV. There are some high bitrate films ripped from my blurays that stutter. I have installed the nvideo 7.2.3+ firmware (their eng release #4 it says) and this makes no odds. I did wait to get this installed before asking this, but it made no difference and I see no settings I need to make in the firmware settings.

 

If I click through the "playback problems" option then it transcodes both video and audio at a high enough rate so as to look fine with no stuttering but the HD audio gets transcoded to DD. Is there any feasible way to leave the audio alone in these case?

 

Specific films that have given me problems recently are Baraka and Samsara - both of which appear to be encoded at about 40Mbp/sec; For reference:

 

Baraka:

 

Video
Title1080p VC1
CodecVC1
Codec tagWVC1
ProfileAdvanced
Level3
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.976
Bitrate38,167 kbps
Pixel formatyuv420p
Ref frames1
 
Samsara:
 
Video
Title1080p H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.976
Bitrate41,052 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4

 

 

Edit: I am certain the underlying issue is on the nvidia as plex gives exactly the same stuttering on direct playback


Edited by pgalbavy, 24 July 2019 - 10:41 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139768 posts
  • Local time: 01:52 PM

Posted 24 July 2019 - 12:41 PM

Hi there, let's go over an example. Please attach the information requested in how to report a media playback issue. thanks.



#3 pgalbavy OFFLINE  

pgalbavy

    Advanced Member

  • Members
  • 59 posts
  • Local time: 06:52 PM

Posted 25 July 2019 - 05:40 AM

Will do, but I am going to do one more thing - copy mkv(s) to storage and try playing directly to exclude any network issues (I have tried both Ethernet and WiFi - the former constrained to 100Mbps because of location, the latter reporting 600MBps but it's WiFi). If it's the nvidia then I'll take the problem to their forums.



#4 pgalbavy OFFLINE  

pgalbavy

    Advanced Member

  • Members
  • 59 posts
  • Local time: 06:52 PM

Posted 28 July 2019 - 09:16 AM

So, copied files to HDD. Played locally on nvidia shield TV and they still stutter - looks like it simply can't cope with the bitrates.

 

Back to my original question; Can I transcode just video to help get over this narrow set of issues until/unless the shield gets fixed in a future update?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139768 posts
  • Local time: 01:52 PM

Posted 28 July 2019 - 09:40 AM

Can we please go over an example based on my request above? Thanks.

#6 pgalbavy OFFLINE  

pgalbavy

    Advanced Member

  • Members
  • 59 posts
  • Local time: 06:52 PM

Posted 28 July 2019 - 09:48 AM

I'm genuinely confused. What information do you need to answer the question / request about if there is a way to only transcode video? I have established that the playback problem is not Emby (or Plex) but the media player and I would really like to keep the audio as "pass through" but down-rate the video stream. 


Edited by pgalbavy, 28 July 2019 - 09:49 AM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139768 posts
  • Local time: 01:52 PM

Posted 28 July 2019 - 11:28 PM

 

 

if there is a way to only transcode video

 

We already do this whenever possible, so if this isn't already happening then I'd want to look at an example so that I can explain why.



#8 pgalbavy OFFLINE  

pgalbavy

    Advanced Member

  • Members
  • 59 posts
  • Local time: 06:52 PM

Posted 29 July 2019 - 03:13 AM

Understood. Will do a clean restart and test later to get new logs.

#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139768 posts
  • Local time: 01:52 PM

Posted 29 July 2019 - 01:34 PM

Thanks !







Also tagged with one or more of these keywords: transcode

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users