Jump to content

"no such module: FTS5" on UPDATE/DELETE


Recommended Posts


I have been living with a "ghost" playlist issue for some time now (placed a m3u file in a lib folder, then deleted it, then added it back, and since the playlist contents have been "frozen"), so today decided to give a manual fix a try inspecting/manipulating the db directly.
I think the root cause is that the record in the db does not have a path to the corresponding m3u file anymore

Because of this I decided (after a db backup) to attempt both UPDATE and DELETE of the record, but in both cases I get back the error in the title... 
My experience with sqlite is non-existent, so I tried doing this from multiple clients (extenal dBeaver adapter, TNAS's pre-installed 'sqlite3' binary, and again using the TNAS's python + sqlite adapter), but the error is consistent.

Does anybody have any suggestion / had similar issues?

Thanks in advance


Device: F2-220
TOS version: 4.0.13
Emby Server version:

Link to comment
Share on other sites

Hi, it sounds like their preinstalled sqlite version is too old. Do you know what version it is?

Link to comment
Share on other sites

Hi Luke, sorry for late reply

[root@TNAS-0032A4 ~]# sqlite3 --version
3.21.0 2017-10-24 18:55:49 1a584e499906b5c87ec7d43d4abce641fdf017c42125b083109bc77c4de48827

But my assumption was this is just a client unrelated to the version of the c lib in use by emby?

Anyway I just noticed the error in dBeaver was actually different:


So I tried setting write permissions for "others" (I am connecting dbeaver over NFS), on library.db, and now it works

The strange thing is that the on-host sqlite3 client was being run as root though... well maybe these were two different issues after all (as you said, it might be the preinstalled sqlite client's version.. oddly enough, I can't even run the latest one from https://www.sqlite.org/download.html because here is some executable restriction in place on this linux distro..)

Thanks anyway :) !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...