Jump to content


Photo

Hardware decoding not working with latest emby server


  • Please log in to reply
5 replies to this topic

#1 BurnMaster OFFLINE  

BurnMaster

    Newbie

  • Members
  • 3 posts
  • Local time: 06:39 AM

Posted 19 July 2019 - 08:14 PM

Hi guys!

 

New here just purchased lifetime premium and i'm having an issue with the hardware transcoding.

Tried:

 

4.1.1.0 

and

4.2.0.33 same issue

 

I have tested this 1080ti with plex and it is working albeit at .8x speed using h265 10bit +60mbit files. Software transcode on emby works really good my cpu couldn't even start one stream with plex and it works here with emby but I wish i could use hw dec/enc from my GPU.

 

I have two different gpu on my computer don't know if that is the issue? Only activated 1080ti on preferred hardware decoders for mpeg-2, vc-1,h.264, h265 and vp9

 

Using latest nvidia 431.36 drivers with unlimited sessions patch

 

Any help is appreciated.

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134225 posts
  • Local time: 07:39 AM

Posted 19 July 2019 - 08:19 PM

Hi there, have you followed our hardware acceleration setup guide?



#3 BurnMaster OFFLINE  

BurnMaster

    Newbie

  • Members
  • 3 posts
  • Local time: 06:39 AM

Posted 19 July 2019 - 08:26 PM

I did. Changed a few settings and still the same no hw transcoding.

Here is the transcode log:

Attached Files


Edited by BurnMaster, 19 July 2019 - 08:27 PM.


#4 watchmeexplode5 OFFLINE  

watchmeexplode5

    Newbie

  • Members
  • 5 posts
  • Local time: 05:39 AM

Posted 19 July 2019 - 09:45 PM

Hey,

I just looked at your logs quickly and I believe you are having the same issue as me. It's related to having 2 GPUs. Something in emby isn't working quite right and doesn't allow use of NVENC/NVDEC (with 2+ GPUs). When selecting DX11VA for transcoding (not nearly as fast as Nvenc in my experiences) it doesn't work and your computer falls back to software transcoding.

 

https://emby.media/c...em-with-2-gpus/

 

@softworkz knows about the issue and is looking into it. 

 

Currently you have 2 options:

1) Wait (hopefully a short time - Emby pushes fixes fast)

2) Physically unplug one of your graphics cards (and select Nvenc option) temporarily until a fix is pushed.


Edited by watchmeexplode5, 19 July 2019 - 09:50 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134225 posts
  • Local time: 07:39 AM

Posted 19 July 2019 - 11:09 PM

Yes it does look like the same thing. It is on our list for review. Thanks.



#6 BurnMaster OFFLINE  

BurnMaster

    Newbie

  • Members
  • 3 posts
  • Local time: 06:39 AM

Posted 20 July 2019 - 03:17 PM

I just disabled my second video card and yes it hw transcoding worked. On the Transcoding settings I saw one new setting alongside DX11VA and it was NVDEC. 

So if anyone else has same Issue just disable or unplug your second video card.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users