Jump to content


Photo

Emby Console shows device name, not renamed device name


  • Please log in to reply
29 replies to this topic

#1 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 19 July 2019 - 08:10 AM

I have a roku waching stuff.

In Emby console it shows its original device sent name - but that was renamed to a friendly name in the past.

The ShieldTV and chrome webapp's dont have this issue - just seems to be the roku ?

 



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 05:57 AM

Posted 19 July 2019 - 11:42 AM

Hi.  Exactly what did you rename?



#3 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 19 July 2019 - 08:10 PM

ok - The feature to 'rename' devices to a friendly name

click devices from emby console

click three dots next to a roku - note its original name

rename it to a friendly name

watch TV on that roku

The friendly name is not shown on the emby console, the original device name is.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 05:57 AM

Posted 19 July 2019 - 08:20 PM

Seems to be working in my testing here. Did you try refreshing the page?



#5 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 19 July 2019 - 09:51 PM

Yep - I refreshed a few times.

I am on the beta server and roku.

They are not online currently.

Will check alter.



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 05:57 AM

Posted 20 July 2019 - 04:21 PM

I thought we changed this a long time ago to respect the actual device name because people would set those and expect them to be used.

 

I believe you need to change the real device name of your Roku (through the Roku).



#7 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 05 September 2019 - 07:40 AM

I'm still seeing the remote roku device, showing the actual content being watches, and the console also shows the 'renamed in emby' device.  The pic below is the actual same device.  Ali_Roku2 is the device as named by the roku itself.  Roku2-Ali-Borrowed is the renamed device in devices section of emby console :

 

5d70f3ef9b06f_Capture.png



#8 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 05 September 2019 - 07:47 AM

I thought we changed this a long time ago to respect the actual device name because people would set those and expect them to be used.

 

I believe you need to change the real device name of your Roku (through the Roku).

 

If this is the case, then maybe the rename option should be removed from the devices list on the roku console ?



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 05:57 AM

Posted 06 September 2019 - 02:12 AM

I thought we had already removed the option from the Roku app.



#10 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 06 September 2019 - 02:26 AM

in emby console, devices, click one, change display name - and you get the above image - both are shown.

I made a display name of the roku to the 'borrowed' one.



#11 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15726 posts
  • Local time: 02:57 AM
  • LocationWashington State

Posted 06 September 2019 - 03:01 AM

In my test the custom name added in devices displays instead of the custom assigned Roku name.  Removing the name revert back to custom assigned Roku device name

 

4.3.0.7

3.0.81  Roku Ultra



#12 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 06 September 2019 - 03:06 AM

In my test the custom name added in devices displays instead of the custom assigned Roku name.  Removing the name revert back to custom assigned Roku device name

 

4.3.0.7

3.0.81  Roku Ultra

 

did you try playing on that (in my case a roku), then you get both listed - as per my image in post 7



#13 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15726 posts
  • Local time: 02:57 AM
  • LocationWashington State

Posted 06 September 2019 - 03:13 AM

did you try playing on that (in my case a roku), then you get both listed - as per my image in post 7

Good point, so I just tested playing something while having a custom device name and Active devices only showed a entry with my custom name and removing custom name shows proper Roku name.



#14 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 06 September 2019 - 05:19 AM

Ok,
I deleted all the duplicate roku’s I had then, and just renamed one to see what happens. I had 4 duplicates in total.
Will wait to see when that user connects what happens.

#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 05:57 AM

Posted 13 September 2019 - 12:40 PM

Are you still seeing this?



#16 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 13 September 2019 - 08:47 PM

Well.....

As I have normal (175) and beta (181) apps on the roku's, I have noticed that one shows the renamed device and the other shows the device name itself. 

It seems the normal app uses the newly named device and the beta app only shows the original device name.

Maybe @Happy2Play can verify this ?



#17 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 05:57 AM

Posted 14 September 2019 - 09:31 AM

This was changed quite a while ago so I don't believe the beta and release apps would behave differently.



#18 vaise OFFLINE  

vaise

    Advanced Member

  • Members
  • 1044 posts
  • Local time: 07:57 PM

Posted 14 September 2019 - 10:05 AM

No worries - I can live with it - will just remove all renamed devices.



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138075 posts
  • Local time: 05:57 AM

Posted 18 September 2019 - 02:26 PM

If you rename the device either on the server or in the Roku device settings, either of those two should work. Renaming on the server will override everything. Can you confirm?

 

@Happy2Play can you reproduce?



#20 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15726 posts
  • Local time: 02:57 AM
  • LocationWashington State

Posted 18 September 2019 - 02:49 PM

If you rename the device either on the server or in the Roku device settings, either of those two should work. Renaming on the server will override everything. Can you confirm?

 

@Happy2Play can you reproduce?

 

In my tests everything worked as it should.

 

Only issue still is apostrophes within the devices name, but server custom device names does fix that. (as discussed in the other topic)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users