Jump to content


Photo

Duplicate calls to api.themoviedb.org

bug

  • Please log in to reply
1 reply to this topic

#1 roblav96 OFFLINE  

roblav96

    Member

  • Members
  • 13 posts
  • Local time: 11:52 AM

Posted 13 July 2019 - 09:06 AM

During a library scan for movies with settings described in the screenshot attached, calls to api.themoviedb.org for metadata gets called twice.

2019-07-13 08:52:34.410 Info HttpClient: GET https://api.themoviedb.org/3/movie/348350?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:34.711 Info HttpClient: GET https://api.themoviedb.org/3/movie/330459?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:35.014 Info HttpClient: GET https://api.themoviedb.org/3/movie/330459?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:35.314 Info HttpClient: GET https://api.themoviedb.org/3/movie/74849?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:35.614 Info HttpClient: GET https://api.themoviedb.org/3/movie/74849?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:35.916 Info HttpClient: GET https://api.themoviedb.org/3/movie/12180?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:36.219 Info HttpClient: GET https://api.themoviedb.org/3/movie/12180?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:36.523 Info HttpClient: GET https://api.themoviedb.org/3/movie/140607?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:36.823 Info HttpClient: GET https://api.themoviedb.org/3/movie/140607?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:37.128 Info HttpClient: GET https://api.themoviedb.org/3/movie/11?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:37.427 Info HttpClient: GET https://api.themoviedb.org/3/movie/11?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:37.730 Info HttpClient: GET https://api.themoviedb.org/3/movie/1893?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:38.034 Info HttpClient: GET https://api.themoviedb.org/3/movie/1893?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:38.336 Info HttpClient: GET https://api.themoviedb.org/3/movie/1894?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:38.640 Info HttpClient: GET https://api.themoviedb.org/3/movie/1894?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:38.942 Info HttpClient: GET https://api.themoviedb.org/3/movie/1895?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:39.246 Info HttpClient: GET https://api.themoviedb.org/3/movie/1895?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers
2019-07-13 08:52:39.547 Info HttpClient: GET https://api.themoviedb.org/3/movie/181808?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers&language=en&include_image_language=en,null
2019-07-13 08:52:39.849 Info HttpClient: GET https://api.themoviedb.org/3/movie/181808?api_key=1234567890&append_to_response=casts,releases,images,keywords,trailers

The additional call is the exact same as the first, except without the following params:

&language=en&include_image_language=en,null

What's odd is that the first item /movie/348350 does not get called twice, but it's missing the language params.

 

I tried unsetting the language options of the library as shown in the screenshot, but the problem remains.

 

This issue is not present while scraping metadata for tv shows.

Attached Files


Edited by roblav96, 13 July 2019 - 09:10 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134803 posts
  • Local time: 11:52 AM

Posted 13 July 2019 - 10:34 AM

It's currently expected so that we can get all images from all languages.





Also tagged with one or more of these keywords: bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users