Jump to content


Photo

Nvidia Shield Server - No Library


  • Please log in to reply
11 replies to this topic

#1 goat999 OFFLINE  

goat999

    Newbie

  • Members
  • 7 posts
  • Local time: 03:38 AM

Posted 07 July 2019 - 10:49 AM

Hi

 

Just installed server on nvidia shield and when setting up media libraries I have a permanent spinning circle.

 

All my media is on a synology NAS which is connected to the shield.

 

Any ideas?



#2 goat999 OFFLINE  

goat999

    Newbie

  • Members
  • 7 posts
  • Local time: 03:38 AM

Posted 07 July 2019 - 02:02 PM

This is for the com.emby.embyserver_4.2.0.25.apk beta release.

 

If I uninstall this and install com.emby.embyserver_4.1.1.0.apk it works as it should



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:38 PM

Posted 07 July 2019 - 02:10 PM

Hi there @goat999, please attach the emby server log. You can learn how to do that here:

https://emby.media/c...port-a-problem/

 

Thanks.



#4 ellie42 OFFLINE  

ellie42

    Newbie

  • Members
  • 4 posts
  • Local time: 07:38 PM

Posted 10 July 2019 - 12:41 AM

Hi, I ran into the same issue today setting up the shield, this was the stack trace the server dashboard had for it:
 

Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown.
at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement (System.ReadOnlySpan`1[T] sqlUtf8Bytes, System.String& tail) [0x00074] in <b11961a0446a4b18a541219c3a0df9af>:0
at SQLitePCL.pretty.DatabaseConnection.PrepareStatement (SQLitePCL.pretty.IDatabaseConnection This, System.ReadOnlySpan`1[T] sqlUtf8) [0x00009] in <b11961a0446a4b18a541219c3a0df9af>:0
at Emby.Sqlite.BaseSqliteRepository.PrepareAll (SQLitePCL.pretty.IDatabaseConnection connection, System.ReadOnlyMemory`1[System.Byte][] sqlUtf8) [0x0001e] in <395a6f6fe5f64651a7830969be1b6ab2>:0
at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItemsInTranscation (SQLitePCL.pretty.IDatabaseConnection db, System.Collections.Generic.List`1[T] tuples) [0x00002] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItems (System.Collections.Generic.List`1[T] items, System.Threading.CancellationToken cancellationToken) [0x000ef] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.Library.LibraryManager.UpdateItems (System.Collections.Generic.List`1[T] items, MediaBrowser.Controller.Entities.BaseItem parent, MediaBrowser.Controller.Library.ItemUpdateType updateReason, System.Threading.CancellationToken cancellationToken) [0x00057] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.Library.LibraryManager.UpdateItem (MediaBrowser.Controller.Entities.BaseItem item, MediaBrowser.Controller.Entities.BaseItem parent, MediaBrowser.Controller.Library.ItemUpdateType updateReason) [0x00014] in <03e61cd8f3684ab69581035195c6ae35>:0
at MediaBrowser.Controller.Entities.BaseItem.UpdateToRepository (MediaBrowser.Controller.Library.ItemUpdateType updateReason) [0x0000c] in <b85c4eb7aa3c47ccbbca766e6bb76793>:0
at Emby.Server.Implementations.Library.LibraryManager.CreateRootFolder () [0x000b2] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.Library.LibraryManager.get_RootFolder () [0x00025] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.IO.LibraryMonitor.Start () [0x0003a] in <03e61cd8f3684ab69581035195c6ae35>:0
at Emby.Server.Implementations.Library.LibraryManager+<ValidateMediaLibraryInternal>d__91.MoveNext () [0x000aa] in <03e61cd8f3684ab69581035195c6ae35>:0
--- End of stack trace from previous location where exception was thrown ---
at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker+<ExecuteInternal>d__69.MoveNext () [0x00188] in <03e61cd8f3684ab69581035195c6ae35>:0 


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:38 PM

Posted 10 July 2019 - 12:43 AM

Hi there @ellie42, please attach the complete emby server log. thanks.



#6 ellie42 OFFLINE  

ellie42

    Newbie

  • Members
  • 4 posts
  • Local time: 07:38 PM

Posted 10 July 2019 - 12:49 AM

Sure, attaching embyserver.txt here

Attached Files



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:38 PM

Posted 10 July 2019 - 01:34 AM

Sure, attaching embyserver.txt here

 

So you're saying this was a fresh install today?



#8 ellie42 OFFLINE  

ellie42

    Newbie

  • Members
  • 4 posts
  • Local time: 07:38 PM

Posted 10 July 2019 - 01:46 AM

Yeah, I just tried installing it and running it for the first time on the Shield just a couple hours ago, and like the original poster said, it just hangs with a spinner on adding libraries for the first time. This is also from the 4.2.0.26 beta apk.

 

 

I do have emby working fine on a Linux box already, I just thought I'd try the Shield as a server out of curiosity.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:38 PM

Posted 10 July 2019 - 01:48 AM

Ok thanks for the info. We'll take a look.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:38 PM

Posted 11 July 2019 - 02:35 AM

This is resolved in 4.2.0.27, but you'll need to delete this file:

/storage/emulated/0/Android/data/com.emby.embyserver/files/data/library.db

Thanks.



#11 ellie42 OFFLINE  

ellie42

    Newbie

  • Members
  • 4 posts
  • Local time: 07:38 PM

Posted 11 July 2019 - 02:59 AM

It looks like that solved it, thanks for the quick replies and fix!



#12 goat999 OFFLINE  

goat999

    Newbie

  • Members
  • 7 posts
  • Local time: 03:38 AM

Posted 14 July 2019 - 08:42 AM

yes thanks guys, awesome support as usual :-)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users