Jump to content

Hardware transcoding on raspberry pi4


nitin.sidhu23
 Share

Recommended Posts

nitin.sidhu23

Hello

 

I am using raspberry pi 4 as an emby server. Emby is running as a docker container. I have mounted the /dev/dri directory into the container. But i am having issue with transcoding of 1080p HEVC movies. Raspberry pi 4 should be able to hardware transcode these? Even if i run the container as root, it was always that it is software transcoding.

I have bought the premiere subscription and hardware transcoding is enabled in the server setting

 

docker-compose file is:

 

emby:
image: emby/embyserver_arm32v7:4.2.0.21
restart: always
container_name: emby
ports:
- 8096:8096
- 8920:8920 #optional
devices:
"/dev/dri:/dev/dri"
environment:
- UID=0
- GID=0
- GIDLIST=0,44,107
volumes:
- /mnt/media/appdata/emby/config:/config
- /mnt/media:/all_media
- /mnt/media/appdata/emby/transcode:/transcode

 

I have attached the related logs here. 

 

is it possible to do hardware transcoding on raspberry pi 4?

 

embyserver.txt

ffmpeg-transcode-58e1fc73-f99b-441b-95bb-806a0d8a8bf1_1.txt

hardware_detection-63697349429.txt

Link to comment
Share on other sites

HI, we haven't yet tested RPI4, we will be soon, but please be warned that hardware transcoding in Docker containers is only experimental at this stage. I would suggest using our ubuntu or debian package. Please let us know if this helps. Thanks.

Link to comment
Share on other sites

nitin.sidhu23

Hello Luke

 

I am now using  emby-server-deb_4.1.1.0_armhf.deb package on RPi4, but still the hardware transcoding isnt working. Do i need to install some drivers for it work? and/or run the server as root?

In the emby-server.conf file i can see LIBVA_DRIVERS_DIR option but I am not sure what path to put in here

 

Thank you

Link to comment
Share on other sites

Hello Luke

 

I am now using  emby-server-deb_4.1.1.0_armhf.deb package on RPi4, but still the hardware transcoding isnt working. Do i need to install some drivers for it work? and/or run the server as root?

In the emby-server.conf file i can see LIBVA_DRIVERS_DIR option but I am not sure what path to put in here

 

Thank you

 

Did you make sure to follow the setup guide in our hardware acceleration wiki?

Link to comment
Share on other sites

nitin.sidhu23

Hello Luke

 

Following the guide on wiki, i installed these package on RPi4, libva2 vainfo libyami-utils

 

I am not sure what to do after the installation and how to test if transcoding is happening in hardware or software. 

My client is Amazon fire stick.

 

Thank you

Link to comment
Share on other sites

mastrmind11

based on the above, i'm fairly certain luke said they haven't tested the 4 yet.  that said, how about you sit tight and let it happen.  the thing literally came out 2 weeks ago.....

Link to comment
Share on other sites

Can you attach the hardware detection log as well? Please note it appears you went back and forth between beta and stable. Keep in mind this is not supported and will cause problems. Thanks.

Link to comment
Share on other sites

  • 3 weeks later...
  • 9 months later...
studio-jurdan

Hello Luke

 

I have attached the hardware detection logs.

I used the latest tag for docker image which was 4.2.0.21 and this showed as being a beta release

 

Thank you

Hello, i'm using Emby and pi4 too in omv and docker, can you tell me if your hardwader is working and realy better than logicial? 

I'm not yet in "premiere emby "and the cost is very hard if i can"t have the transode working good.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...