Jump to content


Photo

Server Crashing all of a sudden


  • Please log in to reply
6 replies to this topic

#1 Dariusz OFFLINE  

Dariusz

    Advanced Member

  • Members
  • 98 posts
  • Local time: 03:51 AM

Posted 24 June 2019 - 11:16 PM

So everything has been fine for me for the longest time.. my wife has been just watching something and all of a sudden the video dropped.  I noticed there was no connection to the emby server,,, it happened before maybe once or twice in the past year and all I had to do was restart the emby server app.. so i did that and noticed server up started loading and within 20 seconds crashed again.. it just keeps doing that.. i did a reboott on my whole nas to make sure it wasn't something weird, but still keeps happening.. attached are my logs, hopefully this can be a simple fix.. i'm thinking of trying the latest beta to see if there would be any improvement, however for now I will hold off till i can have the server working properly again.

 

 

Attached Files



#2 Dariusz OFFLINE  

Dariusz

    Advanced Member

  • Members
  • 98 posts
  • Local time: 03:51 AM

Posted 25 June 2019 - 10:39 AM

So everything has been fine for me for the longest time.. my wife has been just watching something and all of a sudden the video dropped.  I noticed there was no connection to the emby server,,, it happened before maybe once or twice in the past year and all I had to do was restart the emby server app.. so i did that and noticed server up started loading and within 20 seconds crashed again.. it just keeps doing that.. i did a reboott on my whole nas to make sure it wasn't something weird, but still keeps happening.. attached are my logs, hopefully this can be a simple fix.. i'm thinking of trying the latest beta to see if there would be any improvement, however for now I will hold off till i can have the server working properly again.

I think I figured it out.. earlier yesterday I added a smb folder from another NAS to emby server.. i added it as mixed content. my wife was watching a video that was located in that folder for about 30min before  emby server crashed.. i ended up removing the folder today on the NAS and I was able to start the emby server without issues now..



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142718 posts
  • Local time: 03:51 AM

Posted 25 June 2019 - 01:17 PM

@Dariusz, thanks for the info ! Did you add the smb path directly to Emby?



#4 Dariusz OFFLINE  

Dariusz

    Advanced Member

  • Members
  • 98 posts
  • Local time: 03:51 AM

Posted 27 June 2019 - 02:03 PM

@Dariusz, thanks for the info ! Did you add the smb path directly to Emby?

 

i didn't do it manually.. when selecting folders, i used network option to see what's showing on the network and then selected the folder from another NAS listed there.. I re-added it now using "music videos" rather than "mixed content" and it seems to be working now..



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142718 posts
  • Local time: 03:51 AM

Posted 28 June 2019 - 01:27 AM

Ok, so in emby library setup, what does the path look like? is it smb://, unc \\, or / based?



#6 Dariusz OFFLINE  

Dariusz

    Advanced Member

  • Members
  • 98 posts
  • Local time: 03:51 AM

Posted 29 June 2019 - 10:13 PM

Ok, so in emby library setup, what does the path look like? is it smb://, unc \\, or / based?

when i picked the network option, it listed paths as smb://

 

like i said, i readded the library same way, except used music videos instead of mixed content and everything has been fine since..



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142718 posts
  • Local time: 03:51 AM

Posted 29 June 2019 - 11:11 PM

Ok, my suggestion would be to take that smb path and mount it to a local share using the tools built into the operating system. Then add that local share path to Emby instead of the direct smb path.

 

Why, because I think the issue is probably specific to the smb protocol and that would give you a way of avoiding it right now.


  • Dariusz likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users