Jump to content


Photo

Question about Windows Updates


  • Please log in to reply
114 replies to this topic

#41 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 03 July 2019 - 03:59 PM

That means the realtime monitor will probably be going haywire anytime emby server writes to the cache folder.



#42 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 03 July 2019 - 09:45 PM

Update

I removed E:/embycache. 

also removed the library for it.  It was auto generated. 

I set it for c:\embycache

I then restarted the computer. 

Same behavior as before  100 % cpu , after trying to sync music videos and it never finishes 

 

Attached Files



#43 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 04 July 2019 - 10:51 AM

I found a new way to get the cpu usage very high and stay high.

 

I have dlna player/server called twonky. 

Using a web brower it can point to other dlna sources and playback devices. 

 

I restarted the emby before connecting to have a clean log.

 

It took about 5 minutes to get to100% cpu utilation. 



#44 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 04 July 2019 - 11:09 PM

Can you provide a server log from that? Thanks.

#45 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 03:02 PM

Also have you tried the latest beta of the server + addon?



#46 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 07 July 2019 - 07:47 PM

Yes i just tried and learned a few things 

I have been using emby/kodi fine without music/ home videos. 

I synced serveral system and all was fine. 

I added a home video and photo library and tried to sync it.

The CPU went to 100% early. 

 

 

As far a the DLNA issue I have not been able to duplicate it. 

 

john 

 

Attached Files



#47 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 07:49 PM

Well i see a lot of ffprobing of new media files. Some cpu usage during this process is normal. What time did you start the sync?



#48 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 07:52 PM

Also are you actually using files underneath all of these iPod Photo Cache folders? The realtime monitor is reacting to a lot of events based on changes to those folders, presumably from an apple app. I guess we may want to start ignoring those folders.



#49 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 07 July 2019 - 07:57 PM

No I am not using those.

Where does it say they are located ? 



#50 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 07 July 2019 - 07:59 PM

All i did here was access a new libary from kodi and the cpu went to 100 

Should be nice tight clean log. 

Attached Files



#51 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 09:08 PM

No I am not using those.

Where does it say they are located ? 

 

Just  look in the log, there are a lot of them.

2019-07-07 16:26:10.523 Debug App: FolderImageProvider reports change to 60677 - \\TOWER\photos\phone\iPod Photo Cache


#52 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 09:11 PM

All i did here was access a new libary from kodi and the cpu went to 100 

Should be nice tight clean log. 

 

At least one of the two emby for kodi instances in this log is not running the latest version. Please update them to their latest betas and then try again.



#53 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 07 July 2019 - 10:48 PM

Ok should be good now,  4.1.2 for kodi comp 

cpu at low % till it got to the new videos libary i added for this test, 

When it go to sync for the new video dir, the CPU went to 85% and stayed there after it completed . 

 

Attached Files



#54 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 07 July 2019 - 10:51 PM

Angelblue05 is working on new changes that will reduce the number of requests performed by the add-on. Let's re-evaluate once that is available. thanks.



#55 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 09 July 2019 - 12:28 AM

A new beta server is headed up that will now completely ignore those ipod photo cache folders.



#56 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 09 July 2019 - 10:35 PM

I applied the latest updates and it will still go to 90% and stay there.

In kodi videos, then video add ons, then emby , mixed content

It is basicly pictures and home videos,  

the cpu will go wild right away and stay there. 

 

If I access movies or TV then no problem. 

The movies and tv are in different directories show then season. all shows for one season in one directory.

those have been working fine.

 

john 

 

 

 

Attached Files



#57 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 09 July 2019 - 10:47 PM

Do you have really big images or a slow network drive? Because i see some slow image processing here. This is actually coming from the web app and not Kodi.

2019-07-09 09:13:41.615 Debug ImageProcessor: Image encoding took 763ms for \\TOWER\Movies\tv\helicopter-rescue\HelicopterRescue-s01e02-Episode2-thumb.jpg
2019-07-09 09:13:41.616 Info HttpServer: HTTP Response 200 to 50.204.109.194. Time: 765ms. http://73.151.52.233:8096/emby/Items/83068/Images/Primary?maxHeight=185&maxWidth=329&tag=1acf1c8b411904ae1c59fa0252cdd23c&quality=90
2019-07-09 09:13:41.642 Debug ImageProcessor: Image encoding took 818ms for \\TOWER\Movies\tv\jag\landscape.jpg
2019-07-09 09:13:41.642 Info HttpServer: HTTP Response 200 to 50.204.109.194. Time: 819ms. http://73.151.52.233:8096/emby/Items/80731/Images/Thumb?maxWidth=329&tag=54d195fe112eefd0627771ccf94f1cb8&quality=90
2019-07-09 09:13:41.645 Debug ImageProcessor: Image encoding took 846ms for \\TOWER\Movies\dvd\documentories\APOLLO_18\landscape.jpg
2019-07-09 09:13:41.645 Info HttpServer: HTTP Response 200 to 50.204.109.194. Time: 862ms. http://73.151.52.233:8096/emby/Items/65606/Images/Thumb?maxWidth=329&tag=de737ada4d935fd644abe07dab84fcff&quality=90
2019-07-09 09:13:41.662 Info HttpServer: HTTP GET http://73.151.52.233:8096/emby/Items/80796/Images/Thumb?maxWidth=329&tag=f2c60e0a8a9b125fb7a96e805c393376&quality=90. 

See how for some images it takes nearly a full second to create a smaller version for the web app to utilize.



#58 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 09 July 2019 - 10:49 PM

You've also got a sync process going on at the exact same time as video transcoding.



#59 jpimlott OFFLINE  

jpimlott

    Advanced Member

  • Members
  • 69 posts
  • Local time: 11:31 AM
  • LocationNorthern California

Posted 09 July 2019 - 11:39 PM

This should be a clean log , restarted emby server a while ago so it is idle.

I did the same thing as before opened media through video, video add-ons, emby, various directories after 

CPU went 100% quickly 

Attached Files



#60 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134609 posts
  • Local time: 02:31 PM

Posted 10 July 2019 - 12:01 AM

As a test, can you try again but without having the server dashboard open the entire time? Thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users