Jump to content


Photo

Emby Server on Shield TV crashing on newer versions


  • Please log in to reply
22 replies to this topic

#21 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44926 posts
  • Local time: 05:38 PM

Posted 13 June 2019 - 09:03 AM

the Emby process is taking about 1GB of memory on the NAS 

 

I'm just guessing but that may be the key as that is fully 1/3 of the RAM on the device and Android probably isn't optimized for apps that use that much actual memory.



#22 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 06:38 AM

Posted 13 June 2019 - 10:00 AM

It's definitely possible.  This weekend I'll try rebuilding the Shield server again and only set up my TV or Anime library to reduce the overall footprint and see if that makes a difference.  What's odd though is now that I'm looking at the Shield's RAM usage with 4.2.0.12v2 using the top command, I don't see Emby's RES memory ever going above roughly 300MB, with %MEM staying at 10.1% or below before it crashes.  VIRT is 1.8GB, but that's still below Pluto's 2.2G and Youtube's 2.6G (both background, closed processes).

 

 

Beyond that, can you think of any major jumps between 4.0.2.0 and 4.1.0.26 that would explain why the older version is still stable with the same library?  There's so many changes listed between those versions I wouldn't know where to start looking.


Edited by Androktasie, 13 June 2019 - 10:01 AM.


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129397 posts
  • Local time: 05:38 PM

Posted 13 June 2019 - 11:40 AM

It looks to me like a crash coming from the image processing library that we're using, skiasharp.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users