Jump to content


Photo

Emby Server on Shield TV crashing on newer versions


  • Please log in to reply
24 replies to this topic

#1 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 09:16 AM

Hello,

 

I'm using a Shield Android TV (2015) with Shield Experience 7.2.3 (30.6.131.70) installed.  After upgrading Emby Server to either 4.1.0.26, 4.1.1.0 or 4.2.0.10, the Emby service will randomly and frequently crash while merely browsing the library as it loads thumbnails and other images.  This problem can be triggered with both the web frontend (Chrome and Firefox), and also the official Emby app for Android TV.  I do *not* have the CoverArt plugin installed.

 

When the crash occurs, any and all access to the server is halted until the service automatically restarts itself.  A new embyserver.txt log file is generated as the service is restarted.  Also if the Emby Server GUI frontend was open at the time of the crash, it closes back to the Android launcher.  The problem is not specific to any one library folder.

 

I'm not seeing any immediate cause for this issue in the logs, though I have attached them for 4.2.0.10.  This was not an issue with 4.0.2.0, and downgrading the server back to that version appears to alleviate the issue.

 

Please let me know if you require additional details, and thank you for making such clean-looking software.  I'm a recent convert after years of managing my database in XMBC/Kodi/SPMC.

Attached Files


Edited by Androktasie, 01 June 2019 - 09:33 AM.

  • MDS96 likes this

#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47023 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 10:15 AM

I suspect a corrupt image of some sort.  Look at all your images (including the cache) for any that are 0 bytes in length.



#3 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 10:32 AM

I suspect a corrupt image of some sort.  Look at all your images (including the cache) for any that are 0 bytes in length.

Thank you for the reply.  I just ran a search within com.emby.embyserver\files\cache, for "extension:png size:empty" and also "extension:jpg size:empty" and got 0 results.  I ran the same searches under my libraries' source folders and also got 0 results.

 

I don't believe this is tied to a specific image or directory.  Navigating into the same location immediately after the crash works just fine, it's only on subsequent directories later on that the crash resurfaces.

 

Is it possible that the Android OS is closing Emby due to memory usage since the shield only has 3GB of RAM?  If so, how should I go about getting a logcat(?) to capture this when it happens?



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47023 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 11:16 AM

If you install the Android Debug Bridge somewhere you should be able to tail the logcat.



#5 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 11:58 AM

If you install the Android Debug Bridge somewhere you should be able to tail the logcat.

Thank you.  I was able to get adb running and clear the logcat to get a clean set of logs.  The logcat starts just before I start the Emby service and ends just after the crash.  It appears to be dying from a segfault.

 

 

--------- beginning of crash
06-02 00:53:27.715 15972 16048 F libc    : Fatal signal 11 (SIGSEGV), code 1, fault addr 0x27effb6dc0 in tid 16048

Attached Files



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 12:05 PM

Thanks ! Just to rule it out, if you uninstall the dlna plugin and then restart the server, does that have an impact?



#7 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 12:11 PM

Thanks ! Just to rule it out, if you uninstall the dlna plugin and then restart the server, does that have an impact?

Hi Luke,

 

I just deleted the DLNA plugin, stopped and restarted the service, and still experienced the crash with 4.2.0.10.  Please let me know if there's any other logs etc that you need.  I appreciate the help.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 01:29 PM

Is this a valid png file?

/storage/GTI_ARCADIA/Videos/Television/Farscape/logo.png


#9 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 06:52 PM

Seems to be, yes.

5cf301b3bbf4c_logo.png



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 06:59 PM

What about these files?

2019-06-02 00:53:26.558 Debug Skia: Opening /storage/emulated/0/Android/data/com.emby.embyserver/files/metadata/library/b1/b158d6a0e6f5a9a9e3434fdd92328f83/poster.jpg for decoding without forceCleanBitmap
2019-06-02 00:53:26.562 Debug Skia: Opening /storage/emulated/0/Android/data/com.emby.embyserver/files/metadata/library/16/16fe489361e11d9bd862943277c5117f/poster.jpg for decoding without forceCleanBitmap
2019-06-02 00:53:26.564 Debug Skia: Opening /storage/emulated/0/Android/data/com.emby.embyserver/files/metadata/library/e5/e5d63b151f36fbc6b89630f782743429/poster.jpg for decoding without forceCleanBitmap
2019-06-02 00:53:26.570 Debug Skia: Opening /storage/emulated/0/Android/data/com.emby.embyserver/files/metadata/library/b4/b491489a85696a0d8658a31ac9caf9f1/poster.jpg for decoding without forceCleanBitmap
2019-06-02 00:53:26.575 Debug Skia: Opening /storage/emulated/0/Android/data/com.emby.embyserver/files/metadata/library/de/de658acba2003114babec77484af7c95/poster.jpg for decoding without forceCleanBitmap


#11 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 08:23 PM

Hi, I just checked and all of those files are good.  I can upload them if needed.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 01 June 2019 - 08:25 PM

No that's ok. I'm looking To adding more image processing error handling. Let's see if that helps in the next beta. Thanks.

#13 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 01 June 2019 - 11:51 PM

Okay, thank you.  For what it's worth I just tested against Shield Experience 7.2.3+ (30.6.131.8) and still encountered the problem.  Renaming the entire com.emby.embyserver directory to start from scratch was also ineffective.

 

I'll keep an eye out for the new beta.  Thanks again!



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 04 June 2019 - 02:08 AM

Can you please try the new beta? thanks.



#15 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 04 June 2019 - 04:26 AM

Unfortunately it's still an issue with 4.2.0.12.  I've attached debug logs and a fresh logcat.  Please let me know if there's anything else I can do to help.

 

 

Also on a whim (after capturing the logs) I temporarily removed all my theme.mp3 files but unfortunately it didn't make any difference.

Attached Files


Edited by Androktasie, 04 June 2019 - 04:40 AM.


#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 04 June 2019 - 03:10 PM

I've replaced the beta apk with an updated version. Can you please try that? Thanks.



#17 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 05 June 2019 - 04:55 AM

Sure thing.  Thank you again for the assistance.

Attached Files



#18 badwhip OFFLINE  

badwhip

    Member

  • Members
  • 23 posts
  • Local time: 10:08 PM

Posted 10 June 2019 - 04:27 PM

is there a shiled tv beta apk? the current version doesn’t run very well with lots of volley errors etc.

#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:08 PM

Posted 11 June 2019 - 03:40 PM

is there a shiled tv beta apk? the current version doesn’t run very well with lots of volley errors etc.

 

@badwhip let's look at an example. Please attach the information requested in how to report a problem. thanks !



#20 Androktasie OFFLINE  

Androktasie

    Member

  • Members
  • 11 posts
  • Local time: 11:08 AM

Posted 13 June 2019 - 06:14 AM

So, I recently picked up a Synology DS1019+ and tried rebuilding my Emby server from scratch on it using 4.1.1.0.  Unlike when I rebuilt the Shield server from scratch on June 2nd, the NAS seems to have no issues with browsing multiple directories and not crashing.  On average the Emby process is taking about 1GB of memory on the NAS if that gives you any indication of how big my library is.

 

I know it's not a total apples-to-apples comparison, but it seems like the Synology build is much more stable in any case.    Plus, I can actually write to the media folders now since that wasn't possible with 4.0.2.0 on the Shield.  I just tried the Shield again with 4.2.0.12v2 now that my storage is faster, but same issue persists.

 

I picked up a lifetime Premiere license though as thanks for the troubleshooting efforts.  If you're still wanting to troubleshoot the Shield version, I'm always happy to test new builds and capture logs or provide any data you need.  I don't like being beaten by technology.  :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users