Jump to content
mabooth

X88MAX. AndroidTv 1.7.21g direct play error

Recommended Posts

mabooth

Hi,
 
Quite new to Emby but impressed so far and have an active Emby Premiere subscription.
 
I am having issues with files not playing direct when they do on other apps such as Plex and DLNA and also over WIFI to my mobile phone.

 

I get direct play error in stats for nerds (screenshot attached)  and on dashboard

 

Transcoding (226 fps)

10.4 Mbps H264 AAC
 
H.264 (AVC)
NVENC/DEC
 
H.264 (AVC)
NVENC/DEC
 

 

Android TV is on wired Gb Lan so no issues there

 

This always happens when trying to play 1080p video and is such unwatchable as it is jerky and audio is way out of sync.

 

Been through all the settings i can think of and the only way I have managed to play the content is when Audio Output is set to downmix to stereo then the same file plays direct.

 

Everything related to streaming and transcoding is either set to max or auto.

 

I have even put the IP of the Android TV box in the Hostng settings and turned off subtitles.

 

Logs are attached.

 

Just one more thing I am unclear about, how does the server know if I am connecting from with my home network or connecting from outside?

 

Thanks and regards,

 

remux.txt

server.txt

transcode.txt

post-446691-0-14195800-1559038846_thumb.jpg

Share this post


Link to post
Share on other sites
ebr

Looks like an issue with the audio track to me.  Where did the item come from/how was it converted?

 

The fact that our system cannot determine the bitrate for the audio track is a clue that something is not right with it and that is probably why the player cannot play it.

Share this post


Link to post
Share on other sites
mabooth

Hi,

 

The same behaviour is noticed in most 1080p files and some 720p so its not particular to this specific file

 

I now think it is network related as i unchecked Allow remote connections to this Emby Server in advanced settings.

 

Now I cannot connect from the Android PC or a second computer on the LAN but can from my mobile on WIFI?

 

When I try to login on Android TV I get pin confirmed on the PC (emby.media/pin)  then on the TV select server and error message comes back saying server ### cannot be reached?

Also the same when I try to reach the server on my second PC, comes back forbidden?

 

Regards,

Mark

Share this post


Link to post
Share on other sites
Luke

Hi,

 

The same behaviour is noticed in most 1080p files and some 720p so its not particular to this specific file

 

I now think it is network related as i unchecked Allow remote connections to this Emby Server in advanced settings.

 

Now I cannot connect from the Android PC or a second computer on the LAN but can from my mobile on WIFI?

 

When I try to login on Android TV I get pin confirmed on the PC (emby.media/pin)  then on the TV select server and error message comes back saying server ### cannot be reached?

Also the same when I try to reach the server on my second PC, comes back forbidden?

 

Regards,

Mark

 

Try allowing remote connections again.

Share this post


Link to post
Share on other sites
mabooth

OK, Android TV and PC connected again on LAN, my mistake had the wrong IP set in Hosting setting, deleted it now and its blank.

 

Same issue with Transcoding though, been looking at the various file types as per the attached PDF Test 1.

 

I can direct play AAC codec but EAC3 I have issues with.

 

I was starting to think that the android box wasn't capable but the files play fine with Plex?

Test1.pdf

Share this post


Link to post
Share on other sites
Luke

@@mabooth how big is this video file? Is it possible to provide a copy of it for testing? Thanks !

Share this post


Link to post
Share on other sites
mabooth

Size 7974 MB or could provide a link if allowed?

 

MEDIAINFO
Container = Matroska (mkv)
Duration = 01:53:02.802
Filesize = 8 GiB
Overall bitrate = 9 862 kb/s
Video
Codec info = AVC High@L4 | V_MPEG4/ISO/AVC
Resolution = 1920x1080
Display AR = 1.778 | 16:9
Bitrate = 9 220 kb/s
Framerate = CFR 23.976
Color space = YUV
Chroma subsampling = 4:2:0
Encoder = 
Audio
Codec info = E-AC-3 | A_EAC3
Channels = 6
Bitrate = CBR 640 kb/s
Samplerate = 48.0 kHz
Language = English

Share this post


Link to post
Share on other sites
Luke

Yes you can PM me with a link, that would be great, thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...