Jump to content


Photo

Changes to the System.xml file?


  • Please log in to reply
5 replies to this topic

#1 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3409 posts
  • Local time: 04:31 AM
  • LocationWarrington,UK

Posted 21 May 2019 - 12:32 PM

In 4.2.0.6 the system.xml file was changed

 

i.e. the SortRepaceChars and SortRemoveChars were changed to ascii codes from their characters

 

Curious could you explain why?

 

i.e. from

5ce427d759428_Annotation2.png

 

to

5ce427ea675f8_Annotation3.png



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139864 posts
  • Local time: 11:31 PM

Posted 21 May 2019 - 12:53 PM

Well I wanted them as character based operations rather than string based, in any case, these settings only exist on account of sorting limitations, and i don't think we'll need them for much longer.



#3 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3409 posts
  • Local time: 04:31 AM
  • LocationWarrington,UK

Posted 21 May 2019 - 01:14 PM

Ok Thanks



#4 benmoses OFFLINE  

benmoses

    Member

  • Members
  • 22 posts
  • Local time: 11:31 PM
  • LocationIndianapolis, IN

Posted 08 November 2019 - 08:52 PM

Does <SortRemoveChars> and <SortRemoveWords> apply to Music libraries and the "Album" field?



#5 crusher11 OFFLINE  

crusher11

    Advanced Member

  • Members
  • 621 posts
  • Local time: 12:31 PM

Posted 08 November 2019 - 09:00 PM

Well I wanted them as character based operations rather than string based, in any case, these settings only exist on account of sorting limitations, and i don't think we'll need them for much longer.

Why is that?

#6 benmoses OFFLINE  

benmoses

    Member

  • Members
  • 22 posts
  • Local time: 11:31 PM
  • LocationIndianapolis, IN

Posted 08 November 2019 - 09:18 PM

Does <SortRemoveChars> and <SortRemoveWords> apply to Music libraries and the "Album" field?

OK I guess I answered my own question. :)  I think the answer is yes.  However, it appeared that Emby wasn't honoring my additions to these lists.  A restart of Emby server and a simple metadata refresh wasn't cutting it.  I had to remove them from the library, do a scan, and then re-add them and scan again.  But, yeah it appears to be working.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users