Jump to content


Photo

Live TV - Playback error - No comptible streams / missing vp8 encoder


  • Please log in to reply
6 replies to this topic

#1 wp.rauchholz OFFLINE  

wp.rauchholz

    Advanced Member

  • Members
  • 96 posts
  • Local time: 10:43 PM
  • LocationBarcelona

Posted 19 May 2019 - 09:30 AM

I run latest emby-server on a CENTOS 7 home server

I access the server from my CENTOS 7 laptop.

I can stream live TV from my iphone, but not from my CENTOS laptop.

 

I see the error message:

Program data path: /var/lib/emby
    Application directory: /opt/emby-server/system
    System.Exception: System.Exception: No video encoder found for 'vp8'
    
    
    >>>>>>  FindVideoDecoder - MediaType: h264, Mode: 2
    Info    FindVideoDecoder - Checking: 'VAAPI HD Graphics 530 - H.264 (AVC)' (Priority: 100)
    Info    FindVideoDecoder - Check successful - selecting 'VAAPI HD Graphics 530 - H.264 (AVC)'
    
    >>>>>>  FindVideoEncoder - Media: vp8, UseHardwareCodecs: True, Mode: 2

 

 

Which program do I need to install to get the missing encoder?

 

Thanks, Wolfgang

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:43 PM

Posted 20 May 2019 - 12:35 PM

Hi, this is firefox, right? On Linux it does not ship with h264 support so we transcode to vp8, however it looks like our CentOS ffmpeg build is missing this encoder. We are resolving this for the next release.

 

In the meantime you could use a different browser such as Chrome, or install h264 support into your browser. The instructions on how to do that will vary per distro, but this might help:

https://support.mozi...-plugin-firefox



#3 wp.rauchholz OFFLINE  

wp.rauchholz

    Advanced Member

  • Members
  • 96 posts
  • Local time: 10:43 PM
  • LocationBarcelona

Posted 20 May 2019 - 12:51 PM

That fixed it.

Thank you

 

Wolfgang



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:43 PM

Posted 20 May 2019 - 12:54 PM

What did you do? Switch browsers or install the firefox plugin?



#5 wp.rauchholz OFFLINE  

wp.rauchholz

    Advanced Member

  • Members
  • 96 posts
  • Local time: 10:43 PM
  • LocationBarcelona

Posted 21 May 2019 - 02:13 AM

I installed the firefox plugin.

 

Regards, Wolfgang



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:43 PM

Posted 21 May 2019 - 02:22 AM

Thanks for the feedback.



#7 darkm00n OFFLINE  

darkm00n

    Newbie

  • Members
  • 8 posts
  • Local time: 10:43 PM

Posted 19 July 2019 - 11:11 AM

I have the same problem but the setup is different :

 

Server : Debian 10 (Buster)

Client : Windows 10 (not linux)

Firefox Browser with H264 coded activated

 

https://emby.media/c...-found-for-vp8/

 

maybe one thing : the library name for vp8 on Buster is now : libvpx5 (Debian 10) .. it was libvpx4 on Stretch (Debian 9)

 

Regards

DM


Edited by darkm00n, 19 July 2019 - 12:15 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users