Jump to content


Photo

Issue playing a currently recording


  • Please log in to reply
40 replies to this topic

#1 simonselmer OFFLINE  

simonselmer

    Advanced Member

  • Members
  • 68 posts
  • Local time: 10:16 PM

Posted 15 May 2019 - 08:09 AM

Hi

 

Let's say I'm recording a 2 hour movie.

20 minutes after the movie starts, I'm ready to start watching it, from the beginning of course.

 

1. FEATURE REQUEST: I cannot start seeing the movie from the beginning using the TVguide. In MediaPortal, it was "smart" enough so if I play a show/movie from the TVguide, which MediaPortal knew is currently being recorded, it would "of course" jump to that stream already being recorded. And I would be prompted to select "start from beginning" or "start from now".

In Emby, if I start a stream from TVguide, that is already being recoded, it's like it start a new stream, so I cannot jump back to the beginning.

2. SO on my "Emby for Android TV" app, I instead have to go "Recorded TV", and from here I can actually jump into the currently recording stream, both starting from beginning, and also continue to watch the whole movie as it's being recoded. THIS WORKS OK

 

3. BUG/ISSUE - However, the scenario described in #2 above, does not seem to work on "Emby for Android" and "Emby Theater - Desktop edition".

In both of these apps, when I want to watch a currenty ongoing recording from the "Recorded TV", it's acting wierd. I think it jumps to the live TV point, and I'm not able to jump back a start from beginning of the movie.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 17 June 2019 - 11:50 PM

@simonselmer thanks for the feedback. We are looking into improving this. Thanks.


  • Rogero54 likes this

#3 aja07 OFFLINE  

aja07

    Advanced Member

  • Members
  • 47 posts
  • Local time: 08:16 AM
  • LocationAustralia

Posted 13 August 2019 - 07:58 AM

Tried to start playing  a show whilst still recording on Emby Theatre W10 and all I got was the spinning circles.  Only way out was to exit out of Emby Theatre and restart.  Tried 3 times, same result so gave up.  Will try again tomorrow and test with Android TV as well.



#4 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 15 August 2019 - 04:56 PM

I've got the same issue - if you wait long enough it will eventually work - but for some reason its transcoding despite the fact live tv works without transcoding on Emby Theatre. It's a lot quicker to start on the web version, but it's still transcoding. Why can't it use native MPEG2?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 30 August 2019 - 12:50 AM

I've got the same issue - if you wait long enough it will eventually work - but for some reason its transcoding despite the fact live tv works without transcoding on Emby Theatre. It's a lot quicker to start on the web version, but it's still transcoding. Why can't it use native MPEG2?

 

hi @brettuk, web browsers do not support mpeg2. Does that answer your question?



#6 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 80 posts
  • Local time: 02:16 PM

Posted 08 September 2019 - 04:42 PM

I finally got Live TV working, and my main reason for using the DVR/recording feature is to be able to watch baseball on a delay. It looks like I can't fast-forward at all when a recording is in progress, which is really important for baseball. Is this expected behavior? Must I stop the recording to be able to do this? I keep accidentally seeing the live feed, which of course instantly ruins the whole thing.

 

Is there any way to watch/scrub while recording? I'm just trying to figure out if this is something that's supposed to work, but for some reason doesn't with my setup. Is this one of those things that'd be better when connected with an external media player application?

 

Thanks.



#7 clollar OFFLINE  

clollar

    Advanced Member

  • Members
  • 76 posts
  • Local time: 03:16 PM

Posted 08 September 2019 - 10:31 PM

Seems this happens every single football season.  Due to the nature of sports users often want to start in progress recordings.  Yet every year I run into this issue.  Is there some legacy issue I don't know about?  What's the problem?  When will it be fixed?  Anyone know if Plex has the same issue.  Here's my issue.  I try to start an in progress recording (Steelers vs Pats in this example) and it crashes the app.  Very frustrating for sports fans guys, can we figure this out.  Server log attached.


Edited by clollar, 08 September 2019 - 10:33 PM.


#8 clollar OFFLINE  

clollar

    Advanced Member

  • Members
  • 76 posts
  • Local time: 03:16 PM

Posted 08 September 2019 - 10:33 PM

Oh this might help.  On the Android TV app (Shield) there is an option when you select the "on now", basically go to the actual channel the recording is currently on, there's a start from beginning option. That seemed to work.  However there's no "resume from" option once you back out and reenter.  Also I have not seen this option on my Android phone or ET.



#9 simonselmer OFFLINE  

simonselmer

    Advanced Member

  • Members
  • 68 posts
  • Local time: 10:16 PM

Posted 09 September 2019 - 02:14 AM

Which client are you using?

 

I was having some of the same issue on my Shield TV. In another thread on that specific issue of not being to skip forward or it would take a long time to skip forward in an ongoing recording, it improved my experience to update mu Shield to a beta-version. There was a link to how to get that in another thread.

 

It has improved my experience, BUT it could still be better. The issue still seems to be when the recording is ongoing, because once the recording has stopped, it's much more fluent as I recall.

 

If you do not have the Shield as client, then my suggestion is no good to you :)

 

 

I finally got Live TV working, and my main reason for using the DVR/recording feature is to be able to watch baseball on a delay. It looks like I can't fast-forward at all when a recording is in progress, which is really important for baseball. Is this expected behavior? Must I stop the recording to be able to do this? I keep accidentally seeing the live feed, which of course instantly ruins the whole thing.

 

Is there any way to watch/scrub while recording? I'm just trying to figure out if this is something that's supposed to work, but for some reason doesn't with my setup. Is this one of those things that'd be better when connected with an external media player application?

 

Thanks.



#10 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 80 posts
  • Local time: 02:16 PM

Posted 09 September 2019 - 05:00 PM

Using the web client (server running on Mac OS)



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 11 September 2019 - 01:27 PM

Can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !



#12 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 19 September 2019 - 04:38 PM

hi @brettuk, web browsers do not support mpeg2. Does that answer your question?


Sorry I didn't see you replied. I'm having this issue with emby theatre, its transcoding even though live TV and recorded TV is direct play - it takes ages to start watching a recording in progress too, taking up to a couple of minutes.

#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 20 September 2019 - 12:21 AM

Sorry I didn't see you replied. I'm having this issue with emby theatre, its transcoding even though live TV and recorded TV is direct play - it takes ages to start watching a recording in progress too, taking up to a couple of minutes.

 

@brettuk can we please look at an example? thanks !



#14 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 20 September 2019 - 07:55 AM

@brettuk can we please look at an example? thanks !

 

This is me watching it live directly from the channel - note it's direct play and instant to start:

 

5d84bbea31dee_watchinglive.jpg

 

If I watch a previously recorded episode, it is also directplay and instant to start:

 

5d84bc156d107_watchingrecorded.jpg

 

However watching a recording in progress sits at this screen for a min or so:

 

5d84bc47aa786_wait.jpg

 

And then will only be transcoded - it also mean you can't fast forward as the slider is slowly expanding (it has recorded more than 12 seconds when I took this screenshot):

 

5d84bc88b0410_watchingcurrentlyrecordeds

 

Can't see a way to upload logs, so put them on drive and shared: https://drive.google...vWb?usp=sharing



#15 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 28 October 2019 - 12:58 PM

@brettuk can we please look at an example? thanks !

 

Any update on this?

 

Thanks



#16 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:16 PM

Posted 28 October 2019 - 03:20 PM

This is me watching it live directly from the channel - note it's direct play and instant to start:

5d84bbea31dee_watchinglive.jpg

If I watch a previously recorded episode, it is also directplay and instant to start:

5d84bc156d107_watchingrecorded.jpg

However watching a recording in progress sits at this screen for a min or so:

5d84bc47aa786_wait.jpg

And then will only be transcoded - it also mean you can't fast forward as the slider is slowly expanding (it has recorded more than 12 seconds when I took this screenshot):

5d84bc88b0410_watchingcurrentlyrecordeds

Can't see a way to upload logs, so put them on drive and shared: https://drive.google...vWb?usp=sharing


Probably this

https://emby.media/c...ng/#entry795675

#17 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 28 October 2019 - 04:47 PM

 

Yeah looks like the same issue - it's very frustrating.



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 03 November 2019 - 02:43 PM

Are you able to play in-progress recordings using the Emby web app?



#19 brettuk OFFLINE  

brettuk

    Member

  • Members
  • 11 posts
  • Local time: 09:16 PM

Posted 04 November 2019 - 05:41 PM

Are you able to play in-progress recordings using the Emby web app?

 

For me that's not working at all. Not quite true, Chrome web isn't working at all (even for already recorded programmes), Edge is, it plays currently recording TV audio but shows a black screen.

 

Interestingly, due to unimportant reasons I've been using the Emby Fire TV app more over the past week, and that handles in progress recordings perfectly. If I select a TV programme from the guide that is recording, I have the option to watch from the start and it starts playing within seconds.


Edited by brettuk, 04 November 2019 - 05:49 PM.


#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:16 PM

Posted 16 November 2019 - 11:58 PM

We're looking into it. Thanks for reporting.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users