Jump to content

Playback in browser, subtitle is out of sync


danergo
 Share

Recommended Posts

danergo

Hello!

 

I'm trying to watch some movie on an old smart TV which already has browser integrated. (Unfortunately no native Emby is on that)

All the movies are playing nice and smooth, very good!

 

However if I play a movie with subtitles, the browser asks for webvtt. Emby then converts my subtitle on-the-fly to vtt and pass it back to the browser.

Texts are displayed under the movie, but they are delayed by more seconds, so it is not usable.

 

I have compared the vtt file and the original srt, and they are identical (by time-perspective).

 

 

Here are some of the log:

2019-05-13 19:54:55.746 Info HttpServer: HTTP GET http://a.b.c.d:8096/emby/Videos/6178/87afeaa895842dec18af539e0f45efd0/Subtitles/3/0/Stream.vtt. Host=a.b.c.d:8096, Connection=keep-alive, User-Agent=Mozilla/5.0 (Linux; U) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4, Accept=*/*, Referer=http://a.b.c.d:8096/emby/web/index.html, Accept-Encoding=gzip,deflate,sdch, Accept-Language=hu-HU,hu;q=0.8,en-US;q=0.6,en;q=0.4, Accept-Charset=ISO-8859-2,utf-8;q=0.7,*;q=0.3
2019-05-13 19:54:55.767 Info SubtitleEncoder: ProcessRun 'ffmpeg-subtitle_convert' Execute: /opt/emby-server/bin/ffmpeg  -sub_charenc windows-1252 -i "/mediaroot/Ray Donovan (2013)/Season 6/Ray Donovan - 6x08 - Who Once Was Dead.hun.srt" "/embyroot/emby-server/cache/subtitles/b/b451c02c2f0950dff2cd29d05aa4b8af_636925107649591091_3_0_0_False.vtt"
2019-05-13 19:54:55.785 Info SubtitleEncoder: ProcessRun 'ffmpeg-subtitle_convert' Started.
2019-05-13 19:54:56.008 Info SubtitleEncoder: ProcessRun 'ffmpeg-subtitle_convert' Process exited with code 0
2019-05-13 19:54:56.013 Info SubtitleEncoder: ffmpeg subtitle conversion succeeded for /mediaroot/Ray Donovan (2013)/Season 6/Ray Donovan - 6x08 - Who Once Was Dead.hun.srt
2019-05-13 19:54:56.014 Info HttpServer: HTTP Response 200 to w.x.y.z. Time: 268ms. http://a.b.c.d:8096/emby/Videos/6178/87afeaa895842dec18af539e0f45efd0/Subtitles/3/0/Stream.vtt

Do you think there is something that I can try?

(On-the-fly subtitle extraction was enabled, if I disable it is still not working - there was no subtitle then)

 

Thank you!

Link to comment
Share on other sites

  • 2 weeks later...
danergo

Subtitle timings are okay. At least I believe so (on every other device and platform it works well).

This particular device has low memory which might cause these symptoms and I wanted to know if there is something I can still try.

 

So to answer: if I change the subtitle timings it would ruin the subs on the other platforms and on other devices.

 

What do you think?

Link to comment
Share on other sites

  • 2 weeks later...

 

 

So to answer: if I change the subtitle timings it would ruin the subs on the other platforms and on other devices.

 

@@danergo

Yes this probably would be a problem. In the future we plan to add subtitle delay settings, but we haven't gotten there just yet. I suppose you could consider two sets of subtitles, although that would be a pain in the neck.

Link to comment
Share on other sites

pwhodges

Another workaround would be to re-encode with hard subs, using Handbrake, for instance.

Link to comment
Share on other sites

Wondertje

In the future we plan to add subtitle delay settings

 

This made me ridiculously happy, it's something I've been missing since like, forever. Can't wait for that to happen  :D

Link to comment
Share on other sites

danergo

Yepp, reencoding is one option but in this case I guess transcoding could also work, right? It would unload the stress from the TV and balance it towards the server which is much more powerful.

Link to comment
Share on other sites

rbjtech

You could you 'subtitle edit' and create a new subtitle file with suitable delay/advance and then just play that when on this particular device.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...