Jump to content


Photo
- - - - -

Emby for WMC launches very slowly


  • Please log in to reply
4 replies to this topic

#1 mranim8or OFFLINE  

mranim8or

    Advanced Member

  • Members
  • 40 posts
  • Local time: 10:49 PM

Posted 11 May 2019 - 10:46 PM

I have Emby Server and Emby for Windows Media Center on the same Windows 7 PC.  For a long time now I've had trouble launching Emby in WMC...what used to take a second or so now regular takes 30 seconds +.  It does eventually work, but its always very slow to launch. Once it loads everything works perfectly.

 

The startup speed problems began when I switched ISPs. My new ISP wanted me to pay to use their crappy router (which is built into their modem), but I wanted to use my nearly new and very high-end ASUS router instead. So a friend of mine who's a bit more internet tech savvy was able to setup my router so that it would work with their modem...this unfortunately  caused all of my IP addresses to be 192.168.2.#### (note the '2').  This worked beautifully but killed my emby launch speed.   I've gone into Emby Server and under the 'Advanced' settings I changed 'LAN networks:' and 'Bind to local network address' to the static IP address of my PC (since its both server and client): 192.168.2.200. As I said, it works but it is VERY slow to launch. I've also tried <localhost> in both of these, per another forum post, but that just breaks it entirely. Any suggestions? Am I messing with the wrong settings entirely?



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47589 posts
  • Local time: 04:49 PM

Posted 12 May 2019 - 07:49 AM

Sounds like EMC is configured to automatically connect to the old address.  To fix that, log in as you do now, then go to the configuration and set the start up option to show the login screen.  Then exit and come back in and login again.  Then you can set it to remember after that.

 

Please let us know of this solved the issue.

 

Thanks.



#3 mranim8or OFFLINE  

mranim8or

    Advanced Member

  • Members
  • 40 posts
  • Local time: 10:49 PM

Posted 12 May 2019 - 05:06 PM

Unfortunately that didn't solve it, it's still slow. Is there a config file or registry entry I can check to see what IP its trying to talk to?   Should I reinstall EMC?  I'd prefer not to since I am using a few plugins and would have to reconfigure them (Subdued theme, cover wall for the home screen, etc)

 

BTW, I don't think it matters but on the server side the local http port number is 8096 and the local https port number is 8920



#4 mranim8or OFFLINE  

mranim8or

    Advanced Member

  • Members
  • 40 posts
  • Local time: 10:49 PM

Posted 12 May 2019 - 05:17 PM

Nevermind, I got it! I went back in to set the startup behavior back to 'log in user automatically' and noticed under the advanced tab that the 'Connection' setting was set to my correct IP address, but I monkeyed with it anyways and found I could set it to 'Find Automatically'. I tried that and restarted and now everything is working great. When I went back in, the advanced tab still has the same IP address in it, but as long as it works!  Not sure if it was the act of setting it back to 'log in user automatically' or if it was the 'Find Automatically' setting, but something fixed it.  Thanks for your help!



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47589 posts
  • Local time: 04:49 PM

Posted 13 May 2019 - 10:43 AM

Glad you got it fixed up.

 

Thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users