Jump to content


Photo

Upgrade 4.1.1.0 suddenly doesn't work


  • Please log in to reply
33 replies to this topic

#1 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 11 May 2019 - 03:35 PM

I upgrade to the 4.1.1.0. all went ok.

 

Today suddenly i try to access from my iphone app and he say me to install the new version of the server?! (wtf? i thnk another new version) when i see that there wasn't any new version i tried to connect via browser but i have only a black screen.

Force shutdown and restart doesn't change anything.

I tried also to reainstall the 4.1.1.0 all the same.

 

My system: Qnap TS-653 PRO

fw: 4.3.6.0805

 

Any suggestion?


Edited by Caccamo, 11 May 2019 - 03:43 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 11 May 2019 - 03:52 PM

Hi there, can you please attach the emby server log? You can learn how to do that here:

https://emby.media/c...port-a-problem/

 

Thanks.



#3 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 12 May 2019 - 11:53 AM

meanwhile i try also to upgrade 4.1.1.0 installing the Beta, but nothing change...

 

here the logs

Attached Files


Edited by Caccamo, 12 May 2019 - 11:54 AM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 12 May 2019 - 12:06 PM

Is it possible you still have the old 3.x version installed running side by side? Perhaps that is what the iOS app is connecting to.



#5 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 12 May 2019 - 05:21 PM

those are the only app i have installed on my qnap.

 

and i repeat this happen suddenly after some day i upgraded to 4.1.1.0

 

 5cd88e460895e_Immagine.png



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 13 June 2019 - 01:14 PM

@Caccamo, can you please try the beta installation from our website:

 

https://emby.media/nas-server.html

 

Please let us know if this helps. Thanks.



#7 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 04:40 PM

Starts to be annoying....

its like more that one month that my emby doesn't work...

suddenly the problem before described disappeared but now i don't know if with new beta or not i have all my "new" films not identify. Also with manual identify doesn't work...

 

here the logs

 

@Luke

Attached Files



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 18 June 2019 - 04:56 PM

Starts to be annoying....

its like more that one month that my emby doesn't work...

suddenly the problem before described disappeared but now i don't know if with new beta or not i have all my "new" films not identify. Also with manual identify doesn't work...

 

here the logs

 

@Luke

 

@Caccamo this is a rollover log from the previous day. Can you please restart emby server, and then after startup has completed, please attach the latest log? thanks !



#9 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 05:58 PM

here.

 

@Luke

Attached Files

  • Attached File  Log.txt   138.7KB   3 downloads


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 18 June 2019 - 06:10 PM

here.

 

@Luke

 

Well this is different. Did you roll back the server version? If you did this, then you'll need to go to the Plugins tab in your server dashboard. Make a note of all plugins installed. Then use the plugin catalog to manually install compatible versions of every single one.

 

See how the server log is filled with all of these LoaderExceptions:

2019-06-18 23:55:58.898 Error App: LoaderException: Could not load file or assembly 'MediaBrowser.Model, Version=4.2.0.12, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified.

Once you roll back the plugins then those errors should go away.



#11 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 06:17 PM

i don't roll back my server version. 

 

 

@Caccamo, can you please try the beta installation from our website:

 

https://emby.media/nas-server.html

 

Please let us know if this helps. Thanks.

 

just after this message i installed the last beta aviable.

 

What i have to do with plugin?

@Luke


Edited by Caccamo, 18 June 2019 - 06:17 PM.


#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 18 June 2019 - 06:20 PM

Nothing. First you posted a log from 4.2.0.16, then you posted a log from 4.1.1. That's why i thought you rolled back.

 

Can you please restart emby server, and then after startup has completed, please attach the latest log? thanks !



#13 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 06:28 PM

ok this is so strange!!!

i checked and now i have the 4.1.1 ...

 

Wtf?! i have jsut installed the last beta. 



#14 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 06:33 PM

ok i reinstalled last beta. same problem that i can't identify the new film added.

 

here the logs

 

@Luke

Attached Files

  • Attached File  Log.txt   93.75KB   1 downloads


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 18 June 2019 - 06:40 PM

It's because all outgoing connections to all domains are failing:

2019-06-19 00:33:09.119 Error HttpClient: Error getting response from https://api.themoviedb.org/3/find/tt4975856?api_key=f6bd687ffa63cd282b6ff2c6877f2669&external_source=imdb_id
	*** Error Report ***
	Version: 4.2.0.17
	Command line: /share/CACHEDEV1_DATA/.qpkg/EmbyServer/system/EmbyServer.dll -programdata /share/CACHEDEV1_DATA/.qpkg/EmbyServer/programdata -ffdetect /share/CACHEDEV1_DATA/.qpkg/EmbyServer/bin/ffdetect -ffmpeg /share/CACHEDEV1_DATA/.qpkg/EmbyServer/bin/ffmpeg -ffprobe /share/CACHEDEV1_DATA/.qpkg/EmbyServer/bin/ffprobe -defaultdirectory /share/CACHEDEV1_DATA -updatepackage emby-server-qnap_{version}_x86_64.qpkg
	Operating system: Unix 4.2.8.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///share/CACHEDEV1_DATA/.qpkg/EmbyServer/system/System.Private.CoreLib.dll
	Processor count: 4
	Program data path: /share/CACHEDEV1_DATA/.qpkg/EmbyServer/programdata
	Application directory: /share/CACHEDEV1_DATA/.qpkg/EmbyServer/system
	System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: Network is unreachable ---> System.Net.Sockets.SocketException: Network is unreachable
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)

Do you have something that might be preventing emby server from accessing the internet? Like a firewall, security software, etc? Are you behind a vpn? 

 

If you can resolve this then you should be able to identify.



#16 Caccamo OFFLINE  

Caccamo

    Member

  • Members
  • 13 posts
  • Local time: 08:54 PM

Posted 18 June 2019 - 06:41 PM

i have my router like alwayse and i didn0t cahnge everything since one years....



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 18 June 2019 - 06:44 PM

OK, unfortunately I'm not sure what to say. I cannot tell you why your installation cannot access the internet. Most likely something is blocking the connection.



#18 kendling OFFLINE  

kendling

    Member

  • Members
  • 10 posts
  • Local time: 02:54 AM

Posted 03 September 2019 - 11:22 PM

I upgrade to the 4.1.1.0. all went ok.

 

Today suddenly i try to access from my iphone app and he say me to install the new version of the server?! (wtf? i thnk another new version) when i see that there wasn't any new version i tried to connect via browser but i have only a black screen.

Force shutdown and restart doesn't change anything.

I tried also to reainstall the 4.1.1.0 all the same.

 

My system: Qnap TS-653 PRO

fw: 4.3.6.0805

 

Any suggestion?

It's happen to me!

 

NAS: TS-428

SYS: QTS 4.3.6.1040

 

EmbyServer 4.1.1.0 can working.

 

4.2.x.x and 4.3.x.x beta both can't working.

 

Can't start it in App Center after upgrade.

 

It report "Couldn't find a valid ICU package installed on the system." when I start it from shell.

 

No logs found in log folder.

[/share/CACHEDEV1_DATA/.qpkg/EmbyServer] # ./system/EmbyServer
FailFast:
Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

   at System.Environment.FailFast(System.String)
   at System.Globalization.GlobalizationMode.GetGlobalizationInvariantMode()
   at System.Globalization.GlobalizationMode..cctor()
   at System.Globalization.CultureData.CreateCultureWithInvariantData()
   at System.Globalization.CultureData.get_Invariant()
   at System.Globalization.CultureInfo..cctor()
   at System.StringComparer..cctor()
   at System.AppDomain.InitializeCompatibilityFlags()
   at System.AppDomain.CreateAppDomainManager()
   at System.AppDomain.Setup(System.Object)
Aborted


Edited by kendling, 03 September 2019 - 11:24 PM.


#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138093 posts
  • Local time: 02:54 PM

Posted 04 September 2019 - 12:17 AM

 

It's happen to me!

 

NAS: TS-428

SYS: QTS 4.3.6.1040

 

EmbyServer 4.1.1.0 can working.

 

4.2.x.x and 4.3.x.x beta both can't working.

 

Can't start it in App Center after upgrade.

 

It report "Couldn't find a valid ICU package installed on the system." when I start it from shell.

 

No logs found in log folder.

[/share/CACHEDEV1_DATA/.qpkg/EmbyServer] # ./system/EmbyServer
FailFast:
Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

   at System.Environment.FailFast(System.String)
   at System.Globalization.GlobalizationMode.GetGlobalizationInvariantMode()
   at System.Globalization.GlobalizationMode..cctor()
   at System.Globalization.CultureData.CreateCultureWithInvariantData()
   at System.Globalization.CultureData.get_Invariant()
   at System.Globalization.CultureInfo..cctor()
   at System.StringComparer..cctor()
   at System.AppDomain.InitializeCompatibilityFlags()
   at System.AppDomain.CreateAppDomainManager()
   at System.AppDomain.Setup(System.Object)
Aborted

 

Hi, are you using Docker on QNAP?



#20 kendling OFFLINE  

kendling

    Member

  • Members
  • 10 posts
  • Local time: 02:54 AM

Posted 04 September 2019 - 02:06 AM

Hi, are you using Docker on QNAP?

Thanks for your reply,

 

No, I'm using qpkg package.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users