Jump to content


Photo

Default to resume on back


  • Please log in to reply
37 replies to this topic

#1 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 25 April 2019 - 05:10 PM

Done a search and can’t find anybody saying anything about this, but if I play a movie and get say 30 minutes through and hit back, it takes me back to the movie page with play selected again, I’ve lost count of the number of times myself or a member of the family has hit play again only for it to restart from the start.

Can the default behaviour from backing out of a movie be to automatically select “resume” instead of “play” (or whatever the default logic is currently) when hitting back and you’re not at the end of the film. Personally I think this makes a lot of sense.

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 05:05 AM

Posted 26 April 2019 - 01:22 AM

Hi, what Emby app are you referring to?



#3 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 04:25 AM

Nvidia shield

#4 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2279 posts
  • Local time: 10:05 AM
  • LocationLutterworth, England, UK

Posted 26 April 2019 - 06:50 AM

For me it goes back to resume not play using Android TV app on the Shield.

Krs

Mark

Edited by maegibbons, 26 April 2019 - 06:51 AM.

  • CBers likes this

#5 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 06:53 AM

For me it goes back to resume not play using Android TV app on the Shield.
Krs
Mark


Doesn’t for me, hit play on a fresh movie, watch a bit and then hit back the highlighted option is play and not resume. Same behaviour on all 3 shields in the house,

#6 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2279 posts
  • Local time: 10:05 AM
  • LocationLutterworth, England, UK

Posted 26 April 2019 - 07:36 AM

Doesn’t for me, hit play on a fresh movie, watch a bit and then hit back the highlighted option is play and not resume. Same behaviour on all 3 shields in the house,

So is the resume button the 1st or 2nd button on the line. For me resume is 1st and has the focus.

Krs

Mark

#7 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 07:39 AM

So is the resume button the 1st or 2nd button on the line. For me resume is 1st and has the focus.
Krs
Mark


Resume is first in the list, but play (second in list) has the focus. Weird how it works as expected for you, I am running the beta versions of the player, although this has always been the behaviour for me as long as I can remember.

#8 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2279 posts
  • Local time: 10:05 AM
  • LocationLutterworth, England, UK

Posted 26 April 2019 - 07:44 AM

I am running on 1.7.16g

Its always been like this for me.

Krs

Mark8fece709031f650c97297346f7d7dd9f.jpg
  • CBers likes this

#9 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45316 posts
  • Local time: 05:05 AM

Posted 26 April 2019 - 08:23 AM

Yes, this is already how the app is designed.  Not sure why it isn't working for you.



#10 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 08:42 AM

Yes, this is already how the app is designed.  Not sure why it isn't working for you.


https://cloud.fizzya...j7rHLep7kXSS7TJ

I’m using CEC if that makes any difference?

#11 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2279 posts
  • Local time: 10:05 AM
  • LocationLutterworth, England, UK

Posted 26 April 2019 - 08:51 AM

Looking at your video it seems to go back to the detail screen twice. Whats the scene change warning all about?

Think you should try it just with shield controller.

Krs

Mark

#12 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 09:30 AM

Looking at your video it seems to go back to the detail screen twice. Whats the scene change warning all about?
Think you should try it just with shield controller.
Krs
Mark


I think that’s just the TV doing a resolution/frequency change, all our shields are set up the same and all use CEC and exhibit the same issue with the back button, this is the only try that does the flicker though, I’ve seen it on other sources during a frequency/resolution change, just ignore it, it’s the TV.

Just tried with the shield controller and it goes back to play rather than resume when pressing back,

#13 denz OFFLINE  

denz

    Advanced Member

  • Members
  • 2106 posts
  • Local time: 05:05 PM
  • LocationPerth, Australia

Posted 26 April 2019 - 10:07 AM

I just seen the video and that is odd It always goes to resume after watching videos here using Android TV. Not just Android TV it does that in all the apps after you play resume is selected.

Edited by denz, 26 April 2019 - 10:14 AM.


#14 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 11:33 AM

Here’s a second video exhibiting the same problem on a different shield box and tv in the house. Incidentally, this works as expected with TV shows, just doesn’t work with movies.

https://cloud.fizzya...BzZzYgTstaE9TPB

#15 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 26 April 2019 - 05:09 PM

Is everybody reporting this as working seeing the correct behaviour when playing a video, then pressing back?

You’re seeing it go back to the movie selection screen with play and resume options showing with resume selected?

The only way it auto selects resume for me is if I exit back out to the movie selection list screen, select the same movie and then I get both options with resume selected.

Just pressing back while the movie is playing shows both options but play (the second option) is the one that is selected.

@Luke can you look at the code for this and see if anything pops out at you, as you can see from my two videos I don’t see the intended behaviour, in both cases I played a video from fresh and only the play option was available when the movie was started, pressing back during playback has the effect shown in the videos.

#16 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45316 posts
  • Local time: 05:05 AM

Posted 27 April 2019 - 09:05 AM

If you have auto refresh rate switching turned on, try turning it off just to see if it behaves differently.



#17 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 27 April 2019 - 09:38 AM

If you have auto refresh rate switching turned on, try turning it off just to see if it behaves differently.


Nope. Same behaviour, defaults to play when pressing back.

#18 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15254 posts
  • Local time: 10:05 AM
  • LocationKent, England.

Posted 27 April 2019 - 12:17 PM

Is everybody reporting this as working seeing the correct behaviour when playing a video, then pressing back?


Late to the game, but yes, that's how it has always worked.

Have you tried uninstalling and re-installing the app, just in case something is awry with the set up?

#19 fizzyade OFFLINE  

fizzyade

    Advanced Member

  • Members
  • 130 posts
  • Local time: 10:05 AM

Posted 27 April 2019 - 12:23 PM

Late to the game, but yes, that's how it has always worked.
Have you tried uninstalling and re-installing the app, just in case something is awry with the set up?

No difference, same behaviour, play is selected.

#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 05:05 AM

Posted 27 April 2019 - 01:20 PM

Can you go over an example?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users