Jump to content


Photo

subtitle problems

subtitle language und

  • Please log in to reply
6 replies to this topic

#1 DancingMan OFFLINE  

DancingMan

    Member

  • Members
  • 26 posts
  • Local time: 01:49 AM

Posted 17 April 2019 - 12:52 PM

I recently added a few TV shows on my emby server and I'm having an issue with the subtitles. The files have English subtitles, but they are mislabeled inside the mp4 files. If I look at the files using ffprobe, the subtitle and audio streams show "und" next to them (my other files show "eng" for the audio & subtitle streams). Emby seems to go on the assumption that the "und" audio streams are English, and uses them automatically. For the subtitles though, since emby does not see English subtitle streams, it follows through with the server's subtitle settings and tries to download subtitles from online. I have two questions:

1) is there a way to set emby to assume "und" language subtitle streams are English just like it does with "und" audio streams?

2) how can I set those subtitle streams in the mp4 files to have the correct label of "eng"?

Thanks

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:49 AM

Posted 17 April 2019 - 12:53 PM

 

 

Emby seems to go on the assumption that the "und" audio streams are English

Hi, actually we don't do this.



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:49 AM

Posted 17 April 2019 - 12:54 PM

 

 

 is there a way to set emby to assume "und" language subtitle streams are English

No, but it's not a bad idea.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:49 AM

Posted 17 April 2019 - 12:54 PM

 

 

how can I set those subtitle streams in the mp4 files to have the correct label of "eng"?

 

@daedalus do you know of a good embedded track editor for mp4?



#5 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1182 posts
  • Local time: 06:49 AM

Posted 17 April 2019 - 03:09 PM

No, but it's not a bad idea.

even if it would be correct in the majority of cases, i don't agree, you should not assume something "undefined" to be a specific language

 

2) how can I set those subtitle streams in the mp4 files to have the correct label of "eng"?

emby relies on the tags set in you media files and it seems that your media is not correctly tagged, search for software like mp4box to edit mp4 language tags


  • Luke likes this

#6 Meherbt OFFLINE  

Meherbt

    Newbie

  • Members
  • 2 posts

Posted 21 April 2019 - 07:20 AM

Hi you need to add .eng bfore the file extension "filename.eng.srt"

#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142356 posts
  • Local time: 12:49 AM

Posted 21 April 2019 - 12:05 PM

Hi you need to add .eng bfore the file extension "filename.eng.srt"

 

Yes to be recognized as English, that is correct.







Also tagged with one or more of these keywords: subtitle, language, und

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users