Jump to content

DTS/5.1 music (wav format) playing too fast


Tontin.UK
 Share

Recommended Posts

Tontin.UK

Hi All

 

I previously had emby server and emby(WMC) running on win 7 machine all worked fine , PC was getting old (10yr +) so i have changed to a new I7 win10 computer with good graphics SSD drives etc etc,

 

I installed emby server and am using emby theatre with my media , all is ok, all videos are playing ok and dts in films is fine over the optical pass through to my AMP. However I have a large 5.1/DTS collection which sounds great when played through the surround sound and worked perfectly with the old set up but the new plays the 5.1/DTS files too fast, peter Gabriel sledgehammer plays back like he is part chipmunk.

 

Is this a known issue , or is there something I can do to correct this. on the old setup I had Sharky installed that handled all the decoding.

Link to comment
Share on other sites

Guest asrequested

Where did you download the app from? And can you share an example file with which you have this problem?

Link to comment
Share on other sites

Tontin.UK

Okay Luke yes the speakers are set to 5.1, once again I can only reiterate that ET is playing surround sound from films all ok, I would also add that on my old set up (as above) dts/5.1 music played perfectly.

 

okay Doofus as far ai I recall I followed the link from this forum, it states it is version 3.0.6 I have tried to attach a file Peter Gabriel - 02 - Sledgehammer.wav for you to try .

 

when in the settings of ET you select which formats you are passing through although dts etc are ticked there is not a specific one for dts audio, I wonder if ET does not pass it through as it is not in its list therefore just letting win 10 handle it, if I was to install something like sharky would it solve the problem??

Edited by Tontin.UK
Link to comment
Share on other sites

Guest asrequested

External codecs have no involvement. I'll test your file, tonight. In the meantime, when playing, pull up the stats and post a screenshot of them.

Link to comment
Share on other sites

Tontin.UK

erm there is no stats for nerds, when playing a video there is a cog icon etc, but not when playing a dts audio file

Link to comment
Share on other sites

Guest asrequested

I'm just waking up to the fact this is audio only. So it'll be played as a music file, and the audio pass through options I don't think, apply. Do you have upmix enabled? I'm thinking one config is stepping on the other. I'll know more when I test it, later. It should be left to be decoded, with no other options.

Link to comment
Share on other sites

Guest asrequested

What kind of library are you using for this? Music video? Music? I just noticed you're using optical, so we're gonna have to figure a way to bitstream it. Letting mpv decode it to pcm won't work. Im really interested to experiment with this.

Link to comment
Share on other sites

Tontin.UK

originally i set it up as a 'Music' folder, i have added another one pointing to same folder as 'Movie' to see if thats makes a difference, i have also taken off upmixing as you suggested. cant as yet check if the changes have worked people are watching the tv at the moment , will try soon.

Link to comment
Share on other sites

Tontin.UK

i have made it in 3 types music, movie and lastly music video it behaves the same in all,dont get me wrong they play in 5.1 but just a tad too fast not by much but enough to take a singers voice up an octive, if your not sure listen to his voice normally and you will hear the difference.

Link to comment
Share on other sites

Guest asrequested

I'll check it tonight. When you play it from the movie library, what do the stats say? Can you post a screenshot?

Link to comment
Share on other sites

Guest asrequested

Hmmmm... curious. I wonder if because it's a WAV file, it's expecting raw audio??? I'll dig into it, tonight.

Link to comment
Share on other sites

Guest asrequested

OK, it's the file. More specifically, there's probably something wrong with the time stamp. If I play it in mpv and disable audio passthrough so it's decoded by the software, it plays correctly. It's only when I bitstream it, that the timing is off. And I can hear that it's inconsistent (he's more squeaky in some parts, than others). I tried bitstreaming the audio in VLC. It plays at the correct speed, but there are a lot of errors in the stream. The audio drops out many times. I imagine you ripped it from a video? If yes, try using mkvtoolnix. Just load it up, and deselect the video. It'll remux it to mka. 

 

I was going to suggest that you try disabling dts in Theater, but that won't work for you. You're using optical, which doesn't support 5.1 PCM. You can't use HDMI? It's much better. 

 

Anyway, It's not the software, it's the file. If you want, I can show you how to configure mpv to re-encode the audio in your WAV files to AC3 as you play it (on the fly). You won't know the difference, and you'll still be able to bitstream dts. I actually do this for all my music and music videos.

Edited by Doofus
Link to comment
Share on other sites

Tontin.UK

i appreciate all your help......but to put a spanner in the works that song was just an example i have about 500 dts audio songs and they all used to play fine, they are not ripped from videos but proper dts audio albums just stored on my HD, does this change things because surely the same would have occured on the old set up. HDMI is not an option the av reciever is getting old (too old probs) but does not have hdmi.

Link to comment
Share on other sites

Guest asrequested

That doesn't change the issue. Maybe how they were ripped is what caused this. So I think your best option (for theater), is let mpv re-encode them to AC3 on the fly. This way, they'll just play.

Link to comment
Share on other sites

Tontin.UK

lets just say someone (many people probably) ripped them and then erm they were downloaded so they would have been ripped by different machines and software all over the globe.

Link to comment
Share on other sites

Guest asrequested

Lol... understood. But that gives it even more likely hood of error. Certainly of variation. It could be old standards that aren't readily supported when passed through. Mpv is built on ffmpeg, and can correctly decode it. And if you had HDMI, you could just do that. But as you have optical, you need compressed streams like dts and ac3. So I'm offering you the ac3 option.

Link to comment
Share on other sites

Guest asrequested

Actually, the closest I seem to be able to get, is converting all DTS to AC3. The profile doesn't appear to be sensitive enough to be limited to only WAV files. It gets enabled, generally. I had the same issue with audio codecs. But in that case I could use the name. There's no option for that with files. I would need ["file-format-name"]

Link to comment
Share on other sites

Tontin.UK

you lost me there a bit, i did play myself, vlc plays all my dts songs fine right speed etc, i turned off pass through in ET and got no sound, installed shark007 advanced codecs and with no passthrough in ET I now get sound at right speed just not dts, turn passthrough back on in ET and back to dts but faster speed. such a shame it doesn't work out the box where it did with the old setup.

Link to comment
Share on other sites

Guest asrequested

you lost me there a bit, i did play myself, vlc plays all my dts songs fine right speed etc, i turned off pass through in ET and got no sound, installed shark007 advanced codecs and with no passthrough in ET I now get sound at right speed just not dts, turn passthrough back on in ET and back to dts but faster speed. such a shame it doesn't work out the box where it did with the old setup.

 

Yeah sorry, I guess I was thinking 'out loud'. With mpv, you can use profiles to do specific things. As I mentioned, mpv is built on ffmpeg, so there're a massive amount of things you can do with it. And I was just saying that the profile I was using to convert the dts to ac3, specifically for wav files, isn't actually working specifically for wav files, when it should (I may report this to the mpv devs). 

 

As for Shark, it can't be used with Theater. It uses directshow filters, which are entirely different.

 

The reason you get no sound when disabling dts in Theater, is as I explained. mpv can and will decode the audio, correctly. But then the audio is fully decompressed, and is raw audio (PCM). It has a much larger bandwidth, which optical cables don't support. So, no data passes down the optical cable. My solution was to have mpv decode it to raw audio, then re-encode it to AC3, which is supported by optical cables. But am unable to specify it to your wav audio files. The only other option is to let mpv convert all of your dts audio to AC3. You may balk at the idea, but I very much doubt that you could tell the difference. I can make this happen for you, very easily.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...