Jump to content


Photo

Issues with # - Z



  • Please log in to reply
32 replies to this topic

#1 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 02:44 PM

This one is going to be hard to describe (cant find a logical pattern)

 

Dealing with the # - Z (Ae thing) view options on the side of the display.  Music and Music Video Libraries (Movies and TV libraries work fine)

 

At first i figured you have certain letters or key words at the beginning of titles being ignored?  I selected S in that list.  It returned "A Static Lullaby".  It took me to the beginning of the A's.  Not S.

 

So i tried a title that would have the word The in the beginning if it.  Went right to the T's.

 

It appears the the great majority of the other letter selections took me to a title that i have [brackets] in the beginning.  So i think maybe the [ isnt ignored when it needs to be?

 

I dont know like i said i couldn't find a pattern to this to be more helpful.

 

But theater / android tv / android cell app / xbox app display as expected...

 

Thanks In Advance!

 

(i was browsing by artist)


Edited by skidmarks, 31 March 2019 - 02:49 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131281 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 02:48 PM

Hi, the A-Z picker is based on the sort title, so by default, unless you've customized it, the sort title for "A Static Lullaby" is "Static Lullaby".

 

So this would be expected behavior. However it should not take you to the beginning of the A's, but rather the S's. Does that answer your question?

 

How does this compare to the web app? Thanks.



#3 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45299 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 03:13 PM

Make sure your items don't have sort titles filled in that include words like "A" and "The"...



#4 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 03:23 PM

Hi, the A-Z picker is based on the sort title, so by default, unless you've customized it, the sort title for "A Static Lullaby" is "Static Lullaby".

 

So this would be expected behavior. However it should not take you to the beginning of the A's, but rather the S's. Does that answer your question?

 

How does this compare to the web app? Thanks.

Luke the web app and every other app that i use works as expected.  There is something off in the roku app.



#5 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 03:32 PM

Make sure your items don't have sort titles filled in that include words like "A" and "The"...

Yah, i dont do anything special.  I let the magic of emby do its thing!  Just seems as though maybe something got missed in an ignore these XYZ flags in these two library types?

 

I'll play around with it some more and see if i can come up with a better pattern.



#6 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45299 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 03:37 PM

Did you confirm that your items don't have anything in the "Sort Title" field in the metadata manager?



#7 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 03:51 PM

Did you confirm that your items don't have anything in the "Sort Title" field in the metadata manager?

 

Geeze, i sure hope not!  I'll go poke, but not prod, metadata manager and see what comes out!  It does only seem to be an issue with roku though.

 

Maybe i'll find a 00111001 00110001 00110001 in there somewhere!

 

Return with what i findout...

 

Thanks as always!



#8 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 04:54 PM

Metadata manager is not a good solution for this issue.  If i was looking for a specific file it would be wonderful.  But for a seek and destroy mission not so easy.  At one time, maybe MB2, i could go in with sql and read db files.  It was SUPER handy.  Guess thats not an option any longer?  I closed down the server and tried to open the library file and its locked.  Being able to search that db would make what you suggested much easier (if i recall correctly).

 

Oh well, i was just pointing out a issue i was experiencing, possibly a known or verifiable issue.

 

Thanks for the replies!  Keep on keeping on.... 


Edited by skidmarks, 31 March 2019 - 09:51 PM.


#9 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 10:10 PM

Did you confirm that your items don't have anything in the "Sort Title" field in the metadata manager?

 

I remembered what i need to do...  I have a full spread sheet now of my media library.  So i found "ForcedSortName"  is blank for every file in both my music and music video libraries.  "SortName"  obviously is populated.  I did not see "Sort Title" where i looked.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131281 posts
  • Local time: 05:33 PM

Posted 31 March 2019 - 10:14 PM

Actually the metadata manager would be the right tool for the job here. 



#11 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 12:27 AM

Actually the metadata manager would be the right tool for the job here. 

Then  i don't know what i am supposed to be looking for.  I understand i need to see if "Sort Title" is populated in a music or a music video file.  Thats not a simple thing to do in metadata manager when you don't know which file or files might be causing said issue.  Talking about checking thousands of files one at a time (if i understand correctly).  "Sort Title" is not viewable in the appdata db?

 

It's just a little suspicious that roku is the only app i am having this problem with, but If you think it is a local issue, enough said.

 

Thanks for your time!  Have a great week...


Edited by skidmarks, 01 April 2019 - 12:29 AM.


#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131281 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 12:30 AM

I'm not assuming it's a local issue to you, I'm only asking questions at this point. So you're saying it does differ from the web app?



#13 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 12:33 AM

Yes Luke, the web app / android tv / android phone / xbox / theater do no have said issue...



#14 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45299 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 11:27 AM

It works okay on Android TV...?



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131281 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 11:44 AM

So are you saying the titles are sorted differently on Roku?



#16 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45299 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 11:46 AM

So are you saying the titles are sorted differently on Roku?

 

No, I think they are sorted properly.  It is just the letter jump that is confused.  We're looking at it but I just wanted to be sure it wasn't also a problem on Android TV.



#17 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 01:29 PM

No, I think they are sorted properly.  It is just the letter jump that is confused.  We're looking at it but I just wanted to be sure it wasn't also a problem on Android TV.

Just verified...  1.6.99g

 

Flawless!


Edited by skidmarks, 02 April 2019 - 12:39 AM.


#18 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45299 posts
  • Local time: 05:33 PM

Posted 01 April 2019 - 01:50 PM

Thanks.  We're looking into it.



#19 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 24 May 2019 - 11:37 AM

Guys still an issue for me...  Is the status on hold / in work / awaiting parts / or ready for inspection?

 

Enjoy the day! 



#20 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 349 posts
  • Local time: 05:33 PM

Posted 24 May 2019 - 11:50 AM

Looked around and see this:  https://emby.media/c...pps-except-web/

 

So if i'm running the latest server beta this problem is actually resolved?


Edited by skidmarks, 24 May 2019 - 12:38 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users