Jump to content


Photo

Update /emby/Users/{userid}/ return error

api users

  • Please log in to reply
2 replies to this topic

#1 gumma OFFLINE  

gumma

    Newbie

  • Members
  • 3 posts
  • Local time: 04:26 PM

Posted 12 March 2019 - 07:51 AM

when I updated the user on my local using api http://localhost:809.../Users/{userid}

Then it will return "Object reference not set to an instance of an object."

 

I don't know what happen here.

Please Help

Thanks



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45403 posts
  • Local time: 06:56 AM

Posted 12 March 2019 - 09:43 AM

Hi.  The pattern to update any Emby object via the api is to first pull that object down with a "get" call, then change what you want and re-submit the entire item for the update.

 

Thanks.



#3 gumma OFFLINE  

gumma

    Newbie

  • Members
  • 3 posts
  • Local time: 04:26 PM

Posted 13 March 2019 - 06:57 AM

HI

 

I have tried this again when I get the object thats fine. It returned the bytes data and then same data post with user id on (/emby/Users/{userid}) API it returned the same error

"Object reference not set to an instance of an object."

 

if I passed the json data then it retuned the another error:

 

"Type definitions should start with a '{', expecting serialized type 'UserConfiguration', got string starting with: PlayDefaultAudioTrack"


Edited by gumma, 13 March 2019 - 07:11 AM.






Also tagged with one or more of these keywords: api, users

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users