Jump to content


Photo

Live TV Stopping

HDHomeRun Live TV Intermittent Stream

  • Please log in to reply
10 replies to this topic

#1 accarshop OFFLINE  

accarshop

    Member

  • Members
  • 22 posts
  • Local time: 04:42 AM

Posted 11 March 2019 - 09:24 PM

Have run into an issue with LiveTV playback.  Will have LiveTV playing when it will just stop playing with the screen showing just a black playback window or going back to the guide.  I'm also noticing pauses in playback.  I can add the following;

 

  • Doesn't appear to matter if it is a browser playback or Android TV. 
  • Doesn't appear to be load related.  Happens with just one stream or multiple streams.
  • Doesn't appear to be channel specific.
  • Video quality/Stream rates doesn't appear to be a factor. 
  • When it happens it tends to, but not always, affect all active streams.  Had TV running in the living room and my office.  Can hear the TV in the living room from my office.  When my office stream dropped, so did the living room on a couple occasions.
  • Browser versions (Chrome or Firefox) doesn't make a difference.
  • When the steam stops the connection to the HDHomeRun tuner is released.
  • Streaming the channel in VLC directly from the HDHomeRun device doesn't pause or drop.  Tested from workstations and the Emby server.
  • Can't say exactly when this started happening but if I had to guess I'd say it was in the last 4/5 betas ago.  Not saying Emby is at fault.  Just to get a timing.  I'm pretty good about applying updates withing 24-48 hours of them being pulled to the server (auto-update).

 

My setup is pretty simple.  Running 4.1.0.13 beta on an older i7 whitebox Win2016 server and using a 4 channel HDHomeRun (HDHR5-4US) tuner.  Mostly a standard install.

 

The attached logs (emby and last stream that shut down) are for a stoppage at 18:51:49.  It is curious, at 18:51:48.872 I see the first stop entry with a 'q' command being sent to ffmpeg as if I had stopped the playback on my own.  But I did not. 

 

2019-03-11 18:51:48.872 Info HttpServer: HTTP POST http://EMBYSRVR:8096...Playing/Stopped. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

 

2019-03-11 18:51:48.873 Info App: ProcessRun 'StreamTranscode 8974c2': Stopping ffmpeg process with q command for H:\Transcode\transcoding-temp\4b0391ca594d452af36a9799a217054d0.ts

 

I've checked the Windows Event logs to see if Windows captured anything.  There aren't any entries around the time the stream stopped but I do see 2 critical alerts at roughly the same time each day (screenshots below).

 

Any assistance would be greatly appreciated.  

 

5c8707e43ace1_AppAlert.png

5c8707f8ecc1f_RuntimeAlert.png

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131774 posts
  • Local time: 05:42 AM

Posted 12 March 2019 - 02:29 AM

Hi, if you click on the details of that event viewer entry, what does it have there?



#3 cayars OFFLINE  

cayars

    Advanced Member

  • Alpha Testers
  • 2928 posts
  • Local time: 05:42 AM

Posted 12 March 2019 - 02:37 AM

This is confusing.  You have Hauppauge software installed yet you said you are using an HDHomeRun which are different companies.

 

Can you confirm exactly which tuner you are using?



#4 accarshop OFFLINE  

accarshop

    Member

  • Members
  • 22 posts
  • Local time: 04:42 AM

Posted 12 March 2019 - 10:42 AM

Cayars, I understand your confusion.  I do not have any Hauppauge based tuners installed.  Never have.  This server was a clean install just for Emby and the only tuners I've used have been HDHomeRuns. 

Don't believe the error is related to the LiveTV streaming stoppage but included it to err on the side of being thorough. 

 

Luke, here are the details on the 2 recurring events.  As I said, roughly once a day and not around the time the LiveTV streams stop.

 

  System
    - Provider
      [ Name] Application Error
    - EventID 1000
      [ Qualifiers] 0
      Level 2       Task 100       Keywords 0x80000000000000     - TimeCreated
      [ SystemTime] 2019-03-12T03:55:03.654567300Z
      EventRecordID 5529       Channel Application       Computer EMBYSRVR       Security
- EventData
      HauppaugeWindowsProvider.exe       1.0.0.0       f83dd824       KERNELBASE.dll       10.0.14393.2791       5c5a43dc       e0434352       000db152       6bc       01d4d8875eece1b8       I:\Emby_Server-Data\Emby-Server\system\HauppaugeWindowsProvider.exe       C:\Windows\System32\KERNELBASE.dll       80b45710-eb32-4ec5-9f4b-29a92584b4e6

 

 

  System
    - Provider
      [ Name] .NET Runtime
    - EventID 1026
      [ Qualifiers] 0
      Level 2       Task 0       Keywords 0x80000000000000     - TimeCreated
      [ SystemTime] 2019-03-12T03:55:03.188414000Z
      EventRecordID 5528       Channel Application       Computer EMBYSRVR       Security
- EventData
      Application: HauppaugeWindowsProvider.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.FileLoadException

Edited by accarshop, 12 March 2019 - 04:40 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131774 posts
  • Local time: 05:42 AM

Posted 13 March 2019 - 01:32 AM

@accarshop

 

That event viewer entry is from discovery attempts to search for hauppauge, devices, for instance if you used the tuner detection when adding a tuner. It's nothing to worry about.

 

Regarding streams stopping, since you're running the beta server, please continue to test new betas and report your results. thanks.


  • cayars likes this

#6 accarshop OFFLINE  

accarshop

    Member

  • Members
  • 22 posts
  • Local time: 04:42 AM

Posted 13 March 2019 - 07:55 PM

Luke,

 

I wondered if what I'm experiencing is the same as being reported by the IPTV users.  From your answer, it sounds like it.  Am letting the betas apply as they come in.  Will report if I see a change in behavior.  Incidentally, it persists in 4.1.0.14.

 

Have a good one.


Edited by accarshop, 13 March 2019 - 07:56 PM.


#7 accarshop OFFLINE  

accarshop

    Member

  • Members
  • 22 posts
  • Local time: 04:42 AM

Posted 22 March 2019 - 04:12 PM

As an update, things have improved after deploying v4.1.0.16 beta.  Seeing occasional pauses in playback and it will still stop periodically but a fraction of what I saw before.  Also seeing improvement in some of the recorded tv playback.  I do hope for a bit more improvement but am happy with the progress and thank you for your efforts.  



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131774 posts
  • Local time: 05:42 AM

Posted 23 March 2019 - 12:09 AM

Thanks for the feedback.



#9 accarshop OFFLINE  

accarshop

    Member

  • Members
  • 22 posts
  • Local time: 04:42 AM

Posted 18 April 2019 - 03:14 PM

All,

 

I like Emby a LOT and anxious to see where the product goes in the future but there is a factor (one's spouse) that I think many of us have to consider when using Emby or any product.  My wife just wants it to work.  She doesn't want to have to work at being able to watch TV or a show/movie.  Happy wife, happy life.  Unhappy wife, well, lets leave that alone for now.

 

For a bit now we've had challenges with Emby. 

 

As of version 4.1.0.25 beta live TV playback is back to stopping all the time and my wife has gotten frustrated to the point she isn't watching live TV now.  On my PC I've taken to using Emby for the guide and then using VLC to stream the station I want directly from the HDHomeRun tuner.  It works fine but isn't something my wife has the patience to do.

 

If the live TV issue was the only problem happening I don't believe my wife would be as touchy but we are also seeing playback issues with any with anything that has DTS audio.  This accounts for a lot of our content and I see others have commented about.  On my server transcoding for DTS seems to outrun my server so we get momentary pauses (~10 sec) in the playback.  It makes enjoying a show difficult.  I've managed to reduce the frustration with transcoding by installing VLC on our Shield and setting Emby to use an external player.  It isn't as clean or pretty but at least playback is consistent again.

 

Any assistance on clearing this up will be GREATLY appreciated.


Edited by accarshop, 18 April 2019 - 03:17 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131774 posts
  • Local time: 05:42 AM

Posted 18 April 2019 - 04:15 PM

Hi, can we please look at a new example with server & ffmpeg logs? thanks.



#11 abc OFFLINE  

abc

    Newbie

  • Members
  • 1 posts
  • Local time: 11:42 AM

Posted 09 May 2019 - 11:40 AM

Hi, can we please look at a new example with server & ffmpeg logs? thanks.

Hi

Running IPTV-m3u playlist.

I had the same problem, the Live TV always stopped around 10 minutes, hovewer when i made a new playlist and removed links with .m3u8 ending, the Live TV now works 100%. 


Edited by abc, 09 May 2019 - 11:42 AM.






Also tagged with one or more of these keywords: HDHomeRun, Live TV, Intermittent, Stream

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users