Jump to content

Weird problem with port forwarding


Recommended Posts


I'm running emby on 218+ with Linksys ea8500.


emby worked great out of the box when playing locally, however when I looked into remote access, I ran into problems.


I could not access the server remotely, so obviously like recommended, I had to port forward. I have done that before so I'm familiar with it.

So I open the port in the router and remote access works. However, local playback is now crippled. It constantly buffers or won't play at all.

If I remove the port forwarding in the router, local playback works again.

I have tried port forwarding the default 8096 port and also other different port numbers. Same result. Local playback is crippled.  


Does anyone know what problem could be? To me this looks to be some kind of port conflict. Local vs remote.. I don't know.



Link to comment
Share on other sites


I'm forwarding port 443 and port 80 to my synology.
There, I have setup a reverse proxy and a virtual host.


the virtual host is listening to port 80 and redirecting / rewriting to https (443).
Then, the reverse proxy will do the rest and forwargind locally to emby on port 8096

it looks like this for my setup:

Portforwarding on the Router:

Reverse Proxy Settings in Synology:

Webstation Virutal Host settings.

.htaccess file in the virtual host

This setup works perfectly fine for me.
It allows me, that I can connect emby only through https - with a let's encrypt certificate even if I try to connect with http - it will switch to https.
I haven't noticed any issues / diiferences between remote connection and local connection.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...