Jump to content

Enable hardware acceleration on FreeBSD


Duffyx

Recommended Posts

krzysik

Hello, I installed FreeNAS-11.3-U5 on FreeBSD 11.3-RELEASE-p14 amd64. With Emby server installed. To transcode the video I inserted the GTX 1660 super card. I downloaded the driver from https://www.nvidia.pl/Download/driverResults.aspx/184675/pl This is where the problems begin for me; ( Could someone show me step by step how to install the graphics driver in this system?

I downloaded the driver, unpacked the zipped file. In the first step, he gets an error with the "make install" command.

sh: cc: not found
make: "/usr/share/mk/bsd.compiler.mk" line 147: Unable to determine compiler type for CC=cc.  Consider setting COMPILER_TYPE.

I have installed the gcc package (pkg install gcc). The error is the same all the time.

Link to comment
Share on other sites

bbartlomiej

Hey - few hints:

  • if this is new installation, move to TrueNAS 12.x since this is current, FreeNAS is decomissioned
  • for general help with FreeBSD driver installation - try FreeBSD forums
  • for general help with driver installation specifically in TrueNAS - try TrueNAS forums

When you have that figured out, come back here and we can try enable HW acceleration with Emby.

I'm gonna go through the same path with the Quadro I'm waiting for, but I may end up just starting a Linux VM inside TrueNAS and pass through the PCI ID of my GPU inside. That would be a shame though.

  • Like 1
Link to comment
Share on other sites

krzysik
28 minutes ago, bbartlomiej said:

Hey - few hints:

  • ... That would be a shame though.

 

Thank you very much for the tips. I updated to TrueNAS-12.0-U8.

I follow the instructions on the Nvidia website.

http://us.download.nvidia.com/XFree86/FreeBSD-x86_64/495.46/README/installdriver.html

I get an error with make makefile.

In the freeBSD forums I wrote and looked for answers. Unfortunately, nothing helps me.

Link to comment
Share on other sites

bbartlomiej

TrueNAS is a tailored for purpose distribution of FreeBSD - not all guides will work there without additional steps. You will have more luck asking on TrueNAS forums.
Plus - have you read your error message? It actually points you to some fix.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...